Loading ...
Sorry, an error occurred while loading the content.

Re: dbext - keep asking user password in pgsql

Expand Messages
  • Gregory Margo
    ... You can put the password in environment variable PGPASSWORD. http://www.postgresql.org/docs/8.4/interactive/libpq-envars.html --
    Message 1 of 8 , Sep 30, 2009
    View Source
    • 0 Attachment
      On Tue, Sep 29, 2009 at 10:10:46PM -0400, David Fishburn wrote:
      > >> Probably, that's just a minor bug in a function "DB_PGSQL_execSql" - it
      > >> constructs command to be executed as
      > > Hi Mikalai, thanks for your answer. Your tip was very useful to point
      > > me in a good direction.
      > > Turns out there is no easy way to pass a password as a command line
      > > parameter to psql. You can use -W switch to make psql ask for it but
      > > you will have to type it as a second step. I finally created a
      > > ~/.pgpass file as suggested here [1] and now dbext is not asking the
      > > pass anymore.
      >
      > Correct. PGSQL does not allow passwords to be set from the command
      > line which is the reason dbext does not provide it.


      You can put the password in environment variable PGPASSWORD.
      http://www.postgresql.org/docs/8.4/interactive/libpq-envars.html


      --
      +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
      Gregory H. Margo
      gmargo at yahoo/com, gmail/com, pacbell/net; greg at margofamily/org

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_use" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    Your message has been successfully submitted and would be delivered to recipients shortly.