Loading ...
Sorry, an error occurred while loading the content.

Re: Copy wxhen deleting text

Expand Messages
  • David Fishburn
    ... For other conveniences as well you may be interested in my plugin: YankRing.vim : Maintains a history of previous yanks and deletes
    Message 1 of 7 , Aug 2, 2009
    • 0 Attachment
      > I am a big fan of VIM, I use it all the time.
      > There is just one thing that I found anoying :
      > Vim copy text in the clipboard whenever I delete something.
      >
      > This is annoying when you have copied some text and want to paste it
      > at several places, while deleting other text : You clipboard get
      > spammed with the content of what you delete !

      For other conveniences as well you may be interested in my plugin:

      YankRing.vim : Maintains a history of previous yanks and deletes
      http://www.vim.org/scripts/script.php?script_id=1234

      HTH,
      Dave

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_use" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • Tony Mechelynck
      ... Personally I use ... YMMV. Best regards, Tony. -- Cinemuck, n.: The combination of popcorn, soda, and melted chocolate which covers the floors of movie
      Message 2 of 7 , Aug 14, 2009
      • 0 Attachment
        On 02/08/09 16:01, Raphael Jolivet wrote:
        >
        > Hi,
        >
        > I am a big fan of VIM, I use it all the time.
        > There is just one thing that I found anoying :
        > Vim copy text in the clipboard whenever I dlete something.
        >
        > This is anoying when you have copied some text and wwant to paste it
        > at several places, while delteing other text : You clipboard get
        > spammed with the content of what you delete !
        >
        > Do you know if it is possible to disable this behavior ?
        >
        > TH

        Sure, see:
        :help 'clipboard'
        :help 'guioptions'

        Personally I use
        :set cb=html,exclude=cons\\\|linux go=gimrLTtc
        YMMV.

        Best regards,
        Tony.
        --
        Cinemuck, n.:
        The combination of popcorn, soda, and melted chocolate which
        covers the floors of movie theaters.
        -- Rich Hall, "Sniglets"

        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_use" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • KKde
        ... In help clipboard , I see the html name isnot under recognized names for this option. Can you please explain what your setting does?? Sharat
        Message 3 of 7 , Aug 14, 2009
        • 0 Attachment
          >
          > Personally I use
          >         :set cb=html,exclude=cons\\\|linux go=gimrLTtc
          > YMMV.
          >

          In help 'clipboard' , I see the html name isnot under recognized names
          for this option. Can you please explain what your setting does??

          Sharat

          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_use" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        • Tony Mechelynck
          ... This setting answers the OP s question mostly by what it does _not_ include (_not_ unnamed and _not_ autoselect). Please go back and read :help
          Message 4 of 7 , Aug 15, 2009
          • 0 Attachment
            On 15/08/09 08:45, KKde wrote:
            >
            >
            >>
            >> Personally I use
            >> :set cb=html,exclude=cons\\\|linux go=gimrLTtc
            >> YMMV.
            >>
            >
            > In help 'clipboard' , I see the html name isnot under recognized names
            > for this option. Can you please explain what your setting does??
            >
            > Sharat

            This setting answers the OP's question mostly by what it does _not_
            include (_not_ unnamed and _not_ autoselect). Please go back and read
            ":help 'clipboard'".


            Regards,
            Tony.
            --
            Cinemuck, n.:
            The combination of popcorn, soda, and melted chocolate which
            covers the floors of movie theaters.
            -- Rich Hall, "Sniglets"

            --~--~---------~--~----~------------~-------~--~----~
            You received this message from the "vim_use" maillist.
            For more information, visit http://www.vim.org/maillist.php
            -~----------~----~----~----~------~----~------~--~---
          Your message has been successfully submitted and would be delivered to recipients shortly.