Loading ...
Sorry, an error occurred while loading the content.

Re: getting vim to recognize haXe files

Expand Messages
  • Charles Campbell
    ... 1. remove it from .vim/ftplugin -- your haxe.vim file is a syntax file and doesn t belong in .vim/ftplugin. 2. read :help new-filetype I use option C,
    Message 1 of 2 , Jul 30 1:05 PM
    • 0 Attachment
      TheLonelyStar wrote:
      > Hi,
      >
      > I would like to code haXe (www.haxe.org) using vim.
      > Here is a syntax file:
      > http://www.cactusflower.org/haxe.vim
      >
      > since I am unsure what to do with it, I copied it into ~/.vim/ftplugins and
      > ~/.vim/syntax
      >
      > But vim does not recognize haxe (*.hx) files. What do I have to do?
      >

      1. remove it from .vim/ftplugin -- your haxe.vim file is a syntax file
      and doesn't belong in .vim/ftplugin.

      2. read :help new-filetype

      I use option C, myself.

      Regards,
      Chip Campbell


      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_use" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    Your message has been successfully submitted and would be delivered to recipients shortly.