Loading ...
Sorry, an error occurred while loading the content.

Very dark grey line background

Expand Messages
  • TheLonelyStar
    Hi, To change the highlighting of the current line, I have this in my .vimrc: hi CursorLine guisp=NONE gui=NONE guifg=NONE guibg=darkgrey ctermfg=NONE
    Message 1 of 10 , Jul 10, 2009
    • 0 Attachment
      Hi,

      To change the highlighting of the current line, I have this in my .vimrc:
      hi CursorLine guisp=NONE gui=NONE guifg=NONE guibg=darkgrey
      ctermfg=NONE ctermbg=darkgrey term=NONE cterm=NONE

      My problem is, that darkgrey is not dark enough for me!
      I tried doing something like this:
      ... ctermbg=#0f0f0f ...
      but vim does not accept that (E421: Color name or number not recognized:
      ctermbg=#000f00 term=NONE cterm=NONE)

      What can I do?
      Thanks!
      Nathan
      --
      View this message in context: http://www.nabble.com/Very-dark-grey-line-background-tp24423729p24423729.html
      Sent from the Vim - General mailing list archive at Nabble.com.


      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_use" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • TheLonelyStar
      Hi, To change the highlighting of the current line, I have this in my .vimrc: hi CursorLine guisp=NONE gui=NONE guifg=NONE guibg=darkgrey ctermfg=NONE
      Message 2 of 10 , Jul 10, 2009
      • 0 Attachment
        Hi,

        To change the highlighting of the current line, I have this in my .vimrc:
        hi CursorLine guisp=NONE gui=NONE guifg=NONE guibg=darkgrey
        ctermfg=NONE ctermbg=darkgrey term=NONE cterm=NONE

        My problem is, that darkgrey is not dark enough for me!
        I tried doing something like this:
        ... ctermbg=#0f0f0f ...
        but vim does not accept that (E421: Color name or number not recognized:
        ctermbg=#000f00 term=NONE cterm=NONE)

        What can I do?
        Thanks!
        Nathan
        --
        View this message in context: http://www.nabble.com/Very-dark-grey-line-background-tp24423746p24423746.html
        Sent from the Vim - General mailing list archive at Nabble.com.


        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_use" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • bill lam
        try black or brightblack HTH -- regards, ==================================================== GPG key 1024D/4434BAB3 2008-08-24 gpg --keyserver subkeys.pgp.net
        Message 3 of 10 , Jul 10, 2009
        • 0 Attachment
          try black or brightblack

          HTH

          --
          regards,
          ====================================================
          GPG key 1024D/4434BAB3 2008-08-24
          gpg --keyserver subkeys.pgp.net --recv-keys 4434BAB3

          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_use" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        • geoffrey.wood@thomsonreuters.com
          ... You could try defining your own colour in rgb.txt (:help rgb.txt), for example, I use this: 0 96 255 BobBlue Then in my colour scheme definition I use
          Message 4 of 10 , Jul 10, 2009
          • 0 Attachment
            > To change the highlighting of the current line, I have this
            > in my .vimrc:
            > hi CursorLine guisp=NONE gui=NONE guifg=NONE guibg=darkgrey
            > ctermfg=NONE ctermbg=darkgrey term=NONE cterm=NONE
            >
            > My problem is, that darkgrey is not dark enough for me!
            > I tried doing something like this:
            > ... ctermbg=#0f0f0f ...
            > but vim does not accept that (E421: Color name or number not
            > recognized:
            > ctermbg=#000f00 term=NONE cterm=NONE)
            >
            > What can I do?
            > Thanks!
            > Nathan

            You could try defining your own colour in rgb.txt (:help rgb.txt),
            for example, I use this:

            0 96 255 BobBlue

            Then in my colour scheme definition I use it in the normal way like this:

            hi SpecialKey guifg=BobBlue ctermbg=DarkBlue ctermfg=White

            However, there are two problems with this approach, perhaps others can help or
            provide a better solution?

            1) rgb.txt apparently has to be in $VIMRUNTIME and not vimfiles\, so can get lost
            when you upgrade. I couldn't find a better place to define the colour. (The help
            suggests defining its location using rgb_file for FVWM configuration
            files (:helpgrep rgb_file). I haven't looked into it in great detail.)

            2) As you can see some colours don't work in some terminals, my colour
            doesn't work in XP cmd.exe terminal vim. I suppose ymmv depending on which
            terminal you're using, and whether it can handle your particular colour.

            regards,
            Geoff





            Thomson Financial Limited, a Thomson Reuters company, is a company incorporated under the laws of England and Wales (registered number 2012235) having its registered office and address for service at Aldgate House, 33 Aldgate High Street, London, EC3N 1DL, UK.
            This e-mail is for the sole use of the intended recipient and contains information that may be privileged and/or confidential. If you are not an intended recipient, please notify the sender by return e-mail and delete this e-mail and any attachments.

            --~--~---------~--~----~------------~-------~--~----~
            You received this message from the "vim_use" maillist.
            For more information, visit http://www.vim.org/maillist.php
            -~----------~----~----~----~------~----~------~--~---
          • TheLonelyStar
            ... Hi, black is to dark (my normal background is black). brightblack is not recognized -- View this message in context:
            Message 5 of 10 , Jul 10, 2009
            • 0 Attachment
              bill lam wrote:
              >
              >
              > try black or brightblack
              >
              > HTH
              >
              > --
              > regards,
              > ====================================================
              > GPG key 1024D/4434BAB3 2008-08-24
              > gpg --keyserver subkeys.pgp.net --recv-keys 4434BAB3
              >
              > >
              >
              >

              Hi,

              black is to dark (my normal background is black). brightblack is not
              recognized
              --
              View this message in context: http://www.nabble.com/Very-dark-grey-line-background-tp24423746p24424116.html
              Sent from the Vim - General mailing list archive at Nabble.com.


              --~--~---------~--~----~------------~-------~--~----~
              You received this message from the "vim_use" maillist.
              For more information, visit http://www.vim.org/maillist.php
              -~----------~----~----~----~------~----~------~--~---
            • bill lam
              ... I also use black background. If you use xterm you can customise colors inside .Xresources file vim Tip #1384: XTerm256 color names for console vim --
              Message 6 of 10 , Jul 10, 2009
              • 0 Attachment
                On Fri, 10 Jul 2009, TheLonelyStar wrote:
                > black is to dark (my normal background is black). brightblack is not
                > recognized

                I also use black background. If you use xterm you can customise colors
                inside .Xresources file

                vim Tip #1384: XTerm256 color names for console vim

                --
                regards,
                ====================================================
                GPG key 1024D/4434BAB3 2008-08-24
                gpg --keyserver subkeys.pgp.net --recv-keys 4434BAB3

                --~--~---------~--~----~------------~-------~--~----~
                You received this message from the "vim_use" maillist.
                For more information, visit http://www.vim.org/maillist.php
                -~----------~----~----~----~------~----~------~--~---
              • Matt Wozniski
                ... If you use a 256-color terminal emulator that s properly set up (xterm using TERM=xterm-256color for instance) you get an extra 232 colors to play with, 24
                Message 7 of 10 , Jul 10, 2009
                • 0 Attachment
                  On Fri, Jul 10, 2009 at 4:45 AM, TheLonelyStar wrote:
                  >
                  >
                  > Hi,
                  >
                  > To change the highlighting of the current line, I have this in my .vimrc:
                  >  hi CursorLine guisp=NONE   gui=NONE      guifg=NONE guibg=darkgrey
                  > ctermfg=NONE   ctermbg=darkgrey term=NONE cterm=NONE
                  >
                  > My problem is, that darkgrey is not dark enough for me!
                  > I tried doing something like this:
                  > ... ctermbg=#0f0f0f ...
                  > but vim does not accept that (E421: Color name or number not recognized:
                  > ctermbg=#000f00 term=NONE cterm=NONE)
                  >
                  > What can I do?

                  If you use a 256-color terminal emulator that's properly set up (xterm
                  using TERM=xterm-256color for instance) you get an extra 232 colors to
                  play with, 24 of which just make up a greyscale ramp - for instance,

                  if &t_Co == 256
                  hi CursorLine ctermbg=233
                  endif

                  You might also find the CSApprox plugin useful.

                  ~Matt

                  --~--~---------~--~----~------------~-------~--~----~
                  You received this message from the "vim_use" maillist.
                  For more information, visit http://www.vim.org/maillist.php
                  -~----------~----~----~----~------~----~------~--~---
                • Tony Mechelynck
                  ... rgb.txt has to be in $VIMRUNTIME for _Windows_ gvim. Unix gvim can IIUC use the rgb.txt installed by your Unix/Linux distribution in some X11 directory.
                  Message 8 of 10 , Jul 11, 2009
                  • 0 Attachment
                    On 10/07/09 11:13, geoffrey.wood@... wrote:
                    >
                    >> To change the highlighting of the current line, I have this
                    >> in my .vimrc:
                    >> hi CursorLine guisp=NONE gui=NONE guifg=NONE guibg=darkgrey
                    >> ctermfg=NONE ctermbg=darkgrey term=NONE cterm=NONE
                    >>
                    >> My problem is, that darkgrey is not dark enough for me!
                    >> I tried doing something like this:
                    >> ... ctermbg=#0f0f0f ...
                    >> but vim does not accept that (E421: Color name or number not
                    >> recognized:
                    >> ctermbg=#000f00 term=NONE cterm=NONE)
                    >>
                    >> What can I do?
                    >> Thanks!
                    >> Nathan
                    >
                    > You could try defining your own colour in rgb.txt (:help rgb.txt),
                    > for example, I use this:
                    >
                    > 0 96 255 BobBlue
                    >
                    > Then in my colour scheme definition I use it in the normal way like this:
                    >
                    > hi SpecialKey guifg=BobBlue ctermbg=DarkBlue ctermfg=White
                    >
                    > However, there are two problems with this approach, perhaps others can help or
                    > provide a better solution?
                    >
                    > 1) rgb.txt apparently has to be in $VIMRUNTIME and not vimfiles\, so can get lost
                    > when you upgrade. I couldn't find a better place to define the colour. (The help
                    > suggests defining its location using rgb_file for FVWM configuration
                    > files (:helpgrep rgb_file). I haven't looked into it in great detail.)
                    >
                    > 2) As you can see some colours don't work in some terminals, my colour
                    > doesn't work in XP cmd.exe terminal vim. I suppose ymmv depending on which
                    > terminal you're using, and whether it can handle your particular colour.
                    >
                    > regards,
                    > Geoff

                    rgb.txt has to be in $VIMRUNTIME for _Windows_ gvim. Unix gvim can IIUC
                    use the rgb.txt installed by your Unix/Linux distribution in some X11
                    directory.

                    But even so, rgb.txt, like the hexadecimal #RRGGBB colour values,
                    applies only to the GUI. In Console Vim, there is a plugin for
                    256-colour cterm, which IIUC can compute the "nearest" cterm colour from
                    your GUI setting, see Matt Wozniski's post in the parallel thread. If
                    your cterm has fewer colours than that, I don't think it can display
                    gray hues other than blak, darkgray, lightgray and white, so if you want
                    something else as a bg in an 8/16 colour term I suppose you should use
                    darkred, darkblue, darkgreen or brown.


                    Best regards,
                    Tony.
                    --
                    hundred-and-one symptoms of being an internet addict:
                    68. Your cat always puts viruses on your dogs homepage

                    --~--~---------~--~----~------------~-------~--~----~
                    You received this message from the "vim_use" maillist.
                    For more information, visit http://www.vim.org/maillist.php
                    -~----------~----~----~----~------~----~------~--~---
                  • Dominique Pellé
                    ... Specifying colors as #0f0f0f is only for the GUI (guifbg=#0f0f0f) but can t be done for the terminal since ctermgui= requires a color name or color index.
                    Message 9 of 10 , Jul 12, 2009
                    • 0 Attachment
                      TheLonelyStar wrote:

                      > Hi,
                      >
                      > To change the highlighting of the current line, I have this in my .vimrc:
                      >  hi CursorLine guisp=NONE   gui=NONE      guifg=NONE guibg=darkgrey
                      > ctermfg=NONE   ctermbg=darkgrey term=NONE cterm=NONE
                      >
                      > My problem is, that darkgrey is not dark enough for me!
                      > I tried doing something like this:
                      > ... ctermbg=#0f0f0f ...
                      > but vim does not accept that (E421: Color name or number not recognized:
                      > ctermbg=#000f00 term=NONE cterm=NONE)
                      >
                      > What can I do?
                      > Thanks!
                      > Nathan


                      Specifying colors as #0f0f0f is only for the GUI (guifbg=#0f0f0f) but can't
                      be done for the terminal since ctermgui= requires a color name or color index.

                      So what can you do? I highly recommend using the CSApprox plugin, or
                      the guicolorscheme plugin so that colors in the terminal are set to colors
                      specified for the GUI in your colorscheme. It requires a 256-color terminal
                      (which can often be turned on by simply setting export TERM=xterm-256color
                      in your ~/.bashrc, and/or by adding this line in your ~/.vimrc:

                      set t_Co=256

                      Setting up CSApprox plugin, or guicolorscheme plugin is further described
                      in wikia:

                      http://vim.wikia.com/wiki/Using_GUI_color_settings_in_a_terminal

                      Above link discusses pros & cons of both these plugins (CSApprox vs
                      guicolorscheme)

                      Cheers
                      -- Dominique

                      --~--~---------~--~----~------------~-------~--~----~
                      You received this message from the "vim_use" maillist.
                      For more information, visit http://www.vim.org/maillist.php
                      -~----------~----~----~----~------~----~------~--~---
                    • Charlie Kester
                      ... If you d rather not load yet another plugin every time you start up vim, and are comfortable porting software, then you should have a look at rgb2xterm:
                      Message 10 of 10 , Jul 12, 2009
                      • 0 Attachment
                        On Sun 12 Jul 2009 at 06:08:56 PDT Dominique Pell? wrote:
                        >
                        >Specifying colors as #0f0f0f is only for the GUI (guifbg=#0f0f0f) but can't
                        >be done for the terminal since ctermgui= requires a color name or color index.
                        >
                        >So what can you do? I highly recommend using the CSApprox plugin, or
                        >the guicolorscheme plugin so that colors in the terminal are set to
                        >colors specified for the GUI in your colorscheme.

                        If you'd rather not load yet another plugin every time you start up vim,
                        and are comfortable porting software, then you should have a look at
                        rgb2xterm:

                        http://www.frexx.de/xterm-256-notes/

                        Given an RGB tuple, it returns the closest 256-color value and the
                        corresponding color index used by xterm and other 256 color terminals.

                        To explore possible color combinations, I like to use one of the many
                        online colorscheme tools available for web designers.
                        http://colorschemedesigner.com/ is my current favorite.

                        --~--~---------~--~----~------------~-------~--~----~
                        You received this message from the "vim_use" maillist.
                        For more information, visit http://www.vim.org/maillist.php
                        -~----------~----~----~----~------~----~------~--~---
                      Your message has been successfully submitted and would be delivered to recipients shortly.