Loading ...
Sorry, an error occurred while loading the content.

Wildcard not available in sfind path?

Expand Messages
  • wilson.m.liu@convergys.com
    Hi, When I set a path by :set path=... and use sfind to edit one file in the directory, wildcard in the file name seems not working. That is to say, when I
    Message 1 of 5 , Jun 1, 2009
    • 0 Attachment

      Hi,
      When I set a path by ":set path=..." and use "sfind" to edit one file in the directory, wildcard in the file name seems
      not working. That is to say, when I type ":sf Sample.txt" for example, it opens the file successfully. However, when I
      type ":sf Sam*.*"(This pattern uniquely refers to one file), it amazingly shows an error displaying no match. I am puzzled
      whether we can use wildcard in sf path.
      I am using Vim 7.2 on Windows XP.

      Thanks,
      Wilson
      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_use" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---

    • John Beckett
      ... Yes you can use a wildcard in :find and :sfind, however, it searches directories in the path option, so the first step ... John
      Message 2 of 5 , Jun 1, 2009
      • 0 Attachment
        wilson.m.liu wrote:
        > When I set a path by ":set path=..." and use "sfind" to edit
        > one file in the directory, wildcard in the file name seems
        > not working. That is to say, when I type ":sf Sample.txt" for
        > example, it opens the file successfully. However, when I type
        > ":sf Sam*.*"(This pattern uniquely refers to one file), it
        > amazingly shows an error displaying no match. I am puzzled
        > whether we can use wildcard in sf path.

        Yes you can use a wildcard in :find and :sfind, however, it
        searches directories in the 'path' option, so the first step
        would be (the second shows where set, if it has been):

        :set path?
        :verbose set path?

        John


        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_use" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • wilson.m.liu@convergys.com
        ... Hi, I am not clear about what :set path? mean. Would you please make some explanation? Thanks, Wilson
        Message 3 of 5 , Jun 1, 2009
        • 0 Attachment
          vim_use@... wrote on 06/01/2009 03:35:13 PM:

          >
          > wilson.m.liu wrote:
          > > When I set a path by ":set path=..." and use "sfind"
          to edit
          > > one file in the directory, wildcard in the file name seems
          > > not working. That is to say, when I type ":sf Sample.txt"
          for
          > > example, it opens the file successfully. However, when I type
          > > ":sf Sam*.*"(This pattern uniquely refers to one file),
          it
          > > amazingly shows an error displaying no match. I am puzzled
          > > whether we can use wildcard in sf path.
          >
          > Yes you can use a wildcard in :find and :sfind, however, it
          > searches directories in the 'path' option, so the first step
          > would be (the second shows where set, if it has been):
          >
          >   :set path?
          >   :verbose set path?
          >
          > John
          >
          >
          > >
          Hi,

          I am not clear about what ":set path?" mean. Would you please make some explanation?

          Thanks,
          Wilson
          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_use" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---

        • John Beckett
          wilson.m.liu@convergys.com ... That s a command you type in Vim (starting with the colon). ... John --~--~---------~--~----~------------~-------~--~----~ You
          Message 4 of 5 , Jun 1, 2009
          • 0 Attachment
            wilson.m.liu@...
            > I am not clear about what ":set path?" mean.

            That's a command you type in Vim (starting with the colon).

            It will display the value of the 'path' option. See:

            :help 'path'
            :help :set
            :help :find

            John


            --~--~---------~--~----~------------~-------~--~----~
            You received this message from the "vim_use" maillist.
            For more information, visit http://www.vim.org/maillist.php
            -~----------~----~----~----~------~----~------~--~---
          • Tony Mechelynck
            ... In case you haven t yet got your answer (which is unclear according to the present state of this mail thread), I think that on Windows, Vim does its own
            Message 5 of 5 , Jun 4, 2009
            • 0 Attachment
              On 01/06/09 09:12, wilson.m.liu@... wrote:
              >
              > Hi,
              > When I set a path by ":set path=..." and use "sfind" to edit one file in
              > the directory, wildcard in the file name seems
              > not working. That is to say, when I type ":sf Sample.txt" for example,
              > it opens the file successfully. However, when I
              > type ":sf Sam*.*"(This pattern uniquely refers to one file), it
              > amazingly shows an error displaying no match. I am puzzled
              > whether we can use wildcard in sf path.
              > I am using Vim 7.2 on Windows XP.
              >
              > Thanks,
              > Wilson

              In case you haven't yet got your answer (which is unclear according to
              the present state of this mail thread), I think that on Windows, Vim
              does its own globbing (unlike on Unix where wildcards other than ** are
              expanded by the shell). This means that wildcard expansion by Vim on
              Windows is done according to Vim rules, which are perhaps more unixy
              than what is customary on Windows. For instance, on Unix *.* doesn't
              mean "anything at all" (as it does on Dos/Windows), it means "anything
              with at least one actual dot in it". To get "anything at all", the Unix
              wildcard is just *

              Best regards,
              Tony.
              --
              VIRGO (Aug 23 - Sept 22)
              Learn something new today, like how to spell or how to count to
              ten without using your fingers. Be careful dressing this
              morning. You may be hit by a car later in the day and you
              wouldn't want to be taken to the doctor's office in some of
              that old underwear you own.

              --~--~---------~--~----~------------~-------~--~----~
              You received this message from the "vim_use" maillist.
              For more information, visit http://www.vim.org/maillist.php
              -~----------~----~----~----~------~----~------~--~---
            Your message has been successfully submitted and would be delivered to recipients shortly.