Loading ...
Sorry, an error occurred while loading the content.

Re: Align doesn 't work

Expand Messages
  • Charles E. Campbell, Jr.
    ... Sounds like you ve got the AlignMaps plugin in two different places; on the other hand, its got code in it to prevent double loading. I suggest that you
    Message 1 of 4 , Mar 1, 2009
    • 0 Attachment
      andalou wrote:
      > On Mar 1, 8:30 am, "Charles E. Campbell, Jr."
      > <drc...@...> wrote:
      >
      >> andalou wrote:
      >>
      >>> I want to align the following text having the blank as a separator:
      >>>
      >>> m n p
      >>> a $1 $2
      >>> bc €3 €4
      >>> def €5 €6
      >>> gh €7 €8
      >>>
      >>> but it aligns from the third row downwards.
      >>>
      >> You'll want to read
      >>
      >> :help g:align-option for how to align with multibyte characters, and
      >> you'll want to read
      >> :help alignctrl-separators for alignment restrictions concerning spaces
      >> in separators, and
      >> :help alignmap-tsp for a map that works around that constraint.
      >>
      >> In short:
      >>
      >> :let g:Align_xstrlen= 1
      >> V...\tsp
      >>
      >> Regards,
      >> Chip Campbell
      >>
      >
      > Many thanks Dr Chip, it works.
      > I was using an old version of Align. I updated it to the new version
      > but whenever I want to edit a file I'm getting the following messages:
      >
      > ---------------------
      > Error detected while processing C:\Programmi\Vim\vimfiles\plugin
      > \AlignMapsPlugin.
      > vim:
      > line 68:
      > E227: mapping already exists for \a?
      > line 69:
      > E227: mapping already exists for \a,
      > line 70:
      > E227: mapping already exists for \a<
      > line 71:
      > E227: mapping already exists for \a=
      > line 72:
      > E227: mapping already exists for \abox
      > ...........
      > line 158:
      > E227: mapping already exists for \tt
      > ---------------------
      >
      Sounds like you've got the AlignMaps plugin in two different places; on
      the other hand, its got code in it to prevent double loading.
      I suggest that you remove all the Align/AlignMaps plugin components and
      then re-install it.

      Regards,
      Chip Campbell


      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_use" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    Your message has been successfully submitted and would be delivered to recipients shortly.