Loading ...
Sorry, an error occurred while loading the content.

Re: problem in setting font on gvim(opened remotely)

Expand Messages
  • Tony Mechelynck
    ... Are you using a Windows gvim (running on your local machine) or a Unix gvim (running on the remote server)? I suspect the latter. They won t accept the
    Message 1 of 2 , Feb 4 1:38 AM
    • 0 Attachment
      On 04/02/09 08:24, neeraj wrote:
      > I am facing problems in changing the fonts inside gvim, that is opened
      > from a remote linux server on Windows xp using Xservers(ReflectionX,
      > Xming).
      >
      > :set guifont=* doesn't show me a selection menu.
      > Moreover :set guifont=Fixedsys:b doesn't seem to change anything.
      >
      > Can you tell me the reasons and factors on which this thing depends.
      >
      > Thanks
      > Neeraj Mangal

      Are you using a "Windows gvim" (running on your local machine) or a
      "Unix gvim" (running on the remote server)? I suspect the latter. They
      won't accept the same format for the 'guifont' option: on Unix/Linux
      versions of gvim there are four possible incompatible formats for
      'guifont', all different from the Windows format, and each gvim accepts
      only one of these formats; some Unix/Linux versions don't even accept
      ":set gfn=*". See http://vim.wikia.com/wiki/Setting_the_font_in_the_GUI
      for details.

      Best regards,
      Tony.
      --
      It is impossible to travel faster than light, and certainly not
      desirable, as one's hat keeps blowing off.
      -- Woody Allen

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_use" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    Your message has been successfully submitted and would be delivered to recipients shortly.