Loading ...
Sorry, an error occurred while loading the content.

Re: vim bug report: *i_CTRL-\_CTRL-O*

Expand Messages
  • Ben Fritz
    ... Yes, you did. The cursor isn t moving, the temporary indentation was removed, because the line is blank. See :help autoindent . If you don t like this,
    Message 1 of 2 , Feb 2, 2009
    • 0 Attachment
      On Feb 1, 8:57 pm, Sean <maxiangji...@...> wrote:
      > Problem:  *i_CTRL-\_CTRL-O* moves the cursor, while the vim help says:
      >
      > CTRL-O          execute one command, return to Insert mode   *i_CTRL-O*
      > CTRL-\ CTRL-O   like CTRL-O but don't move the cursor        *i_CTRL-
      > \_CTRL-O*
      >
      > To reproduce:
      >
      > (1) gvim -u NONE -U NONE --noplugin
      > (2) :set autoindent
      > (3) i<Tab>xxx
      > (4) <Enter>
      > (5) <C-\><C-O>
      >
      > Now the cursor moves to the first column, instead of staying where it
      > was.
      >
      > Do I miss something?
      >

      Yes, you did.

      The cursor isn't moving, the temporary indentation was removed,
      because the line is blank. See :help 'autoindent'. If you don't like
      this, see http://vim.wikia.com/wiki/Prevent_autoindent_from_removing_indentation.
      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_use" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    Your message has been successfully submitted and would be delivered to recipients shortly.