Loading ...
Sorry, an error occurred while loading the content.

Re: History completion

Expand Messages
  • Dominique Pelle
    ... Type... ... ... and check whether the command line history feature is enabled in your vim. If enabled, you should see +cmdline_hist. If not, you should
    Message 1 of 5 , Feb 1, 2009
    • 0 Attachment
      Vincent Birebent wrote:

      > On my Macvim however nothing appears what ever arrows is pushed...

      Type...

      :version

      ... and check whether the command line history feature is enabled
      in your vim. If enabled, you should see +cmdline_hist. If not,
      you should see -cmdline_hist

      See also :help cmdline-history

      Regards
      -- Dominique

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_use" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • Vincent Birebent
      Hi Dominique, Thx! ... It fixed the issue (yet it seems most mysterious to me, since it s the default value). ...Didn t solve my echo problem though... ;)
      Message 2 of 5 , Feb 1, 2009
      • 0 Attachment
        Hi Dominique,

        Thx!

        I had +cmdline_hist set up, but after I typed:

        :set history=20

        It fixed the issue (yet it seems most mysterious to me, since it's the
        default value).

        ...Didn't solve my "echo" problem though... ;)

        Regards,

        Vincent.

        Le Feb 1, 2009 à 5:54 PM, Dominique Pelle a écrit :

        > Type...
        >
        > :version
        >
        > ... and check whether the command line history feature is enabled
        > in your vim. If enabled, you should see +cmdline_hist. If not,
        > you should see -cmdline_hist
        >
        > See also :help cmdline-history
        >
        > Regards
        > -- Dominique



        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_use" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • Tony Mechelynck
        ... Maybe you were running in compatible mode, where the default is zero? Best regards, Tony. -- ARTHUR: Charge! [They all charge with swords drawn towards
        Message 3 of 5 , Feb 1, 2009
        • 0 Attachment
          On 01/02/09 18:59, Vincent Birebent wrote:
          > Hi Dominique,
          >
          > Thx!
          >
          > I had +cmdline_hist set up, but after I typed:
          >
          > :set history=20
          >
          > It fixed the issue (yet it seems most mysterious to me, since it's the
          > default value).

          Maybe you were running in 'compatible' mode, where the default is zero?

          Best regards,
          Tony.
          --
          ARTHUR: Charge!
          [They all charge with swords drawn towards the RABBIT. A tremendous
          twenty
          second fight with Peckinpahish shots and borrowing heavily also on the
          Kung Fu and karate-type films ensues, in which some four KNIGHTS are
          comprehensively killed.]
          ARTHUR: Run away! Run away!
          "Monty Python and the Holy Grail" PYTHON (MONTY)
          PICTURES LTD

          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_use" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        Your message has been successfully submitted and would be delivered to recipients shortly.