Loading ...
Sorry, an error occurred while loading the content.
 

History completion

Expand Messages
  • Tony Mechelynck
    References: In-Reply-To: Content-Type: text/plain;
    Message 1 of 5 , Feb 1, 2009
      References: <FA6196AC-0057-4EC7-831F-188C85EAAEA7@...>
      In-Reply-To: <FA6196AC-0057-4EC7-831F-188C85EAAEA7@...>
      Content-Type: text/plain; charset=ISO-8859-1; format=flowed
      Content-Transfer-Encoding: 7bit

      On 01/02/09 13:35, Vincent Birebent wrote:
      [...]
      > Also (probably noobish question): in vim after I type ":" I can get
      > last entered commands by using down arrow (and after ":m" all former
      > commands begining with ":m"...). Doesn't seems to work on Macvim... Am
      > I wrong?
      >
      > Thanks.

      Here (on Linux) :<Down> gives a beep but :<Up> gives the latest
      ex-command-line (and repeatedly hitting <Up> goes "up" in history). It's
      only after using <Up> one or more times that I can use <Down> to go to
      successively more recent completions (and finally to my colon ot to
      whichever text I typed before triggering the completion).

      Best regards,
      Tony.
      --
      Experience is that marvelous thing that enables you recognize a mistake
      when you make it again.
      -- F. P. Jones

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_use" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • Vincent Birebent
      Hi Tony, You re right, and I have exactly the same than you on regular vim. On my Macvim however nothing appears what ever arrows is pushed... Cheers, Vincent.
      Message 2 of 5 , Feb 1, 2009
        Hi Tony,

        You're right, and I have exactly the same than you on regular vim.

        On my Macvim however nothing appears what ever arrows is pushed...

        Cheers,

        Vincent.

        Le Feb 1, 2009 à 5:12 PM, Tony Mechelynck a écrit :
        >>
        > Here (on Linux) :<Down> gives a beep but :<Up> gives the latest
        > ex-command-line (and repeatedly hitting <Up> goes "up" in history).
        > It's
        > only after using <Up> one or more times that I can use <Down> to go to
        > successively more recent completions (and finally to my colon ot to
        > whichever text I typed before triggering the completion).
        >
        > Best regards,
        > Tony.
        > --
        > Experience is that marvelous thing that enables you recognize a
        > mistake
        > when you make it again.
        > -- F. P. Jones
        >
        > >



        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_use" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • Dominique Pelle
        ... Type... ... ... and check whether the command line history feature is enabled in your vim. If enabled, you should see +cmdline_hist. If not, you should
        Message 3 of 5 , Feb 1, 2009
          Vincent Birebent wrote:

          > On my Macvim however nothing appears what ever arrows is pushed...

          Type...

          :version

          ... and check whether the command line history feature is enabled
          in your vim. If enabled, you should see +cmdline_hist. If not,
          you should see -cmdline_hist

          See also :help cmdline-history

          Regards
          -- Dominique

          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_use" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        • Vincent Birebent
          Hi Dominique, Thx! ... It fixed the issue (yet it seems most mysterious to me, since it s the default value). ...Didn t solve my echo problem though... ;)
          Message 4 of 5 , Feb 1, 2009
            Hi Dominique,

            Thx!

            I had +cmdline_hist set up, but after I typed:

            :set history=20

            It fixed the issue (yet it seems most mysterious to me, since it's the
            default value).

            ...Didn't solve my "echo" problem though... ;)

            Regards,

            Vincent.

            Le Feb 1, 2009 à 5:54 PM, Dominique Pelle a écrit :

            > Type...
            >
            > :version
            >
            > ... and check whether the command line history feature is enabled
            > in your vim. If enabled, you should see +cmdline_hist. If not,
            > you should see -cmdline_hist
            >
            > See also :help cmdline-history
            >
            > Regards
            > -- Dominique



            --~--~---------~--~----~------------~-------~--~----~
            You received this message from the "vim_use" maillist.
            For more information, visit http://www.vim.org/maillist.php
            -~----------~----~----~----~------~----~------~--~---
          • Tony Mechelynck
            ... Maybe you were running in compatible mode, where the default is zero? Best regards, Tony. -- ARTHUR: Charge! [They all charge with swords drawn towards
            Message 5 of 5 , Feb 1, 2009
              On 01/02/09 18:59, Vincent Birebent wrote:
              > Hi Dominique,
              >
              > Thx!
              >
              > I had +cmdline_hist set up, but after I typed:
              >
              > :set history=20
              >
              > It fixed the issue (yet it seems most mysterious to me, since it's the
              > default value).

              Maybe you were running in 'compatible' mode, where the default is zero?

              Best regards,
              Tony.
              --
              ARTHUR: Charge!
              [They all charge with swords drawn towards the RABBIT. A tremendous
              twenty
              second fight with Peckinpahish shots and borrowing heavily also on the
              Kung Fu and karate-type films ensues, in which some four KNIGHTS are
              comprehensively killed.]
              ARTHUR: Run away! Run away!
              "Monty Python and the Holy Grail" PYTHON (MONTY)
              PICTURES LTD

              --~--~---------~--~----~------------~-------~--~----~
              You received this message from the "vim_use" maillist.
              For more information, visit http://www.vim.org/maillist.php
              -~----------~----~----~----~------~----~------~--~---
            Your message has been successfully submitted and would be delivered to recipients shortly.