Loading ...
Sorry, an error occurred while loading the content.

139133Re: Which version of Ruby should I use with Vim 7.4?

Expand Messages
  • Oskar Kvist
    Sep 11, 2013
    • 0 Attachment
      I read about the issue here http://hynek.me/articles/vim-7-3-on-win32/ and downloaded a version that was compiled for Ruby 2 from http://wyw.dcweb.cn/. Works great.

      However, this should probably be reported as an issue. I read that bugs should be reported on vim_dev but I don't know if this qualifies. I read somewhere that if one is not sure that it's a bug, use vim_use instead.

      On Wednesday, September 11, 2013 2:21:20 AM UTC+2, Tony Mechelynck wrote:
      > On 11/09/13 00:14, Oskar Kvist wrote:
      >
      > > Hi!
      >
      > >
      >
      > > I'm having trouble getting Ruby to work (need it for the LustyJuggler plugin) with Vim 7.4. If I look in the gvim.exe file, it references "msvcrt-ruby192.dll", but even the latest ruby 1.9.3 has msvcrt-ruby191.dll in it. I tried renaming that to msvcrt-ruby192.dll but it didn't work (results in a "LoadError: Incompatible library version"), not renaming the dll does not work either, has('ruby') == 0 then.
      >
      > >
      >
      > > I'm searched for answers to this question, but to my surprise I could not find anything.
      >
      > >
      >
      > > I'm on Windows by the way, maybe that has something to do with it.
      >
      > >
      >
      >
      >
      > "Vim without Cream" has, alas, not yet got beyond 7.3.829; it hasn't
      >
      > changed since 20 February. If you want to use it anyway, you need Ruby
      >
      > 1.9.1.
      >
      >
      >
      > I'm surprised that your Ruby 1.9.3 has a ruby191.dll with it. If your
      >
      > gvim version needs a msvcrt-ruby192.dll, I would expect it to have been
      >
      > compiled for Ruby 1.9.2. You can check that by starting it and checking
      >
      > the bottom half of the output of the :version command: you'll probably
      >
      > see there a number of Ruby-related compiler and linker defines.
      >
      >
      >
      > If you compile Vim yourself (on any OS), you can compile it for (almost)
      >
      > any Ruby version, but you need to make sure that there is no mismatch
      >
      > between your Ruby version and what Vim expects. On Linux this would be
      >
      > simply a matter of having the right "development" packages installed
      >
      > (and configure would mostly do the right thing), but on Windows you have
      >
      > to tell the make program which Ruby version you have installed; how to
      >
      > do that may vary according to which compiler (and makefile) you are
      >
      > using. Check the text of your src/make_{something}.mak (where
      >
      > {something} varies according to your compiler): you ought to be able to
      >
      > find there which make command-line switch (or environment variable) you
      >
      > need to set, and to what, as a function of your installed Ruby package.
      >
      > Usually there is a default value, which may or may not be the version
      >
      > installed on your system.
      >
      >
      >
      >
      >
      > Best regards,
      >
      > Tony.
      >
      > --
      >
      > "Gentlemen of the jury," said the defense attorney, now beginning
      >
      > to warm to his summation, "the real question here before you is, shall this
      >
      > beautiful young woman be forced to languish away her loveliest years in a
      >
      > dark prison cell? Or shall she be set free to return to her cozy little
      >
      > apartment at 4134 Mountain Ave. -- there to spend her lonely, loveless hours
      >
      > in her boudoir, lying beside her little Princess phone, 962-7873?"

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Show all 5 messages in this topic