Loading ...
Sorry, an error occurred while loading the content.

137523Re: can't use vimrc

Expand Messages
  • skyworld
    May 8, 2013
      在 2013年5月8日星期三UTC+8下午4时51分48秒,Christian Brabandt写道:
      > On Wed, May 8, 2013 10:12, skyworld wrote: > Hi, > thanks for your kind information. I checked the way you showed me and I > can now confirm that gvim7.1 has loaded my old settings. The reason why I > can't find those my familiar setting in gvim7.1 is that I found some font > are not installed in gvim7.1 but installed in gvim7.0. I have to find a > way to install them:-) Please show us the output of :version for both gvim versions. Remember, different gui flavors need different font settings and I suspect, this could be your problem. regards, Christian

      thanks. Here is my results for gvim7.1:
      :version
      VIM - Vi IMproved 7.1 (2007 May 12, compiled Jun 1 2011 18:27:06)
      Compiled by satish@gridsync4
      Normal version with GTK GUI. Features included (+) or not (-):
      -arabic +autocmd +balloon_eval +browse +builtin_terms +byte_offset +cindent +clientserver +clipboard
      +cmdline_compl +cmdline_hist +cmdline_info +comments +cryptv +cscope +cursorshape +dialog_con_gui +diff
      +digraphs +dnd -ebcdic -emacs_tags +eval +ex_extra +extra_search -farsi +file_in_path +find_in_path
      +folding -footer +fork() -gettext -hangul_input -iconv +insert_expand +jumplist -keymap -langmap +libcall
      +linebreak +lispindent +listcmds +localmap +menu +mksession +modify_fname +mouse +mouseshape -mouse_dec
      +mouse_gpm -mouse_jsbterm -mouse_netterm +mouse_xterm -multi_byte +multi_lang -mzscheme +netbeans_intg
      -osfiletype +path_extra -perl +postscript +printer -profile -python +quickfix +reltime -rightleft -ruby
      +scrollbind +signs +smartindent -sniff +statusline -sun_workshop +syntax +tag_binary +tag_old_static
      -tag_any_white -tcl +terminfo +termresponse +textobjects +title +toolbar +user_commands +vertsplit
      +virtualedit +visual +visualextra +viminfo +vreplace +wildignore +wildmenu +windows +writebackup +X11
      -xfontset +xim +xsmp_interact +xterm_clipboard -xterm_save
      system vimrc file: "$VIM/vimrc"
      user vimrc file: "$HOME/.vimrc"
      user exrc file: "$HOME/.exrc"
      system gvimrc file: "$VIM/gvimrc"
      user gvimrc file: "$HOME/.gvimrc"
      system menu file: "$VIMRUNTIME/menu.vim"
      fall-back for $VIM: "/grid/common/pkgs/vim/v7.1/share/vim"
      Compilation: /grid/common/pkgs/gcc/v4.1.2p2/bin/gcc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_GTK -I/usr/
      include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib64/glib/include -I/usr/X11R6/include -I/grid/common/pkgs
      /glib/v2.22.4/include -I/grid/common/pkgs/gtk+/v2.10.14/include -I/grid/common/pkgs/ncurses/v5.6/include -
      I/grid/common/pkgs/flex/v2.5.4a/include -I/grid/common/pkgs/xpm/v3.4k/include -I/grid/common/pkgs/glib/v2
      .22.4/include -I/grid/common/pkgs/gtk+/v2.10.14/include -I/grid/common/pkgs/ncurses/v5.6/include -I/grid/c
      ommon/pkgs/flex/v2.5.4a/include -I/grid/common/pkgs/xpm/v3.4k/include -I/usr/X11R6/include
      Linking: /grid/common/pkgs/gcc/v4.1.2p2/bin/gcc -L/usr/X11R6/lib64 -L/grid/common/pkgs/glib/v2.22.4/lib
      -L/grid/common/pkgs/gtk+/v2.10.14/lib -Wl,-rpath,/grid/common/pkgs/glib/v2.22.4/lib -Wl,-rpath,/grid/comm
      on/pkgs/gtk+/v2.10.14/lib -L/grid/common/pkgs/xpm/v3.4k/lib -Wl,-rpath,/grid/common/pkgs/xpm/v3.4k/lib -L/
      usr/local/lib -o vim -L/usr/lib64 -L/usr/X11R6/lib64 -lgtk -lgdk -rdynamic -lgmodule -lglib -lXi -lXext
      -lm -lXt -lncurses -lacl -lgpm

      Here is my result for gvim7.0:
      :version
      VIM - Vi IMproved 7.0 (2006 May 7, compiled Jun 12 2009 07:07:08)
      Included patches: 1, 3-4, 7-9, 11, 13-17, 19-26, 29-31, 34-44, 47, 50-56, 58-64, 66-73, 75, 77-92, 94-107, 109, 202, 234-237
      Modified by <bugzilla@...>
      Compiled by <bugzilla@...>
      Huge version with GTK2 GUI. Features included (+) or not (-):
      +arabic +autocmd +balloon_eval +browse ++builtin_terms +byte_offset +cindent +clientserver +clipboard +cmdline_compl
      +cmdline_hist +cmdline_info +comments +cryptv +cscope +cursorshape +dialog_con_gui +diff +digraphs +dnd -ebcdic +emacs_tags
      +eval +ex_extra +extra_search +farsi +file_in_path +find_in_path +folding -footer +fork() +gettext -hangul_input +iconv
      +insert_expand +jumplist +keymap +langmap +libcall +linebreak +lispindent +listcmds +localmap +menu +mksession +modify_fname
      +mouse +mouseshape +mouse_dec +mouse_gpm -mouse_jsbterm +mouse_netterm +mouse_xterm +multi_byte +multi_lang -mzscheme
      -netbeans_intg -osfiletype +path_extra +perl +postscript +printer +profile +python +quickfix +reltime +rightleft -ruby
      +scrollbind +signs +smartindent -sniff +statusline -sun_workshop +syntax +tag_binary +tag_old_static -tag_any_white -tcl
      +terminfo +termresponse +textobjects +title +toolbar +user_commands +vertsplit +virtualedit +visual +visualextra +viminfo
      +vreplace +wildignore +wildmenu +windows +writebackup +X11 -xfontset +xim +xsmp_interact +xterm_clipboard -xterm_save
      system vimrc file: "/etc/vimrc"
      user vimrc file: "$HOME/.vimrc"
      user exrc file: "$HOME/.exrc"
      system gvimrc file: "/etc/gvimrc"
      user gvimrc file: "$HOME/.gvimrc"
      system menu file: "$VIMRUNTIME/menu.vim"
      fall-back for $VIM: "/usr/share/vim"
      Compilation: gcc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_GTK -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/incl
      ude/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/
      freetype2 -I/usr/include/libpng12 -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buf
      fer-size=4 -m64 -mtune=generic -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_FORTIFY_SOURCE=2 -I/usr/include64 -D_REENTRANT -D_GNU
      _SOURCE -Wdeclaration-after-statement -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/include/gdbm -I/
      usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi/CORE -I/usr/include/python2.4 -pthread
      Linking: gcc -L/lib64 -L/usr/lib64 -Wl,-E -Wl,-rpath,/usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi/CORE -L/usr/local/l
      ib -o vim -L/lib64 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lpangocairo-1.0 -lpango-1.0 -lcairo -lgobject-2.0
      -lgmodule-2.0 -lglib-2.0 -lXt -lncurses -lselinux -lacl -lgpm -Wl,-E -Wl,-rpath,/usr/lib64/perl5/5.8.8/x86_64-linux-threa
      d-multi/CORE /usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi/auto/DynaLoader/DynaLoader.a -L/usr/lib64/perl5/5.8.8/x86_64-lin
      ux-thread-multi/CORE -lperl -lresolv -lutil -lc -L/usr/lib64/python2.4/config -lpython2.4 -lutil -lm -Xlinker -export-dynamic

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Show all 12 messages in this topic