Loading ...
Sorry, an error occurred while loading the content.

136944Re: Question Ctrl+Shift+V

Expand Messages
  • Hendrikus Godvliet
    Mar 27, 2013
    • 0 Attachment
      Gary 

      Thanks for your information. I am on Linux Mind and using Vim. You make me aware that i can paste with the mouse and it works. 

      Greating Hendrikus

      Op di, mrt 26, 2013 at 4:28 ,Gary Johnson <garyjohn@...> schreef:
      On 2013-03-26, Hendrikus Godvliet wrote:
      > I have a problem to get pasted copy in to Vim
      >
      > Please take a look to this two screenshots Gedit and Vim
      >
      > Vim make's a mash of the pasting code
      >
      > http://hendrikus-godvliet.appspot.com/chakras/30001
      >
      > Plaese can someone help to make me clear how to corect past copy
      > from outsite Vim into Vim.

      The solution depends on how you are pasting, whether you're using
      using vim or gvim, how your Vim was built, and how your Vim is
      configured.

      There is usually no problem pasting to gvim, so I'm going to assume
      you're using vim in a terminal. (The URL above didn't show
      anything. NoScript asked if I wanted to allow scripts on that page
      and I declined.)

      If you are using a vim that supports X11 and the xterm_clipboard, as
      you should be, and if you have mouse=all, then pasting should work
      properly. Oftentimes a Linux distribution will provide a vim that
      does not have X11 and xterm_clipboard included. You can find out if
      yours does by executing ":version". If you don't have those two
      features, then either install a more fully-functional vim package or
      invoke vim as "gvim -v". The latter will run gvim in terminal mode.

      If none of that is possible, then as a last resort you can do as
      others have suggested and set paste before pasting and nopaste
      afterwards. The only time I ever have to use paste/nopaste is when
      I'm using vim from PuTTY over an ssh connection. Otherwise, normal
      pasting using the mouse "just works".

      HTH,
      Gary

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.



      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
       
      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
       
       
    • Show all 10 messages in this topic