Loading ...
Sorry, an error occurred while loading the content.

135663Re: Cygwin gvim needs weird ritual to past from Windows clipboard

Expand Messages
  • Christian Brabandt
    Jan 21, 2013
    • 0 Attachment
      On Tue, January 22, 2013 06:03, AndyHancock wrote:
      > I installed cygwin's gvim on Windows 7. I found that pasting from the
      > Windows clipboard into gvim doesn't work by clicking the middle mouse
      > button unless I go through a weird ritual that I discovered by
      > accident. If I don't do this, I get "E353: Nothing in register *".
      >
      > First, I have to highlight some text using gvim.
      >
      > Second, I copy from Windows. Finally I paste into gvim using the
      > middle mouse button (Shift-Insert never works).
      >
      > I am working in a locked down environment where arranging to run
      > setup/install executables take months to arrange, and opening firewall
      > ports might never happen. At first, I thought the problem might be
      > related to an X11 error message about ports being blocked, but then I
      > discovered the above recipe.
      >
      > Given the above clue, can anyone suggest what the cause might be, and
      > possible ways to make the ritual unnecessary? Here is the diagnostic
      > data that I am able to find.

      You might be interested in the cygwin_clipboard patch, that is floating
      around vim_dev and just recently was updated to work with recent Vim
      versions:
      http://groups.google.com/group/vim_dev/msg/b9fa96cceeb03518

      If you try the patch, please report there if it works or if you encounter
      some problems. This way, we might eventually get this patch included
      into Vim source.

      regards,
      Christian

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Show all 9 messages in this topic