Loading ...
Sorry, an error occurred while loading the content.

135306Re: slow samba+vim, I'm out of suggestions ...

Expand Messages
  • dza
    Jan 3, 2013
    • 0 Attachment
      On Thursday, 13 December 2012 18:11:26 UTC+1, dza wrote:
      > I wonder why my Vim is so slow over our Windows samba share - not only opening/closing is slow - also typing and edit/insert commands are slow as well :-commands, plugins, everything.
      > Can I tame Vim running on a fileshare? Or make it cache the files locally so it doesn't slow down?
      > I've seen alot of suggestions, but none of them seems to do the trick.
      > For example:
      > nofsync
      > ttyfast
      > ttimeout
      > timeout
      > Thank you very much in advance, I would really like to know how I can fix this !

      Hello guys - It's been some time since I last answered, but I have made some real progress since!

      I was seeing alot of "NAME NOT FOUND" entries in ProcMon from www.sysinternals.com to these files:

      I solved this simply by disabling "Offline Files"
      Search in Explorer for "Offline Files" click the UAC "Disable Offline Files", needs a restart and gone are the mysterious slowing "NAME NOT FOUND" entries in ProcMon and a noticeable gain in performance in Vim :) (while not running ProcMon of course which slows things down tremendously)

      I am still getting alot of "FAST IO DISALLOWED" entries. However, I am not sure if this is because of misconfiguration of SAMBA or simply because Network Shares are not having "FAST IO" ...

      Other than that you are right; swap, backup, dir needs to be turned off and the current dir "." removed from the array.

      I've also gained some speed by using
      let g:miniBufExplCheckDupeBufs = 0
      let g:miniBufExplorerMoreThanOne = 0

      I still get slowdowns on several tabs with vertical and horizontal tabs when buffers starts to grow. I will keep using ProcMon and ":debug wincmd p "

      ":debug wincmd p" shows alot of minibufexpl calls, and that is essentially what I think is causing the slowdown between switching buffers, although the plugin is quite essential.

      I still have experimented alot with/without configs and plugins and I will keep doing this.

      Sincerely thanks,
      Christoffer Aasted.

      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Show all 15 messages in this topic