Loading ...
Sorry, an error occurred while loading the content.

Re: New to Vim, Japanese setup

Expand Messages
  • Glenn Maynard
    ... You need iconv.dll to handle euc-jp. You also need to change fileencoding , not encoding . encoding represents the internal representation, and should
    Message 1 of 4 , Oct 5, 2003
    • 0 Attachment
      On Mon, Oct 06, 2003 at 01:13:40AM +0900, Rick Frankum wrote:
      > To update: the vim I have is indeed multibyte-enabled. The big
      > problem appears to be that I'm not editing S-JIS files but
      > in fact EUC-jp. When I run vim under Windows it doesn't
      > recognize (I tried :set encoding=euc-jp) the encoding,
      > and when I run it under Cygwin I still get garbage (though
      > it _does_ recognize euc-jp but not cp932).

      You need iconv.dll to handle euc-jp.

      You also need to change "fileencoding", not "encoding". "encoding"
      represents the internal representation, and should be set to "utf-8".

      --
      Glenn Maynard
    Your message has been successfully submitted and would be delivered to recipients shortly.