Loading ...
Sorry, an error occurred while loading the content.

Re: New to Vim, Japanese setup

Expand Messages
  • Rick Frankum
    ... I appreciate it! ... To update: the vim I have is indeed multibyte-enabled. The big problem appears to be that I m not editing S-JIS files but in fact
    Message 1 of 4 , Oct 5, 2003
    • 0 Attachment
      Tony Mechelynck wrote:
      > I have only some of the answers you are looking for. Probably someone else
      > will jump in to fill in what I didn't know.

      I appreciate it!
      >>I'm trying to figure out how to configure vim on my system.
      >>I'm running Windows XP (English menus, but with Japanese
      >>support enabled) and would like to edit Japanese
      >>files (S-JIS enc), but the documentation is slightly
      >>confusing. I'd appreciate any help that the list can offer.

      To update: the vim I have is indeed multibyte-enabled. The big
      problem appears to be that I'm not editing S-JIS files but
      in fact EUC-jp. When I run vim under Windows it doesn't
      recognize (I tried :set encoding=euc-jp) the encoding,
      and when I run it under Cygwin I still get garbage (though
      it _does_ recognize euc-jp but not cp932).

      Hiroji Kimura writes:
      > http://www.kaoriya.net/#VIM6
      > Try the above link. That's what I use to edit Japanese.

      If I can't get the standard version working, I'll try this. What's
      a .bz2 extension, though?

      Eric Long writes:
      > When you say you get raw garbage, does that mean you see a lot of
      > accented letters, or do you get a lot of stuff like ~B and ~K
      > (or perhaps <82> and <8b>) ? If you have the accented letters it'll
      > probably work with the right font, but if you have the ~B and ~K it
      > means the encoding isn't getting set right.

      The garbage I refer to is mostly half-width katakana and dots.

      Thanks again for the help,
      --Rick
      frankum@...
    • Glenn Maynard
      ... You need iconv.dll to handle euc-jp. You also need to change fileencoding , not encoding . encoding represents the internal representation, and should
      Message 2 of 4 , Oct 5, 2003
      • 0 Attachment
        On Mon, Oct 06, 2003 at 01:13:40AM +0900, Rick Frankum wrote:
        > To update: the vim I have is indeed multibyte-enabled. The big
        > problem appears to be that I'm not editing S-JIS files but
        > in fact EUC-jp. When I run vim under Windows it doesn't
        > recognize (I tried :set encoding=euc-jp) the encoding,
        > and when I run it under Cygwin I still get garbage (though
        > it _does_ recognize euc-jp but not cp932).

        You need iconv.dll to handle euc-jp.

        You also need to change "fileencoding", not "encoding". "encoding"
        represents the internal representation, and should be set to "utf-8".

        --
        Glenn Maynard
      Your message has been successfully submitted and would be delivered to recipients shortly.