Loading ...
Sorry, an error occurred while loading the content.

Re: Need config option controlling addition of byte order mark to UTF-8 files

Expand Messages
  • Bram Moolenaar
    ... Vim doesn t add a BOM, it only preserves it when it s already there. ... You can reset the bomb option to remove a BOM when writing a file. -- My
    Message 1 of 2 , Sep 10, 2003
    • 0 Attachment
      Aleksander Adamowski wrote:

      > I've noticed that with version 6.2 VIM started to add the BOM at teh
      > beginning of files when I use an UTF-8 locale.

      Vim doesn't add a BOM, it only preserves it when it's already there.

      > Unfortunately, even with the latest version (2.0.47) Apache doesn't
      > remove that mark and outputs it, which makes PHP scripts not work - when
      > output is sent to browser before I can issue output buffering command, I
      > cannot send headers to the browser.

      You can reset the 'bomb' option to remove a BOM when writing a file.

      --
      My girlfriend told me I should be more affectionate.
      So I got TWO girlfriends.

      /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
      /// Creator of Vim - Vi IMproved -- http://www.Vim.org \\\
      \\\ Project leader for A-A-P -- http://www.A-A-P.org ///
      \\\ Help AIDS victims, buy here: http://ICCF-Holland.org/click1.html ///
    Your message has been successfully submitted and would be delivered to recipients shortly.