Loading ...
Sorry, an error occurred while loading the content.

How can set VIM to show single utf-8 characters as single characters?

Expand Messages
  • Ken Wolf
    After downloading vim-6.2.tar.bz2, compiling with CONF_OPT_MULTIBYTE = --enable-multibyte, and starting VIM with fileencoding and encoding set to utf-8, I can
    Message 1 of 2 , Jun 9, 2003
    • 0 Attachment
      After downloading vim-6.2.tar.bz2,
      compiling with CONF_OPT_MULTIBYTE = --enable-multibyte,
      and starting VIM with fileencoding and encoding set to utf-8,
      I can insert a utf-8 paragraph character from insert
      mode by typing ^K and then PI (PI is a digraph) or by typing ^V and
      then 182

      In both cases, the correct two characters are inserted (ascii 194 and
      182) but they display as two characters instead of as one character.
      When I go to the second of the two displayed characters and type x the
      character after my two characters is deleted!

      I am working in a Reflection X for Windows NT (version 8.0.2) telnet
      window to a SunOS (version 5.8) machine.

      How can set VIM to show single utf-8 characters as single characters?

      thanks,
      Ken Wolf
    • Bram Moolenaar
      ... Did you try using termencoding ? Your terminal probably expects latin1 characters while Vim is sending utf-8 bytes. -- Fingers not found - Pound head on
      Message 2 of 2 , Jun 22, 2003
      • 0 Attachment
        Ken Wolf wrote:

        > After downloading vim-6.2.tar.bz2,
        > compiling with CONF_OPT_MULTIBYTE = --enable-multibyte,
        > and starting VIM with fileencoding and encoding set to utf-8,
        > I can insert a utf-8 paragraph character from insert
        > mode by typing ^K and then PI (PI is a digraph) or by typing ^V and
        > then 182
        >
        > In both cases, the correct two characters are inserted (ascii 194 and
        > 182) but they display as two characters instead of as one character.
        > When I go to the second of the two displayed characters and type x the
        > character after my two characters is deleted!
        >
        > I am working in a Reflection X for Windows NT (version 8.0.2) telnet
        > window to a SunOS (version 5.8) machine.
        >
        > How can set VIM to show single utf-8 characters as single characters?

        Did you try using 'termencoding'? Your terminal probably expects latin1
        characters while Vim is sending utf-8 bytes.

        --
        Fingers not found - Pound head on keyboard to continue.

        /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
        /// Creator of Vim - Vi IMproved -- http://www.Vim.org \\\
        \\\ Project leader for A-A-P -- http://www.A-A-P.org ///
        \\\ Help AIDS victims, buy at Amazon -- http://ICCF.nl/click1.html ///
      Your message has been successfully submitted and would be delivered to recipients shortly.