Loading ...
Sorry, an error occurred while loading the content.

Encoding in quickfix window?

Expand Messages
  • Valery Kondakoff
    Hello, people at vim-multibyte list! Ah! Another encoding-related problem: the right encoding is not set in quickfix window. There is an example: I was
    Message 1 of 3 , Apr 3, 2003
    • 0 Attachment
      Hello, people at vim-multibyte list!

      Ah! Another encoding-related problem: the 'right' encoding is not set
      in 'quickfix' window.

      There is an example: I was using grep to search text in files, that
      contain text in cp1251 encoding. Then I'm opening quickfix window
      (:copen) and see garbage instead of Russian characters.

      There is a screenshot, that illustrates the problem (~20k): the bottom
      window is the quickfix widow and the top window is just a the same
      grep output redirected to a file and opened in GVim as a text file.
      ('set fenc?' returns 'cp1251' in quickfix window).

      http://www.nbk.orc.ru/temp/qf.png

      How can I set quickfix to display characters in cp1251?

      Here are my settings (I'm using GVim 6.1.423, WinXP Pro):

      set encoding=utf-8
      set fileencoding=cp1251
      set fileencodings=cp1251,cp866,koi8-r
      set guifont=courier_new:h11
      set keymap=russian-jcukenwin

      Thank you.

      --
      Best regards,
      Valery Kondakoff
      http://www.nbk.orc.ru (Ne Bey Kopytom)
      http://www.nbk.orc.ru/mtb (MTB riding in Moscow)

      PGP key: mailto:pgp-public-keys@...?subject=GET%20strauss@...
    • Bram Moolenaar
      ... This not just a problem of the quickfix window, the :clist command should have the same problem. The errorfile is read without conversion, thus it s used
      Message 2 of 3 , Apr 3, 2003
      • 0 Attachment
        Valery Kondakoff wrote:

        > Hello, people at vim-multibyte list!
        >
        > Ah! Another encoding-related problem: the 'right' encoding is not set
        > in 'quickfix' window.
        >
        > There is an example: I was using grep to search text in files, that
        > contain text in cp1251 encoding. Then I'm opening quickfix window
        > (:copen) and see garbage instead of Russian characters.
        >
        > There is a screenshot, that illustrates the problem (~20k): the bottom
        > window is the quickfix widow and the top window is just a the same
        > grep output redirected to a file and opened in GVim as a text file.
        > ('set fenc?' returns 'cp1251' in quickfix window).
        >
        > http://www.nbk.orc.ru/temp/qf.png
        >
        > How can I set quickfix to display characters in cp1251?

        This not just a problem of the quickfix window, the ":clist" command
        should have the same problem.

        The errorfile is read without conversion, thus it's used with the value
        of 'encoding'. Your 'encoding' is set to "utf-8" and the file is in
        cp1251, thus you don't see the right characters.

        I'll add a remark that some option should be added to specify the
        encoding of the errorfile, so that conversion can be done. Don't expect
        this soon though...

        --
        Q: Is selling software the same as selling hardware?
        A: No, good hardware is sold new, good software has already been used by many.

        /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
        /// Creator of Vim - Vi IMproved -- http://www.Vim.org \\\
        \\\ Project leader for A-A-P -- http://www.A-A-P.org ///
        \\\ Help AIDS victims, buy at Amazon -- http://ICCF.nl/click1.html ///
      • Valery Kondakoff
        Hello, Bram! ... BM This not just a problem of the quickfix window, the :clist command BM should have the same problem. Exactly! BM I ll add a remark that
        Message 3 of 3 , Apr 3, 2003
        • 0 Attachment
          Hello, Bram!

          Friday, April 4, 2003, you wrote to me:


          >> Ah! Another encoding-related problem: the 'right' encoding is not set
          >> in 'quickfix' window.

          BM> This not just a problem of the quickfix window, the ":clist" command
          BM> should have the same problem.

          Exactly!

          BM> I'll add a remark that some option should be added to specify the
          BM> encoding of the errorfile, so that conversion can be done. Don't expect
          BM> this soon though...

          Thank you.

          --
          Best regards,
          Valery Kondakoff
          http://www.nbk.orc.ru (Ne Bey Kopytom)
          http://www.nbk.orc.ru/mtb (MTB riding in Moscow)

          PGP key: mailto:pgp-public-keys@...?subject=GET%20strauss@...

          np: The Cure - Bloodflowers (Bloodflowers) [stopped]
        Your message has been successfully submitted and would be delivered to recipients shortly.