Loading ...
Sorry, an error occurred while loading the content.

font problem with SuSE 8.1

Expand Messages
  • Paul Williams
    Has anyone tried UTF-8 on SuSE 8.1? After recently upgrading form SuSE 7.3 I m having new problems. 1) I can t build. There s a header conflict between the
    Message 1 of 1 , Mar 15, 2003
    • 0 Attachment
      Has anyone tried UTF-8 on SuSE 8.1? After recently upgrading form SuSE 7.3 I'm
      having new problems.

      1) I can't build. There's a header conflict between the /usr/local/include and
      /usr/X11R6/include dirs, looks like a SuSE problem (never had any problems with

      2) The problem I'm seeing with the SuSE build is a font selection problem,
      broken umlauts in UTF-8 files. The guifont & guifontwide are set correctly in
      .gvimrc, but when I bring up gvim, the umlauts are broken. But if I then
      explicitly give the command

      :set guifont=-misc-fixed-medium-r-normal-*-18-120-100-100-c-90-iso10646-1

      the umlauts are fixed. But this command sets the font to what it already is!
      This is the same value given in .gvimrc and the same value returned by :set.
      Also tried setting the font at the command line with the '-font' param but that
      has the same behavior.

      So I grabbed the latest RPM (vim-6.1-247.i586.rpm) from
      same problem.

      3) Very low priority - the localized menus also have broken umlauts. I also
      saw this on SuSE 7.3 and Windows 2000.

      Here's the version info

      VIM - Vi IMproved 6.1 (2002 Mar 24, compiled Jan 13 2003 18:07:20)
      Inclusive der Korrekturen: 1, 3-15, 17-18, 20-22, 24-34, 36-72, 74-75, 77-87,
      89-92, 94-99, 101-118, 120-146, 150
      �bersetzt von root@minkowski
      Gro�e Version mit GTK GUI. Ein- (+) oder ausschlie�lich (-) der Eigenschaften:
      +autocmd -balloon_eval +browse ++builtin_terms +byte_offset +cindent
      +clientserver +clipboard +cmdline_compl +cmdline_hist +cmdline_info
      +comments +cryptv +cscope +dialog_con_gui +diff +digraphs -ebcdic +emacs_tags
      +eval +ex_extra +extra_search +farsi +file_in_path
      +find_in_path +folding -footer +fork() +gettext -hangul_input +iconv
      +insert_expand +jumplist +keymap +langmap +libcall +linebreak
      +lispindent +listcmds +localmap +menu +mksession +modify_fname +mouse
      +mouseshape +mouse_dec +mouse_gpm -mouse_jsbterm +mouse_netterm
      +mouse_xterm +multi_byte +multi_lang -osfiletype +path_extra +perl +postscript
      +printer +python +quickfix +rightleft -ruby +scrollbind +signs
      +smartindent -sniff +statusline -sun_workshop +syntax +tag_binary
      +tag_old_static -tag_any_white -tcl +terminfo +termresponse +textobjects
      +title +toolbar +user_commands +vertsplit +virtualedit +visual +visualextra
      +viminfo +vreplace +wildignore +wildmenu +windows +writebackup
      +X11 +xfontset +xim +xterm_clipboard -xterm_save
      System-vimrc-Datei: "/etc/vimrc"
      System-vimrc-Datei: "$HOME/.vimrc"
      Nutzer-exrc-Datei: "$HOME/.exrc"
      System-gvimrc-Datei: "/etc/gvimrc"
      Nutzer-gvimrc-Datei: "$HOME/.gvimrc"
      System-Men�-Datei: "$VIMRUNTIME/menu.vim"
      Voreinstellung f�r $VIM: "/etc"
      und f�r $VIMRUNTIME: "/usr/share/vim/current"
      �bersetzt: gcc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_GTK
      -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include
      1R6/include -O2 -march=i586 -mcpu=i686 -fmessage-length=0 -Wall -pipe
      -I/usr/X11R6/include -D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing
      -I/usr/lib/perl5/5.8.0/i586-linux-thread-multi/CORE -I/usr/include/python2.2
      Linken: gcc -L/usr/X11R6/lib -rdynamic
      -Wl,-rpath,/usr/lib/perl5/5.8.0/i586-linux-thread-multi/CORE -L/usr/local/lib
      -o gvim -L/usr/lib
      -L/usr/X11R6/lib -lgtk -lgdk -rdynamic -lgmodule -lglib -ldl -lXi -lXext -lX11
      -lm -lSM -lICE -lXpm -lXt -lX11 -lXdmcp -lSM -lICE -lncurses -
      lgpm -ldl -rdynamic
      r/DynaLoader.a -L/usr/lib/perl5/5.8.0/i586-linux-thread-multi/CORE -lperl -lnsl
      -ldl -lm -lpthread -lcrypt -lutil -L/usr/lib/python2.2/config
      -lpython2.2 -ldl -lpthread -lutil -lm -Xlinker -export-dynamic
      Dr�cken Sie die EINGABETASTE oder geben Sie einen Befehl ein

      Do you Yahoo!?
      Yahoo! Web Hosting - establish your business online
    Your message has been successfully submitted and would be delivered to recipients shortly.