Loading ...
Sorry, an error occurred while loading the content.

Inserting multi-byte Chinese is not elegant

Expand Messages
  • maxiangjiang
    Hey, I am happy to find that I can type Chinese using gvim on my English OS (W2K). Wish it can be more elegant. Here is a case: If I have three Chinese chars,
    Message 1 of 4 , Mar 13, 2003
    • 0 Attachment
      Hey,

      I am happy to find that I can type Chinese using gvim
      on my English OS (W2K). Wish it can be more elegant.

      Here is a case:

      If I have three Chinese chars, say, "xx12xx",
      and my cursor is on "12":

      1. type s (works, the whole char is replaced)
      2. input a Chinese through IME
      a) I could see Chinese on the input bar
      b) pick a Chinese char through mouse or number
      3. Now, instead of the Chinse char being inserted,
      I found a sqare is showed on the location of "1"
      4. Hit Enter, the char is replaced correctly.

      Step 3 is not elegant. It can happen through other ways,
      as v2lc, 3s, etc



      Thanks.

      Xiangjiang Ma
    • Glenn Maynard
      ... It sounds like the font being used by the IME over-the-spot display doesn t actually support Chinese. This works fine for Japanese, at least for me; I see
      Message 2 of 4 , Mar 13, 2003
      • 0 Attachment
        On Thu, Mar 13, 2003 at 11:15:50AM -0800, maxiangjiang wrote:
        > If I have three Chinese chars, say, "xx12xx",
        > and my cursor is on "12":
        >
        > 1. type s (works, the whole char is replaced)
        > 2. input a Chinese through IME
        > a) I could see Chinese on the input bar
        > b) pick a Chinese char through mouse or number
        > 3. Now, instead of the Chinse char being inserted,
        > I found a sqare is showed on the location of "1"
        > 4. Hit Enter, the char is replaced correctly.

        It sounds like the font being used by the IME over-the-spot display
        doesn't actually support Chinese.

        This works fine for Japanese, at least for me; I see the chosen
        characters on top of Vim (aligned properly but not "inserting"
        in realtime; that's hard) until I hit enter.

        What IME are you using? I can't find a Chinese IME in Win2K, only
        Japanese and Korean ones.

        --
        Glenn Maynard
      • maxiangjiang
        Glenn, I am using W2K US English, IBM laptop. I set my IME through: Regional Options Input Locales Chinese(PRC) Chinese (Simplified) -MS-PinYin98 I don t see
        Message 3 of 4 , Mar 13, 2003
        • 0 Attachment
          Glenn,

          I am using W2K US English, IBM laptop.
          I set my IME through:
          Regional Options
          Input Locales
          Chinese(PRC) Chinese (Simplified) -MS-PinYin98

          I don't see problem when I started using IME for inputing.
          I could see Chinese char being inserted into vim buffer.
          The problem started when I <Esc> from INSERT mode and get back
          to INSERT mode by typing s or cl. Now, even if I restarted IME,
          I could not see real char until I hit ENTER.

          Something might "triggled" this bad behavior.


          Thanks.

          Xiangjiang Ma
        • maxiangjiang
          I found the following IME is bad. ... Instead, the following are stable (no more step 3 bug) Input Locales Chinese(PRC) Chinese (Simplified) -MS-Shuang-Pin
          Message 4 of 4 , Mar 13, 2003
          • 0 Attachment
            I found the following IME is bad.

            > Input Locales
            > Chinese(PRC) Chinese (Simplified) -MS-PinYin98

            Instead, the following are stable (no more step 3 bug)

            Input Locales
            Chinese(PRC) Chinese (Simplified) -MS-Shuang-Pin

            Input Locales
            Chinese(PRC) Chinese (Simplified) -MS-Quan-Pin



            ----- Original Message -----
            From: "maxiangjiang" <maxiangjiang@...>
            To: <vim-multibyte@...>
            Sent: Thursday, March 13, 2003 10:36 PM
            Subject: Re: Inserting multi-byte Chinese is not elegant


            > Glenn,
            >
            > I am using W2K US English, IBM laptop.
            > I set my IME through:
            > Regional Options
            > Input Locales
            > Chinese(PRC) Chinese (Simplified) -MS-PinYin98
            >
            > I don't see problem when I started using IME for inputing.
            > I could see Chinese char being inserted into vim buffer.
            > The problem started when I <Esc> from INSERT mode and get back
            > to INSERT mode by typing s or cl. Now, even if I restarted IME,
            > I could not see real char until I hit ENTER.
            >
            > Something might "triggled" this bad behavior.
            >
            >
            > Thanks.
            >
            > Xiangjiang Ma
          Your message has been successfully submitted and would be delivered to recipients shortly.