Loading ...
Sorry, an error occurred while loading the content.

Re: Wrong encoding when copying to/from Clipboard in the newest builds

Expand Messages
  • Glenn Maynard
    From: Valery Kondakoff To: Glenn Maynard Could you please tell your mailer not to put my name on the mailing list
    Message 1 of 9 , Mar 12, 2003
    • 0 Attachment
      From: Valery Kondakoff <strauss@...>
      To: Glenn Maynard <vim-multibyte@...>

      Could you please tell your mailer not to put my name on the mailing list
      address? It's wrong and extremely confusing.

      On Thu, Mar 13, 2003 at 12:48:46AM +0300, Valery Kondakoff wrote:
      > No. I just downloaded Win32 build with the latest patches applied
      > (http://www.unb.ca/chem/ajit/vim.htm). BTW - as far as I understand
      > the reported problem is not related to UTF-8, because text is copied
      > in cp1251. Am I wrong?

      Er, it's a general clipboard fix, not just UTF-8; without it, it'll put
      text on the clipboard in the wrong encoding in some cases.

      I'd rather not start troubleshooting the clipboard code as it was before
      this patch, since I have to worry about whether the problem you're having
      happens to be fixed by the patch.

      --
      Glenn Maynard
    • Valery Kondakoff
      Hello, Glenn! ... GM I don t know the full implications of Vim without the current clipboard GM patch, so I d like him to apply it (and recheck the problems)
      Message 2 of 9 , Mar 13, 2003
      • 0 Attachment
        Hello, Glenn!

        13 марта 2003 г., you wrote to me:

        >> I don't know what's wrong. Glenn? Ron?

        GM> I don't know the full implications of Vim without the current clipboard
        GM> patch, so I'd like him to apply it (and recheck the problems) before I
        GM> try troubleshooting anything.

        I have found a link to patched GVIM, that you send in one of the
        previous messages. Today I downloaded it. There is a report: it seems,
        this patch fixes my problem with garbage encodings. At least there are
        no clipboard-related encoding problems in this build.

        But it introduces another problem: when copying _from_ another app to
        GVIM the last character of clipboard contents is _not_ copied to GVIM.

        There is an example: I'm copying a string '1234' from Notepad. After
        pasting in GVIM ("*p) it will be truncated to '123'.

        The last character is not truncated, when pasting from GVIM to
        Notepad. (WinXP Pro).

        :)

        --
        Best regards,
        Valery Kondakoff
        http://www.nbk.orc.ru (Ne Bey Kopytom)
        http://www.nbk.orc.ru/mtb (MTB riding in Moscow)

        PGP key: mailto:pgp-public-keys@...?subject=GET%20strauss@...
      • Glenn Maynard
        ... The only binaries I ve put up are fairly old, and don t include the recent patch and may not include some other bugfixes. I ll see about updating that
        Message 3 of 9 , Mar 13, 2003
        • 0 Attachment
          On Fri, Mar 14, 2003 at 04:23:54AM +0300, Valery Kondakoff wrote:
          > I have found a link to patched GVIM, that you send in one of the
          > previous messages. Today I downloaded it. There is a report: it seems,
          > this patch fixes my problem with garbage encodings. At least there are
          > no clipboard-related encoding problems in this build.

          The only binaries I've put up are fairly old, and don't include the
          recent patch and may not include some other bugfixes.

          I'll see about updating that binary in the next day or two.

          --
          Glenn Maynard
        • Valery Kondakoff
          Hello, Glenn! 14 ìàðòà 2003 ã., you wrote to me: ... GM The only binaries I ve put up are fairly old, and don t include the GM recent patch and may not
          Message 4 of 9 , Mar 14, 2003
          • 0 Attachment
            Hello, Glenn!

            14 марта 2003 г., you wrote to me:

            GM> On Fri, Mar 14, 2003 at 04:23:54AM +0300, Valery Kondakoff wrote:
            >> I have found a link to patched GVIM, that you send in one of the
            >> previous messages. Today I downloaded it. There is a report: it seems,
            >> this patch fixes my problem with garbage encodings. At least there are
            >> no clipboard-related encoding problems in this build.

            GM> The only binaries I've put up are fairly old, and don't include the
            GM> recent patch and may not include some other bugfixes.

            Currently I'm experimenting with your build. I have set 'encoding' to
            'utf-8' in my _vimrc, and this fixes the problem with disappearing
            character after copying text from external app to GVIM. And there are
            _no_ problems with text encoding.

            So, it seems, that the last character disappears only when unicode is
            not enabled.


            --
            Best regards,
            Valery Kondakoff
            http://www.nbk.orc.ru (Ne Bey Kopytom)
            http://www.nbk.orc.ru/mtb (MTB riding in Moscow)

            PGP key: mailto:pgp-public-keys@...?subject=GET%20strauss@...
          Your message has been successfully submitted and would be delivered to recipients shortly.