Loading ...
Sorry, an error occurred while loading the content.

Re: Is it possible to set up GVIM to work with multiple file encodings? (I can not)

Expand Messages
  • Glenn Maynard
    ... Setting imsearch=0 fixed this. (The oddity of the IME turning off was due to a forgotten IME keybinding I made: ^U in the IME turns it off. I was hitting
    Message 1 of 6 , Apr 12, 2002
    • 0 Attachment
      On Thu, Apr 11, 2002 at 08:22:29PM +0200, Bram Moolenaar wrote:
      > Something with the 'imsearch' option?

      Setting imsearch=0 fixed this. (The oddity of the IME turning off was
      due to a forgotten IME keybinding I made: ^U in the IME turns it off. I
      was hitting ^U in Vim, to clear the IME input, but it was really the IME
      keybinding.)

      I'd suggesting documenting the fact that iminsert and imsearch follow
      the IME status regardless of how it's turned on or off. Most IME2K
      users are likely to use IME bindings to toggle it, not Vim bindings (as
      they're system-wide).

      "Note that this option changes when the input method is toggled
      in Insert mode, such as with CTRL-^ |c_CTRL-^|." (Or something
      clearer.)

      I'd still like to see iminsert (and now imsearch) default to 0 rather
      than 2 when using this IME. (Or, perhaps, default to the state the IME
      was in when Vim loads; that might help to give Vim the same IME behavior
      in input mode as other applications give with other IMEs.)

      --
      Glenn Maynard
    Your message has been successfully submitted and would be delivered to recipients shortly.