Loading ...
Sorry, an error occurred while loading the content.

Can't convert this file encoding...

Expand Messages
  • Valery Kondakoff
    Hello, Ron! ... RA You are doing things correctly, but it appears you have a defective iconv.dll. RA You should download mine: RA
    Message 1 of 4 , Apr 7 1:30 AM
    • 0 Attachment
      Hello, Ron!

      7 Апрель 2002 г., you wrote to me:


      >>On certain files, after trying to perform file encoding conversion (:e
      >>++enc=cp866, for example), I receive "Not converted" error, and the
      >>file remains in wrong encoding. (VIM 6.1, iconv.dll - 423.640,
      >>09.03.01 04:49, WinXP)

      RA> You are doing things correctly, but it appears you have a defective iconv.dll.
      RA> You should download mine:
      RA> http://www.mossbayeng.com/~ron/vim/iconv.dll
      RA> which should be the libiconv 1.7.0.1. Try and see if it fixes your problem;
      RA> for me, trying on Windows Me, it worked fine with your example file.

      Thank you for your answer. I downloaded your iconv.dll and replaced
      the previous one (downloaded from http://vim.sourceforge.net/, BTW the
      both files are the same size) but the problem still remains. :(

      There are my settings (default encoding is cp1251):
      set fileencodings=cp866,koi8-r,cp1251

      When I'm opening the file "ru_cp866.txt" (:e ru_cp866.txt) it is open
      in cp1251 encoding. Then I'm trying to perform force encoding (:e
      ++enc=cp866), after pressing <enter> on command line I see report:
      "ru_cp866.txt" [NOT converted] 2L, 116C" and the file remains in wrong
      cp1251 encoding.

      But when I delete two chars from this file (they are ASCII graphics:
      Col 57, Line 1 and Col 40 Line 2), the file opens in right encoding
      (cp866).

      Do you have any idea - what may be wrong?

      --
      Best regards,
      Valery Kondakoff mailto:strauss@...
      http://www.nbk.orc.ru Ne Bey Kopytom
      http://www.nbk.orc.ru/mtb MTB riding in Moscow

      *** The previous line contains the naughty word "$&".
      if /(ibm|apple|awk)/; # :-)
      --Larry Wall
    • Valery Kondakoff
      Hello, Ron! ... RA Sorry, try again. I had an older iconv.dll there. The newer one is in its RA place. Thank you. I (re)downloaded updated file...
      Message 2 of 4 , Apr 7 11:18 AM
      • 0 Attachment
        Hello, Ron!

        7 Апрель 2002 г., you wrote to me:

        >>Thank you for your answer. I downloaded your iconv.dll and replaced
        >>the previous one (downloaded from http://vim.sourceforge.net/, BTW the
        >>both files are the same size) but the problem still remains. :(

        RA> Sorry, try again. I had an older iconv.dll there. The newer one is in its
        RA> place.

        Thank you.

        I (re)downloaded updated file... Unfortunately, the problem still exist.
        :(
        I can reproduce this problem on two machines (at home and at work),
        both running WinXP (currently I have no access to any PC, that runs
        Win9* or WinME).

        Example file that I send in my previous message is displayed
        correctly in all the editors (Bred2, FAR internal editor/viewer,
        Windows internal command-line "Edit"), but, unfortunately, not in VIM...

        I'm very new to VIM-world. Maybe I'm doing smth wrong? Smth with VIM
        settings?

        BTW, I have another one "encoding"-related problem. There it is:
        currently I need to view/edit files in three encodings - cp1251
        (windows default), cp866 (DOS) and koi8-r (Unix one). When trying to
        perform some kind of (semi)automatic encoding detection I wrote in my
        vimrc: "set fileencodings=cp866,koi8-r,cp1251".

        This setting works as expected - in most cases files are opened in
        correct encoding, but there is an additional drawback: most files with
        no local letters (with no russian language inside) are opened in cp866
        (the first one mentioned in "fileencodings") encoding instead of the
        default cp1251. And if I'm changing the encoding order to "set
        fileencodings=cp1251,cp866,koi8-r" the other two encodings are not
        (auto)detected anymore, becouse they are "stealed" with cp1251...

        Please, let me understand - if there is smth I can do with atomatic
        encoding detection? I just want to open _all_ files in cp1251, except
        files that are encoded in cp866 or koi8-r... Is it possible?

        Thank you!

        --
        Best regards,
        Valery Kondakoff mailto:strauss@...
        http://www.nbk.orc.ru Ne Bey Kopytom
        http://www.nbk.orc.ru/mtb MTB riding in Moscow

        [End of diatribe. We now return you to your regularly scheduledprogramming...]
        --Larry Wall
      Your message has been successfully submitted and would be delivered to recipients shortly.