Loading ...
Sorry, an error occurred while loading the content.

Re: XIM problem in gvim 6.x

Expand Messages
  • Bram Moolenaar
    ... I don t know what causes this problem. I ll forward the message to the vim-multibyte list. -- I d like to meet the man who invented sex and see what he s
    Message 1 of 2 , Mar 14, 2002
    • 0 Attachment
      Yuheng Xie wrote:

      > In gvim 6.x (till 6.1b), when switch to insert mode the second time,
      > XIM cannot be evoked.
      > For example, the first time I press "i" and come to insert mode, I could
      > press "Ctrl+Space" to evoke my XIM and input Chinese. Then I press "Esc"
      > and press "i" again, from now on, "Ctrl+Space" will input a space instead
      > of calling out the XIM.
      > Vim in RXVT, gvim for win32, gvim 5.8 and other XWindow programs
      > don't have this problem.

      I don't know what causes this problem. I'll forward the message to the
      vim-multibyte list.

      --
      I'd like to meet the man who invented sex and see what he's working on now.

      /// Bram Moolenaar -- Bram@... -- http://www.moolenaar.net \\\
      /// Creator of Vim -- http://vim.sf.net -- ftp://ftp.vim.org/pub/vim \\\
      \\\ Project leader for A-A-P -- http://www.a-a-p.org ///
      \\\ Help me helping AIDS orphans in Uganda - http://iccf-holland.org ///
    • Nam SungHyun
      ... I met such a problem when the next variables were introduced (gvim tries to control IM status, but there was some issue... uhmm...). Now I have no problem
      Message 2 of 2 , Mar 14, 2002
      • 0 Attachment
        Bram Moolenaar wrote:
        >
        > Yuheng Xie wrote:
        >
        > > In gvim 6.x (till 6.1b), when switch to insert mode the second time,
        > > XIM cannot be evoked.
        > > For example, the first time I press "i" and come to insert mode,
        > > I could press "Ctrl+Space" to evoke my XIM and input Chinese. Then I
        > > press "Esc" and press "i" again, from now on, "Ctrl+Space" will
        > > input a space instead of calling out the XIM.
        > > Vim in RXVT, gvim for win32, gvim 5.8 and other XWindow programs
        > > don't have this problem.
        >
        > I don't know what causes this problem. I'll forward the message to the
        > vim-multibyte list.

        I met such a problem when the next variables were introduced (gvim
        tries to control IM status, but there was some issue... uhmm...).
        Now I have no problem with these setting. It might help you.

        set noimdisable noimcmdline imsearch=0 iminsert=0
        set imactivatekey=S-space

        Or recent Yasuhiro's patch (imactivatekey related) might help?
        I didn't try that patch.

        Regards,
        namsh
      Your message has been successfully submitted and would be delivered to recipients shortly.