Loading ...
Sorry, an error occurred while loading the content.

problems with hebrew utf-8

Expand Messages
  • Stephen Fleischman
    I have been attempting to use gvim 6.0 on Windows to type mixed Hebrew and English text and not having great success. After setting the encoding=utf8; the
    Message 1 of 2 , Feb 3, 2002
    • 0 Attachment
      I have been attempting to use gvim 6.0 on Windows to type mixed Hebrew
      and English text and not having great success. After setting the
      encoding=utf8; the Hebrew keymap and righttoleft mode (set rl), I can
      type in logical order and get the Hebrew. Then leaving right to left
      mode (set norl), the Hebrew remains in the correct direction. However,
      if I put the cursor on each Hebrew letter, the text will reverse.
      Actually, each character that the cursor is placed on displays the
      character in the same position in the reverse order (e.g., if in logical
      text order a line consists of aleph bet gimel putting the curser on the
      gimel will cause it to display aleph in that position. ^L will restore
      it. If one then attempts to insert latin characters, the hebrew becomes
      permanently reverse.

      I am trying to write Perl scripts that will deal with modifying Hebrew
      text and will need to mix English (actually Perl code) with the Hebrew.

      Are there known bugs and have any been fixed? Is there a more recently
      patched binary for the Windows Gvim?

      Thanks.
    • Ron Aaron
      ... This is an old bug; what exact version of 6.0 are you using, on what version of Windows? Ron
      Message 2 of 2 , Feb 3, 2002
      • 0 Attachment
        Stephen Fleischman <sfleisch@...> writes:
        >I have been attempting to use gvim 6.0 on Windows to type mixed Hebrew
        >and English text and not having great success. After setting the
        >encoding=utf8; the Hebrew keymap and righttoleft mode (set rl), I can
        >type in logical order and get the Hebrew. Then leaving right to left
        >mode (set norl), the Hebrew remains in the correct direction. However,
        >if I put the cursor on each Hebrew letter, the text will reverse.
        >Actually, each character that the cursor is placed on displays the
        >character in the same position in the reverse order (e.g., if in logical
        >text order a line consists of aleph bet gimel putting the curser on the
        >gimel will cause it to display aleph in that position. ^L will restore
        >it. If one then attempts to insert latin characters, the hebrew becomes
        >permanently reverse.
        >
        >I am trying to write Perl scripts that will deal with modifying Hebrew
        >text and will need to mix English (actually Perl code) with the Hebrew.
        >
        >Are there known bugs and have any been fixed? Is there a more recently
        >patched binary for the Windows Gvim?
        >
        >Thanks.

        This is an old bug; what exact version of 6.0 are you using, on what version
        of Windows?

        Ron
      Your message has been successfully submitted and would be delivered to recipients shortly.