Loading ...
Sorry, an error occurred while loading the content.

Re: ATOK X (XIM) doesn't work with Vim 6.0

Expand Messages
  • Takuhiro Nishioka
    Hi, ... OS: Turbo Linux 6.1 IM server: kinput2x Conversion server: atok12x Vim version: Vim 6.0.11 [bug] Vim hangs up when
    Message 1 of 5 , Jan 8, 2002
    • 0 Attachment
      Hi,

      >> ATOK X (XIM) doesn't work with Vim 6.0 on Linux. With Vim 5.8, it works
      >> well.
      >
      >Well, I have no idea what causes this or how to fix it. Hopefully you
      >or someone else can provide additional information.

      OS: Turbo Linux 6.1
      IM server: kinput2x
      Conversion server: atok12x
      Vim version: Vim 6.0.11

      [bug]

      Vim hangs up when using fFtT command with XIM.

      [how to reproduce the bug]

      1. compile Vim with these options:
      --enable-multibyte --enable-fontset --enable-xim --with-x
      2. options value that related with XIM
      iminsert = 0
      imsearch = 0
      imactivatekey=s-space
      3. start gvim.
      4. enter insert mode.
      5. turn on XIM pressing <S-Space>.
      6. go back to normal mode pressing <Esc>.
      7. press f to find a character.
      8. enter a character to search forward.

      --
      Takuhiro Nishioka mailto:takuhiro@...
    • Bram Moolenaar
      ... I can use XIM in my own environment, and it works OK here. I can t use the environment you mention. Hopefully you or someone else can track down this
      Message 2 of 5 , Jan 9, 2002
      • 0 Attachment
        Takuhiro Nishioka wrote:

        > >> ATOK X (XIM) doesn't work with Vim 6.0 on Linux. With Vim 5.8, it works
        > >> well.
        > >
        > >Well, I have no idea what causes this or how to fix it. Hopefully you
        > >or someone else can provide additional information.
        >
        > OS: Turbo Linux 6.1
        > IM server: kinput2x
        > Conversion server: atok12x
        > Vim version: Vim 6.0.11
        >
        > [bug]
        >
        > Vim hangs up when using fFtT command with XIM.
        >
        > [how to reproduce the bug]
        >
        > 1. compile Vim with these options:
        > --enable-multibyte --enable-fontset --enable-xim --with-x
        > 2. options value that related with XIM
        > iminsert = 0
        > imsearch = 0
        > imactivatekey=s-space
        > 3. start gvim.
        > 4. enter insert mode.
        > 5. turn on XIM pressing <S-Space>.
        > 6. go back to normal mode pressing <Esc>.
        > 7. press f to find a character.
        > 8. enter a character to search forward.

        I can use XIM in my own environment, and it works OK here. I can't use
        the environment you mention.

        Hopefully you or someone else can track down this problem and suggest a
        good solution. First thing to do is to find out if it's really Vim that
        is the problem, or perhaps the XIM or something else.

        --
        A parent can be arrested if his child cannot hold back a burp during a church
        service.
        [real standing law in Nebraska, United States of America]

        /// Bram Moolenaar -- Bram@... -- http://www.moolenaar.net \\\
        ((( Creator of Vim -- http://vim.sf.net -- ftp://ftp.vim.org/pub/vim )))
        \\\ Help me helping AIDS orphans in Uganda - http://iccf-holland.org ///
      • Takuhiro Nishioka
        Hi, ... I m exchanging some Japanese e-mails with Matsumoto-san (mattn_jp@hotmail.com) about this. I m not sure that Vim is the problem. Matsumoto-san said
        Message 3 of 5 , Jan 9, 2002
        • 0 Attachment
          Hi,

          >I can use XIM in my own environment, and it works OK here. I can't use
          >the environment you mention.
          >
          >Hopefully you or someone else can track down this problem and suggest a
          >good solution. First thing to do is to find out if it's really Vim that
          >is the problem, or perhaps the XIM or something else.

          I'm exchanging some Japanese e-mails with Matsumoto-san
          (mattn_jp@...) about this. I'm not sure that Vim is the problem.
          Matsumoto-san said kinput2 version 2 works well. kinput2 version 3 with some
          modification doesn't work well.

          --
          Takuhiro Nishioka mailto:takuhiro@...
        Your message has been successfully submitted and would be delivered to recipients shortly.