Loading ...
Sorry, an error occurred while loading the content.
 

'imi' default value (Re: win2k IME...)

Expand Messages
  • Muraoka Taro
    That default value may be for XIM. It make XIM set focus to vim. This was required by some version of XIM users. I don t like this default value 2. But I can
    Message 1 of 2 , Oct 10, 2001
      That default value may be for XIM.
      It make XIM set focus to vim.
      This was required by some version of XIM users.

      I don't like this default value 2.
      But I can "set iminsert=0" in my vimrc,
      so I don't care about it.
      Probably, some documentation is needed.
      ----
      Muraoka Taro <koron@...>


      > The default value of iminsert with IM compiled in is 2; with IME2k,
      > this sets the input language to Japanese. This was rather confusing and
      > took quite a while to track down, as applications normally don't change
      > the input mode on start by default.
      >
      > Is this the intent? (I've never seen another application do this.) Setting
      > it to 0 restored expected behavior, but that's nontrivial to find.
      >
      > --
      > Glenn Maynard
      >
    • Glenn Maynard
      ... The default should be reasonable for the system it s running on. If this can be figured out at compile-time, this is easy (set to 0 if Windows, 2 if X);
      Message 2 of 2 , Oct 10, 2001
        On Wed, Oct 10, 2001 at 05:48:12PM +0900, Muraoka Taro wrote:
        > That default value may be for XIM.
        > It make XIM set focus to vim.
        > This was required by some version of XIM users.
        >
        > I don't like this default value 2.
        > But I can "set iminsert=0" in my vimrc,
        > so I don't care about it.
        > Probably, some documentation is needed.

        The default should be reasonable for the system it's running on. If
        this can be figured out at compile-time, this is easy (set to 0 if
        Windows, 2 if X); if 2 is needed for non-IME2K IM's in Windows, this'll
        need to be figured out at runtime. I can't suggest changing the
        compile-time default since I don't know how this works on other IMEs in
        Windows.

        --
        Glenn Maynard
      Your message has been successfully submitted and would be delivered to recipients shortly.