Loading ...
Sorry, an error occurred while loading the content.

selection

Expand Messages
  • Ričardas Čepas
    Hi! I have found one non-english character selection bug, don t know if this is Vim problem or GTK. When copying UTF-8 characters from gvim (GTK) to gvim or
    Message 1 of 6 , Aug 31, 2001
    • 0 Attachment
      Hi!

      I have found one non-english character selection bug, don't know if this is Vim problem or GTK. When copying UTF-8 characters from gvim (GTK) to gvim or from xterm vim to xterm vim it works as expected. But when copying from gvim to xterm vim or from vim to gvim some characters get lost, I think these containing 0x80-0x9F bytes. Copying from xterm vim to mozilla and vice versa does work as expected.

      Best Regards,
      Richard.

      :version
      VIM - Vi IMproved 6.0at BETA (2001 Aug 27, compiled Aug 30 2001 21:51:21)
      Compiled by rch@...
      Big version with GTK GUI. Features included (+) or not (-):
      +autocmd -balloon_eval +browse ++builtin_terms +byte_offset +cindent +clientserver +clipboard +cmdline_compl
      +cmdline_hist +cmdline_info +comments +cryptv +cscope +dialog_con_gui +diff +digraphs -ebcdic +emacs_tags +eval
      +ex_extra +extra_search +farsi +file_in_path +find_in_path +folding -footer +fork() +gettext -hangul_input +iconv
      +insert_expand +jumplist +keymap +langmap +libcall +linebreak +lispindent +listcmds +localmap +menu +mksession
      +modify_fname +mouse +mouseshape +mouse_dec -mouse_gpm -mouse_jsbterm +mouse_netterm +mouse_xterm +multi_byte
      +multi_lang -osfiletype +path_extra +perl +postscript +printer -python +quickfix +rightleft -ruby +scrollbind +signs
      +smartindent -sniff +statusline -sun_workshop +syntax +tag_binary +tag_old_static -tag_any_white +tcl +terminfo
      +termresponse +textobjects +title +toolbar +user_commands +vertsplit +virtualedit +visual +visualextra +viminfo
      +vreplace +wildignore +wildmenu +windows +writebackup +X11 +xfontset -xim +xterm_clipboard -xterm_save
      system vimrc file: "$VIM/vimrc"
      user vimrc file: "$HOME/.vimrc"
      user exrc file: "$HOME/.exrc"
      system gvimrc file: "$VIM/gvimrc"
      user gvimrc file: "$HOME/.gvimrc"
      system menu file: "$VIMRUNTIME/menu.vim"
      fall-back for $VIM: "/usr/local/share/vim"
      Compilation: gcc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_GTK -I/usr/X11R6/include/gtk12 -I/usr/local/include/glib12 -
      I/usr/local/include -I/usr/X11R6/include -I/usr/local/include -O2 -pipe -march=i686 -I/usr/X11R6/include -fno-strict-a
      liasing -I/usr/local/include -I/usr/lib/perl5/5.6.1/i386-freebsd/CORE -I/usr/local/include/tcl8.0
      Linking: gcc -L/usr/X11R6/lib -Wl,-R/usr/lib/perl5/5.6.1/i386-freebsd/CORE -L/usr/local/lib -o vim -L/usr/X11R6/lib
      -L/usr/X11R6/lib -lgtk12 -lgdk12 -L/usr/local/lib -Wl,-E -lgmodule12 -lglib12 -lintl -lxpg4 -lXext -lXt -lncurses -lpos
      ix1e -lintl -Wl,-R/usr/lib/perl5/5.6.1/i386-freebsd/CORE -Wl,-E -L/usr/local/lib /usr/lib/perl5/5.6.1/i386-freebsd/aut
      o/DynaLoader/DynaLoader.a -L/usr/lib/perl5/5.6.1/i386-freebsd/CORE -lperl -lcrypt -liconv -lutil -L/usr/local/lib -ltcl
      80 -lm
    • Bram Moolenaar
      ... I did a few simple tests but didn t see a problem. Can you give example text with which it fails? -- The question is: What do you do with your life? The
      Message 2 of 6 , Aug 31, 2001
      • 0 Attachment
        Ricardas Cepas wrote:

        > I have found one non-english character selection bug, don't know if
        > this is Vim problem or GTK. When copying UTF-8 characters from gvim
        > (GTK) to gvim or from xterm vim to xterm vim it works as expected.
        > But when copying from gvim to xterm vim or from vim to gvim some
        > characters get lost, I think these containing 0x80-0x9F bytes.
        > Copying from xterm vim to mozilla and vice versa does work as
        > expected.

        I did a few simple tests but didn't see a problem. Can you give example
        text with which it fails?

        --
        The question is: What do you do with your life?
        The wrong answer is: Become the richest guy in the graveyard.
        (billionaire and Oracle founder Larry Ellison)

        /// Bram Moolenaar -- Bram@... -- http://www.moolenaar.net \\\
        ((( Creator of Vim -- http://vim.sf.net -- ftp://ftp.vim.org/pub/vim )))
        \\\ Help me helping AIDS orphans in Uganda - http://iccf-holland.org ///
      • Ričardas Čepas
        ... For example here are two strings: ččččččččččč ššššššššššš First one consists of c caron characters (c4 8d, Hex 010d). Second one
        Message 3 of 6 , Aug 31, 2001
        • 0 Attachment
          On Fri Aug 31 20:57:00 2001 +0200 Bram Moolenaar wrote:

          >
          > Ricardas Cepas wrote:
          >
          > > I have found one non-english character selection bug, don't know if
          > > this is Vim problem or GTK. When copying UTF-8 characters from gvim
          > > (GTK) to gvim or from xterm vim to xterm vim it works as expected.
          > > But when copying from gvim to xterm vim or from vim to gvim some
          > > characters get lost, I think these containing 0x80-0x9F bytes.
          > > Copying from xterm vim to mozilla and vice versa does work as
          > > expected.
          >
          > I did a few simple tests but didn't see a problem. Can you give example
          > text with which it fails?
          >
          For example here are two strings:
          ččččččččččč
          ššššššššššš
          First one consists of c caron characters (c4 8d, Hex 010d). Second one consists of s caron (c5 a1, Hex 0161). I can copy and paste second one from xterm vim into gvim, but when I try to copy and paste first one I get nothing. GTK is 1.2.9, XFree 4.1.0 if that makes difference. set=isprint? gives:
          isprint=@,32-255,^127
          I can input these characters from keyboard in all cases.
          --
          ☻ Ričardas Čepas ☺
          ~~
          ~
        • Bram Moolenaar
          ... It works fine for me. I m using xterm 157, compiled with wide characters. Both gvim and xterm are using utf-8 encoding. -- ARTHUR: Then who is your
          Message 4 of 6 , Sep 1, 2001
          • 0 Attachment
            Ricardas Cepas wrote:

            > > > I have found one non-english character selection bug, don't know if
            > > > this is Vim problem or GTK. When copying UTF-8 characters from gvim
            > > > (GTK) to gvim or from xterm vim to xterm vim it works as expected.
            > > > But when copying from gvim to xterm vim or from vim to gvim some
            > > > characters get lost, I think these containing 0x80-0x9F bytes.
            > > > Copying from xterm vim to mozilla and vice versa does work as
            > > > expected.
            > >
            > > I did a few simple tests but didn't see a problem. Can you give example
            > > text with which it fails?
            > >
            > For example here are two strings:
            > ����������������������
            > ����������������������
            > First one consists of c caron characters (c4 8d, Hex 010d). Second
            > one consists of s caron (c5 a1, Hex 0161). I can copy and paste
            > second one from xterm vim into gvim, but when I try to copy and paste
            > first one I get nothing. GTK is 1.2.9, XFree 4.1.0 if that makes
            > difference. set=isprint? gives:
            > isprint=@,32-255,^127
            > I can input these characters from keyboard in all cases.

            It works fine for me. I'm using xterm 157, compiled with wide
            characters. Both gvim and xterm are using utf-8 encoding.

            --
            ARTHUR: Then who is your lord?
            WOMAN: We don't have a lord.
            ARTHUR: What?
            DENNIS: I told you. We're an anarcho-syndicalist commune. We take it in
            turns to act as a sort of executive officer for the week.
            The Quest for the Holy Grail (Monty Python)

            /// Bram Moolenaar -- Bram@... -- http://www.moolenaar.net \\\
            ((( Creator of Vim -- http://vim.sf.net -- ftp://ftp.vim.org/pub/vim )))
            \\\ Help me helping AIDS orphans in Uganda - http://iccf-holland.org ///
          • Ričardas Čepas
            ... Hmm, maybe it is GTK bug. I have found now that the same happens for me to some other GTK programms as well. -- ☻ Ričardas Čepas ☺ ~~ ~
            Message 5 of 6 , Sep 1, 2001
            • 0 Attachment
              On Sat Sep 1 13:16:57 2001 +0200 Bram Moolenaar wrote:

              >
              > Ricardas Cepas wrote:
              >
              > > > > I have found one non-english character selection bug, don't know if
              > > > > this is Vim problem or GTK. When copying UTF-8 characters from gvim
              > > > > (GTK) to gvim or from xterm vim to xterm vim it works as expected.
              > > > > But when copying from gvim to xterm vim or from vim to gvim some
              > > > > characters get lost, I think these containing 0x80-0x9F bytes.
              > > > > Copying from xterm vim to mozilla and vice versa does work as
              > > > > expected.
              > > >
              > > > I did a few simple tests but didn't see a problem. Can you give example
              > > > text with which it fails?
              > > >
              > > For example here are two strings:
              > > ččččččččččč
              > > ššššššššššš
              > > First one consists of c caron characters (c4 8d, Hex 010d). Second
              > > one consists of s caron (c5 a1, Hex 0161). I can copy and paste
              > > second one from xterm vim into gvim, but when I try to copy and paste
              > > first one I get nothing. GTK is 1.2.9, XFree 4.1.0 if that makes
              > > difference. set=isprint? gives:
              > > isprint=@,32-255,^127
              > > I can input these characters from keyboard in all cases.
              >
              > It works fine for me. I'm using xterm 157, compiled with wide
              > characters. Both gvim and xterm are using utf-8 encoding.
              >
              Hmm, maybe it is GTK bug. I have found now that the same happens for me to some other GTK programms as well.

              --
              ☻ Ričardas Čepas ☺
              ~~
              ~
            • Bram Moolenaar
              ... I did try it with the GTK version. Thus it s unlikely GTK itself. I m using GTK 1.2.10, if that matters. -- ARTHUR: You fight with the strength of many
              Message 6 of 6 , Sep 1, 2001
              • 0 Attachment
                Ricardas Cepas wrote:

                > > It works fine for me. I'm using xterm 157, compiled with wide
                > > characters. Both gvim and xterm are using utf-8 encoding.
                > >
                > Hmm, maybe it is GTK bug. I have found now that the same
                > happens for me to some other GTK programms as well.

                I did try it with the GTK version. Thus it's unlikely GTK itself. I'm
                using GTK 1.2.10, if that matters.

                --
                ARTHUR: You fight with the strength of many men, Sir knight.
                I am Arthur, King of the Britons. [pause]
                I seek the finest and the bravest knights in the land to join me
                in my Court of Camelot. [pause]
                You have proved yourself worthy; will you join me? [pause]
                You make me sad. So be it. Come, Patsy.
                BLACK KNIGHT: None shall pass.
                The Quest for the Holy Grail (Monty Python)

                /// Bram Moolenaar -- Bram@... -- http://www.moolenaar.net \\\
                ((( Creator of Vim -- http://vim.sf.net -- ftp://ftp.vim.org/pub/vim )))
                \\\ Help me helping AIDS orphans in Uganda - http://iccf-holland.org ///
              Your message has been successfully submitted and would be delivered to recipients shortly.