Loading ...
Sorry, an error occurred while loading the content.

Re: Might be a bug for IME Chinese inpu

Expand Messages
  • Bram Moolenaar
    ... I suspect that the Chinese only appears in the IME window. When you hit CR the bytes are sent to Vim and not interpreted correctly. What do you have
    Message 1 of 5 , Aug 9, 2001
    • 0 Attachment
      Xiangjiang Ma wrote:

      > Might be a bug for IME Chinese input from English version of Windows 2000
      > Professional.
      >
      > I downloaded pc/vim60aq and compiled it using bc5 without
      > changing anything. gvim.exe worked great and has +multi-byte-ime
      > feature installed as default.
      >
      > Now, I turned on Global IME by hitting Left_Alt-Shift key.
      > I could see Chinese as soon I type "ma" (mother in Chinese).
      > I did see Chinese, however, whenever I hit enter or hit Esc,
      > all of my input disappeared. The only thing I got is ??????.
      >
      > Attached please find screen shot of my input. However, I was
      > unable to save Chinese (in multibyte) into my text file.

      I suspect that the Chinese only appears in the IME window. When you hit CR
      the bytes are sent to Vim and not interpreted correctly.

      What do you have 'encoding' set to? Try setting it to "cp936". You then may
      also have to select another font. Unfortunately, this isn't done
      automatically yet. Vim should pick up the 'encoding' from the environment
      and select a good font for it, but I don't know how to do that.

      > It is exciting to be able to input Chinese within vim, though.

      Please give it some testing. It has not been used much yet.

      --
      GALAHAD: No look, really, this isn't nescess ...
      PIGLET: We must examine you.
      GALAHAD: There's nothing wrong with ... that.
      "Monty Python and the Holy Grail" PYTHON (MONTY) PICTURES LTD

      /// Bram Moolenaar -- Bram@... -- http://www.moolenaar.net \\\
      ((( Creator of Vim -- http://vim.sf.net -- ftp://ftp.vim.org/pub/vim )))
      \\\ Help me helping AIDS orphans in Uganda - http://iccf-holland.org ///
    • Bram Moolenaar
      ... Thanks, that rules out some of the possible causes. It seems that the bytes which IME sends to Vim somehow don t end up correctly. I m afraid I don t know
      Message 2 of 5 , Aug 9, 2001
      • 0 Attachment
        Xiangjiang Ma wrote:

        > Attached please find my screen shot.
        >
        > 1. I can see Chinese article without any problem.
        > In fact, I always "cut and paste" Chinese from IE to my vim and read the
        > news
        > 2. encoding and guifont have to be set correctly to read Chinese within vim
        > As I checked with :se encoding?, and :se guifonts?, I did find they are
        > correct!
        > 3. I could type Chinese, but I couldn't save my typing.

        Thanks, that rules out some of the possible causes.

        It seems that the bytes which IME sends to Vim somehow don't end up correctly.
        I'm afraid I don't know why.

        You don't have 'termencoding' set, do you?

        --
        Not too long ago, a keyboard was something to make music with...

        /// Bram Moolenaar -- Bram@... -- http://www.moolenaar.net \\\
        ((( Creator of Vim -- http://vim.sf.net -- ftp://ftp.vim.org/pub/vim )))
        \\\ Help me helping AIDS orphans in Uganda - http://iccf-holland.org ///
      • Bram Moolenaar
        ... I ll copy it there. ... OK, thus it s also not a problem with termencoding . This points in the direction of a problem with bytes from IME not ending up
        Message 3 of 5 , Aug 9, 2001
        • 0 Attachment
          Xiangjiang Ma wrote:

          > Can you forwarded our discussions to multi-byte guys out there?
          > I used <vim-multibyte@...>, but it bounncd back.

          I'll copy it there.

          > As for termencoding, I tried both, neither worked.
          >
          > ====================case 1
          > set encoding=prc
          > set termencoding=
          >
          > ====================case 2
          > set encoding=prc
          > set termencoding=prc

          OK, thus it's also not a problem with 'termencoding'. This points in the
          direction of a problem with bytes from IME not ending up in Vim as they were
          intended. I suppose this worked in the past. Hopefully someone can find out
          why it stopped working, I don't have a system to try this on.

          > > Xiangjiang Ma wrote:
          > >
          > > > Attached please find my screen shot.
          > > >
          > > > 1. I can see Chinese article without any problem.
          > > > In fact, I always "cut and paste" Chinese from IE to my vim and read
          > > > the news
          > > > 2. encoding and guifont have to be set correctly to read Chinese within
          > > > vim As I checked with :se encoding?, and :se guifonts?, I did find
          > > > they are correct!
          > > > 3. I could type Chinese, but I couldn't save my typing.
          > >
          > > Thanks, that rules out some of the possible causes.
          > >
          > > It seems that the bytes which IME sends to Vim somehow don't
          > > end up correctly.
          > > I'm afraid I don't know why.
          > >
          > > You don't have 'termencoding' set, do you?

          --
          LAUNCELOT leaps into SHOT with a mighty cry and runs the GUARD through and
          hacks him to the floor. Blood. Swashbuckling music (perhaps).
          LAUNCELOT races through into the castle screaming.
          SECOND SENTRY: Hey!
          "Monty Python and the Holy Grail" PYTHON (MONTY) PICTURES LTD

          /// Bram Moolenaar -- Bram@... -- http://www.moolenaar.net \\\
          ((( Creator of Vim -- http://vim.sf.net -- ftp://ftp.vim.org/pub/vim )))
          \\\ Help me helping AIDS orphans in Uganda - http://iccf-holland.org ///
        • Muraoka Taro
          I know all version of Windows2000 has supported IME instead of GlobalIME. So I know there are no GlobalIME for Windows2000. Where did you get GlobalIME for
          Message 4 of 5 , Aug 9, 2001
          • 0 Attachment
            I know all version of Windows2000 has supported IME instead of
            GlobalIME. So I know there are no GlobalIME for Windows2000. Where did
            you get GlobalIME for Windows2000? If you want to install IME supported
            by OS, you can add it in "Control Pannel" -> "Regional Options" ->
            "Input Locales". See below URLs.

            - Microsoft
            http://www.microsoft.com/globaldev/win2k/setup/default.asp

            - for Japanese but it may work for Chinese.
            http://www.seanspot.com/jwrite/MS-IME/GetIME/jwrite-getime-w2k.htm
            ----
            Muraoka Taro <koron@...>



            >
            > Xiangjiang Ma wrote:
            >
            > > Might be a bug for IME Chinese input from English version of Windows 2000
            > > Professional.
            > >
            > > Now, I turned on Global IME by hitting Left_Alt-Shift key.
            > > I could see Chinese as soon I type "ma" (mother in Chinese).
          • Muraoka Taro
            I just remember and have tested this. Did you set Language settings for the system in Regional Options - General to chinese? You must set this to
            Message 5 of 5 , Aug 9, 2001
            • 0 Attachment
              I just remember and have tested this. Did you set "Language settings
              for the system" in "Regional Options" -> "General" to chinese? You must
              set this to "Simplified Chinese" or other. Previously I have seen a
              similar question on a mailing list. Please check top of below page
              for setting details.

              http://www.seanspot.com/jwrite/MS-IME/GetIME/jwrite-getime-w2k.htm

              Regards.
              ----
              Muraoka Taro <koron@...>


              ----- Original Message -----
              From: "Ma, Xiangjiang" <Xiangjiang.Ma@...>
              To: "'Muraoka Taro'" <koron@...>; "Bram Moolenaar" <Bram@...>
              Cc: <vim-multibyte@...>
              Sent: Friday, August 10, 2001 8:06 AM
              Subject: RE: Might be a bug for IME Chinese inpu


              >
              > > all version of Windows2000 has supported IME
              > Yes, you are right.
              >
              > > by OS, you can add it in "Control Pannel" -> "Regional Options" ->
              > > "Input Locales". See below URLs.
              >
              > That is exactly what I did.
              >
              > However, I could not be able to insert anything except ??? into my vim buffer.
              >
              > Thanks.
            Your message has been successfully submitted and would be delivered to recipients shortly.