Loading ...
Sorry, an error occurred while loading the content.

Re: Patch 5.6.037 causes a side effect

Expand Messages
  • Takuhiro Nishioka
    Hello! ... Yes, I m usually using rxvt-with-overthespot. But in this case, I m talking about Gtk GUI version Vim, sorry for didn t mention about it. ... Yes.
    Message 1 of 7 , Jun 25, 2000
    • 0 Attachment
      Hello!

      Sung-Hyun Nam wrote:
      > Imagine you run 'vim' on the rxvt-with-overthespot.
      > There's no different with gvim+above-patch.

      Yes, I'm usually using rxvt-with-overthespot. But in this
      case, I'm talking about Gtk GUI version Vim, sorry for
      didn't mention about it.

      > You cannot input multibyte character with 'f' without
      > the patch.

      Yes.

      >> Because we need to turn on XIM after "f" by hands, then off after the
      >> command.
      >
      > you said it is side-effect?

      No.

      > I don't understand 'a side effect'.
      [...]
      > And if you didnot input multibyte char with 'f', what is
      > different?

      The side effect means that, thanks to this patch, we can
      input a multibyte character after "f" like commands, but
      this patch disables XIM control on GVim.

      The side effect is that it disables XIM control on GVim
      (possibly with Japanese XIM only?).

      > With Over-The-Spot, focus and unfocus is not important with my IM
      > server. It didn't do anything when I input english character.
      > But your IM server has different behavior?
      [...]
      > With the patch, gvim always connect to XIM. But your case,
      > unfocus is important?

      Yes, it is important for Japanese XIM. Because when
      inputting English characters, it should not focus on XIM.
      We need some extra procedure to input English characters
      when XIM is focused. Focusing off XIM, we can input
      English characters directly.

      Normally, to input English characters, first we turn off
      XIM, then input English characters. This is true for
      executing normal commands. Thanks to focus-unfocus
      system, we don't need to do this by hands (yes, we don't
      have focus-unfocus system on terminal emulators). But
      this patch disables the focus-unfocus system on GVim.

      > PS) Because I used on-the-spot method (from a month ago or so),
      > I may not understand your problem. If your IM server
      > supports On-The-Spot and if you use gtk+ gui, I can send this
      > unofficial patch to you.
      > (This patch made by Chi-Deok Hwang, and he didn't send
      > it to mailing list yet).

      Wow, that will be great! Please send me it. And if
      possible, please send the patch to this mailing list so
      that other can test.

      --
      Takuhiro Nishioka mailto:takuhiro@...
    • Sung-Hyun Nam
      ... Ah! I couldn t imagine this situation. We normally use language toggle hotkey (my case shift+space). Though the IM server has focus, if current language
      Message 2 of 7 , Jun 25, 2000
      • 0 Attachment
        Takuhiro Nishioka wrote:
        >
        > Sung-Hyun Nam wrote:
        >
        > [...]
        >
        > > With Over-The-Spot, focus and unfocus is not important with my IM
        > > server. It didn't do anything when I input english character.
        > > But your IM server has different behavior?
        > [...]
        > > With the patch, gvim always connect to XIM. But your case,
        > > unfocus is important?
        >
        > Yes, it is important for Japanese XIM. Because when
        > inputting English characters, it should not focus on XIM.
        > We need some extra procedure to input English characters
        > when XIM is focused. Focusing off XIM, we can input
        > English characters directly.
        >
        > Normally, to input English characters, first we turn off
        > XIM, then input English characters. This is true for
        > executing normal commands. Thanks to focus-unfocus
        > system, we don't need to do this by hands (yes, we don't
        > have focus-unfocus system on terminal emulators). But
        > this patch disables the focus-unfocus system on GVim.

        Ah! I couldn't imagine this situation. We normally use
        language toggle hotkey (my case shift+space). Though the
        IM server has focus, if current language mode is english,
        IM server don't do anything. It just bypass all the keys
        to gvim because it knows user inputs english character.

        So, you want that patch removed...
        Bram, I don't care. Yes, it is not so usable yet.

        > > PS) Because I used on-the-spot method (from a month ago or so),
        > > I may not understand your problem. If your IM server
        > > supports On-The-Spot and if you use gtk+ gui, I can send this
        > > unofficial patch to you.
        > > (This patch made by Chi-Deok Hwang, and he didn't send
        > > it to mailing list yet).
        >
        > Wow, that will be great! Please send me it. And if
        > possible, please send the patch to this mailing list so
        > that other can test.

        I hope Hwang send it to list, because I don't know well about it.
        I cannot explain anything if someone want to comment about it...
        Anyway I will send it to you.

        namsh
      • Takuhiro Nishioka
        ... Yes. Or, if possible, I would like to have some other solution for f like commands with multibyte. ... Thanks! I ve tested with Gtk GUI version Vim 5.7.
        Message 3 of 7 , Jun 26, 2000
        • 0 Attachment
          Sung-Hyun Nam wrote:
          > So, you want that patch removed...

          Yes. Or, if possible, I would like to have some other
          solution for "f" like commands with multibyte.

          > I hope Hwang send it to list, because I don't know well about it.
          > I cannot explain anything if someone want to comment about it...
          > Anyway I will send it to you.

          Thanks!

          I've tested with Gtk GUI version Vim 5.7. This is great.
          But here is one problem.

          When connecting to XIM, pressing CTRL key makes GVim
          hangs.

          --
          Takuhiro Nishioka mailto:takuhiro@...
        • Sung-Hyun Nam
          ... If possible, your IM server should act like mine. Then you can also live with rxvt+vim. Anyway with a problem below, this is not related to Korean, I
          Message 4 of 7 , Jun 26, 2000
          • 0 Attachment
            Takuhiro Nishioka wrote:
            > Sung-Hyun Nam wrote:
            > > So, you want that patch removed...
            >
            > Yes. Or, if possible, I would like to have some other
            > solution for "f" like commands with multibyte.

            If possible, your IM server should act like mine.
            Then you can also live with rxvt+vim.

            Anyway with a problem below, this is not related to Korean, I believe.
            I don't understand your situation. I hope Japanese fix these
            problem.

            > > I hope Hwang send it to list, because I don't know well about it.
            > > I cannot explain anything if someone want to comment about it...
            > > Anyway I will send it to you.
            >
            > Thanks!
            >
            > I've tested with Gtk GUI version Vim 5.7. This is great.
            > But here is one problem.
            >
            > When connecting to XIM, pressing CTRL key makes GVim
            > hangs.

            I have no problem with CTRL key. I always use c-f c-b ... in normal
            mode and c-i ... in insert mode.
            It may be related to your IM server or is there special ctrl+? key
            to make gvim hangs?

            regards,

            namsh
          • Takuhiro Nishioka
            ... I m sorry for didn t mention that, this problem happenes with OnTheSpot patch. I m using FreeBSD 4.0-STABLE, XFree86 4.0. My XIM is kinput2 version 3 with
            Message 5 of 7 , Jun 26, 2000
            • 0 Attachment
              Sung-Hyun Nam wrote:
              > I have no problem with CTRL key. I always use c-f c-b ... in normal
              > mode and c-i ... in insert mode.
              > It may be related to your IM server or is there special ctrl+? key
              > to make gvim hangs?

              I'm sorry for didn't mention that, this problem happenes
              with OnTheSpot patch. I'm using FreeBSD 4.0-STABLE,
              XFree86 4.0. My XIM is kinput2 version 3 with Canna
              Kana-Kanji conversion server.

              Thanks to this patch, we can use OnTheSpot. Setting
              input-stype to OnTheSpot. For anyone that doesn't know
              OnTheSpot, I'll explain it.

              Here is a line, where ".." and ",," is multibyte
              characters.

              ..,,..,,..,,..,,..,,
              ~~<- cursor is here

              Using OnTheSpot input-style, preediting text "-------" is
              dynamically displayed.

              ..,,..--------,,..,,..,,..,,

              --
              Takuhiro Nishioka mailto:takuhiro@...
            Your message has been successfully submitted and would be delivered to recipients shortly.