Loading ...
Sorry, an error occurred while loading the content.
 

Re: Unable to display Hebrew correctly on Mac OS/X

Expand Messages
  • Ron Aaron
    I ve tried all four monospaced fonts on the Mac, and I get exactly the same results. Each word is drawn in reverse, e.g. it shows as ABC instead of CBA ,
    Message 1 of 9 , Mar 24, 2009
      I've tried all four 'monospaced' fonts on the Mac, and I get exactly
      the same results. Each word is drawn in reverse, e.g. it shows as
      "ABC" instead of "CBA", but the position in the sentence is correct.

      I find it hard to believe I'm the only person who has seen this
      behavior on Mac. In any case, I'm certain it must be do to the OS
      helping out. My OS is: Mac OS X 10.5.5, if that's relevant to the
      discussion.

      I'm not too keen to start dissecting the os_macosx.c ...

      Best,
      Ron
      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_multibyte" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • Tony Mechelynck
      ... Vim doesn t display true-bidi. With a normal (non-bidi) terminal, or in the GUI, you ll see the contents of each window displayed either all RTL or all
      Message 2 of 9 , Mar 24, 2009
        On 24/03/09 12:11, Ron Aaron wrote:
        >
        > I've tried all four 'monospaced' fonts on the Mac, and I get exactly
        > the same results. Each word is drawn in reverse, e.g. it shows as
        > "ABC" instead of "CBA", but the position in the sentence is correct.
        >
        > I find it hard to believe I'm the only person who has seen this
        > behavior on Mac. In any case, I'm certain it must be do to the OS
        > helping out. My OS is: Mac OS X 10.5.5, if that's relevant to the
        > discussion.
        >
        > I'm not too keen to start dissecting the os_macosx.c ...
        >
        > Best,
        > Ron

        Vim doesn't display true-bidi. With a "normal" (non-bidi) terminal, or
        in the GUI, you'll see the contents of each window displayed either all
        RTL or all LTR depending on the setting of the window-local 'rightleft'
        setting. This means that in mixed text you'll either see Latin script
        the right way and Hebrew script reversed, or the opposite -- your
        choice, and you can even have two windows with opposite directionality
        on a single file. I thought you knew all this.

        If you are using Console Vim in a true-bidi terminal, you should ":set
        norightleft termbidi" to tell Vim that the terminal is in charge of
        bidirectionality. Or at least when editing Arabic; I'm not sure how this
        option applies to Hebrew. I'm also not sure how the display of the text
        cursor is affected by this option.


        Best regards,
        Tony.
        --
        "What is the robbing of a bank compared to the FOUNDING of a bank?"
        -- Bertold Brecht

        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_multibyte" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • Ron Aaron
        On Mar 24, 1:44 pm, Tony Mechelynck ... Em, yes, I m well aware of all this, I ve been using vim with bidi text for many years
        Message 3 of 9 , Mar 24, 2009
          On Mar 24, 1:44 pm, Tony Mechelynck <antoine.mechely...@...>
          wrote:
          > Vim doesn't display true-bidi. With a "normal" (non-bidi) terminal, or
          > in the GUI, you'll see the contents of each window displayed either all
          > RTL or all LTR depending on the setting of the window-local 'rightleft'
          > setting. This means that in mixed text you'll either see Latin script
          > the right way and Hebrew script reversed, or the opposite -- your
          > choice, and you can even have two windows with opposite directionality
          > on a single file. I thought you knew all this.

          Em, yes, I'm well aware of all this, I've been using vim with bidi
          text for many years now.

          Again: I am using GUI vim, not Console vim. The 'termbidi' option
          doesn't apply.

          The problem seems to be related to the ATSUI renderer, at least there
          are some hints in 'gui_mac.c' that indicate this might be true. It
          may be a good thing to set "kATSULineDirectionTag" so the drawing
          occurs correctly, but I don't know enough about Mac GUI to know what
          to do exactly.

          If noone else chimes in with helpful information, I'll try to fix it
          myself.

          >
          > If you are using Console Vim in a true-bidi terminal, you should ":set
          > norightleft termbidi" to tell Vim that the terminal is in charge of
          > bidirectionality. Or at least when editing Arabic; I'm not sure how this
          > option applies to Hebrew. I'm also not sure how the display of the text
          > cursor is affected by this option.
          >
          > Best regards,
          > Tony.
          > --
          > "What is the robbing of a bank compared to the FOUNDING of a bank?"
          >                 -- Bertold Brecht
          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_multibyte" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        • björn
          Hi Ron, ... You are not telling us which version of Vim you are using but by the sounds of it you are using the outdated Carbon port. There is a newer port
          Message 4 of 9 , Mar 24, 2009
            Hi Ron,

            2009/3/24 Ron Aaron:
            >
            > Again: I am using GUI vim, not Console vim.  The 'termbidi' option
            > doesn't apply.
            >
            > The problem seems to be related to the ATSUI renderer, at least there
            > are some hints in 'gui_mac.c' that indicate this might be true.  It
            > may be a good thing to set "kATSULineDirectionTag" so the drawing
            > occurs correctly, but I don't know enough about Mac GUI to know what
            > to do exactly.
            >
            > If noone else chimes in with helpful information, I'll try to fix it
            > myself.

            You are not telling us which version of Vim you are using but by the
            sounds of it you are using the outdated Carbon port. There is a newer
            port called "MacVim" which can be downloaded here:

            http://code.google.com/p/macvim/

            I have also CCed this post to the vim_mac mailing list which is a more
            appropriate list for Mac specific problems.

            Please let me know how MacVim copes with your situation: if it doesn't
            work I'll look into it as soon as I get a chance.

            Björn

            --~--~---------~--~----~------------~-------~--~----~
            You received this message from the "vim_multibyte" maillist.
            For more information, visit http://www.vim.org/maillist.php
            -~----------~----~----~----~------~----~------~--~---
          • Ron Aaron
            Hi, Björn - I m using the latest vim - 7.2.148, with some additional patches of my own. Is the MacVim base totally separate from the main vim? I ll try the
            Message 5 of 9 , Mar 24, 2009
              Hi, Björn -

              I'm using the latest vim - 7.2.148, with some additional patches of my
              own. Is the "MacVim" base totally separate from the main vim?

              I'll try the MacVim port and see how it fares, thanks.
              Ron

              On Mar 24, 2:08 pm, björn <bjorn.winck...@...> wrote:

              > You are not telling us which version of Vim you are using but by the
              > sounds of it you are using the outdated Carbon port.  There is a newer
              > port called "MacVim" which can be downloaded here:
              >
              > http://code.google.com/p/macvim/

              --~--~---------~--~----~------------~-------~--~----~
              You received this message from the "vim_multibyte" maillist.
              For more information, visit http://www.vim.org/maillist.php
              -~----------~----~----~----~------~----~------~--~---
            • Tony Mechelynck
              ... IIUC, the MacVim base is basically the main Vim base, with some Mac-specific patches which never made it into Bram s sources. However some of the Mac
              Message 6 of 9 , Mar 24, 2009
                On 24/03/09 13:17, Ron Aaron wrote:
                >
                > Hi, Björn -
                >
                > I'm using the latest vim - 7.2.148, with some additional patches of my
                > own. Is the "MacVim" base totally separate from the main vim?

                IIUC, the MacVim base is basically the main Vim base, with some
                Mac-specific patches which never made it into Bram's sources. However
                some of the Mac people might expain it better than I can.


                Best regards,
                Tony.
                --
                Q: How many heterosexual males does it take to screw in a light bulb
                in San Francisco?
                A: Both of them.

                --~--~---------~--~----~------------~-------~--~----~
                You received this message from the "vim_multibyte" maillist.
                For more information, visit http://www.vim.org/maillist.php
                -~----------~----~----~----~------~----~------~--~---
              • björn
                ... Yes, MacVim works just like any other GUI port in that it hooks into the various gui_mch_*() calls. The big difference is that MacVim spawns one Vim
                Message 7 of 9 , Mar 24, 2009
                  2009/3/24 Tony Mechelynck:
                  >
                  > On 24/03/09 13:17, Ron Aaron wrote:
                  >>
                  >> Hi, Björn -
                  >>
                  >> I'm using the latest vim - 7.2.148, with some additional patches of my
                  >> own.  Is the "MacVim" base totally separate from the main vim?
                  >
                  > IIUC, the MacVim base is basically the main Vim base, with some
                  > Mac-specific patches which never made it into Bram's sources. However
                  > some of the Mac people might expain it better than I can.

                  Yes, MacVim works just like any other GUI port in that it hooks into
                  the various gui_mch_*() calls. The big difference is that MacVim
                  spawns one Vim process for each GUI-window and uses another process
                  (MacVim) to coordinate everything in order to be able to support
                  multiple GUI-windows. More details concerning the source code can be
                  found in src/MacVim/README. Note that there are some modifications to
                  the Vim codebase in the MacVim repo but these are intentionally few --
                  the bulk of the MacVim specific code resides in src/MacVim.

                  Björn

                  --~--~---------~--~----~------------~-------~--~----~
                  You received this message from the "vim_multibyte" maillist.
                  For more information, visit http://www.vim.org/maillist.php
                  -~----------~----~----~----~------~----~------~--~---
                Your message has been successfully submitted and would be delivered to recipients shortly.