Loading ...
Sorry, an error occurred while loading the content.

devanagari vim and word

Expand Messages
  • miten
    Hello, I read that vim supports unicode editing so tried to enter utf-8 characters using ctrl-v u followed by 4 digit hex code like 093f 092e 0947 0924 0928
    Message 1 of 2 , Oct 12, 2008
    • 0 Attachment
      Hello,

      I read that vim supports unicode editing so tried to enter utf-8
      characters using ctrl-v u followed by 4 digit hex code like
      093f
      092e
      0947
      0924
      0928

      all on one line. Of course the display was garbled but I assume thats
      how it looks on console. I am on win xp with vim version as below.

      Before insert mode in command mode I have tried setting encoding and
      fileencoding to utf8.

      After saving file I try opening in Microsoft Word it correctly prompts
      me to pick file format but utf-8 and others dont render the text as
      appropriate. I have Devanagari MT for IBM installed with MS Word so
      it should let me edit using devanagari font.

      Any idea what I need to do ?

      Below is detail of my vim version.

      Thanks.

      Miten Mehta
      miten.mehta@...
      imiten@...


      C:\Documents and Settings\Miten Mehta>vim --version
      VIM - Vi IMproved 7.2 (2008 Aug 9, compiled Aug 10 2008 10:52:25)
      Compiled by corinna@cathi
      Huge version without GUI. Features included (+) or not (-):
      +arabic +autocmd -balloon_eval -browse ++builtin_terms +byte_offset
      +cindent
      -clientserver -clipboard +cmdline_compl +cmdline_hist +cmdline_info
      +comments
      +cryptv +cscope +cursorshape +dialog_con +diff +digraphs -dnd -ebcdic
      +emacs_tags +eval +ex_extra +extra_search +farsi +file_in_path
      +find_in_path
      +float +folding -footer +fork() +gettext -hangul_input -iconv
      +insert_expand
      +jumplist +keymap +langmap +libcall +linebreak +lispindent +listcmds
      +localmap
      +menu +mksession +modify_fname +mouse -mouseshape +mouse_dec -
      mouse_gpm
      -mouse_jsbterm +mouse_netterm -mouse_sysmouse +mouse_xterm +multi_byte
      +multi_lang -mzscheme -netbeans_intg -osfiletype +path_extra -perl
      +postscript
      +printer +profile -python +quickfix +reltime +rightleft -ruby
      +scrollbind
      +signs +smartindent -sniff +statusline -sun_workshop +syntax
      +tag_binary
      +tag_old_static -tag_any_white -tcl +terminfo +termresponse
      +textobjects +title
      -toolbar +user_commands +vertsplit +virtualedit +visual +visualextra
      +viminfo
      +vreplace +wildignore +wildmenu +windows +writebackup -X11 -xfontset -
      xim -xsmp
      -xterm_clipboard -xterm_save
      system vimrc file: "$VIM/vimrc"
      user vimrc file: "$HOME/.vimrc"
      user exrc file: "$HOME/.exrc"
      fall-back for $VIM: "/usr/share/vim"
      Compilation: gcc -c -I. -Iproto -DHAVE_CONFIG_H -g -O2
      Linking: gcc -L/usr/local/lib -o vim.exe -lm -lncurses -lintl

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_multibyte" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • Tony Mechelynck
      ... Many Windows programs, when told that a certain file is Unicode, assume UTF-16 unless the file includes a BOM. So I recommend not only ... but also ... or
      Message 2 of 2 , Oct 12, 2008
      • 0 Attachment
        On 12/10/08 10:37, miten wrote:
        > Hello,
        >
        > I read that vim supports unicode editing so tried to enter utf-8
        > characters using ctrl-v u followed by 4 digit hex code like
        > 093f
        > 092e
        > 0947
        > 0924
        > 0928
        >
        > all on one line. Of course the display was garbled but I assume thats
        > how it looks on console. I am on win xp with vim version as below.
        >
        > Before insert mode in command mode I have tried setting encoding and
        > fileencoding to utf8.
        >
        > After saving file I try opening in Microsoft Word it correctly prompts
        > me to pick file format but utf-8 and others dont render the text as
        > appropriate. I have Devanagari MT for IBM installed with MS Word so
        > it should let me edit using devanagari font.
        >
        > Any idea what I need to do ?
        >
        > Below is detail of my vim version.
        >
        > Thanks.
        >
        > Miten Mehta
        > miten.mehta@...
        > imiten@...

        Many Windows programs, when told that a certain file is Unicode, assume
        UTF-16 unless the file includes a BOM. So I recommend not only

        :set enc=utf-8
        :set fencs=ucs-bom,utf-8,default,latin1
        :set fenc=
        but also
        :set bomb
        or at least
        :setglobal bomb

        Also, you should set 'termencoding' to whatever 'encoding' was set to at
        Vim startup, before you changed it to UTF-8.

        Best regards,
        Tony.
        --
        There is a Massachusetts law requiring all dogs to have their hind legs
        tied during the month of April.

        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_multibyte" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      Your message has been successfully submitted and would be delivered to recipients shortly.