Loading ...
Sorry, an error occurred while loading the content.

hangulinput option with UTF-8 locale

Expand Messages
  • Kiwon Um
    Hello there. Because of some problems with XIM, I checked the hangulinput option. But it doesn t seem to work well with UTF-8 locale. Is there anyway to use
    Message 1 of 3 , Jun 18, 2008
    • 0 Attachment
      Hello there.

      Because of some problems with XIM, I checked the hangulinput option.
      But it doesn't seem to work well with UTF-8 locale.
      Is there anyway to use this option with UTF-8 locale without changing
      it to EUC-KR?

      Thanks.
      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_multibyte" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • Tony Mechelynck
      ... I don t understand :help hangulin.txt very well. For instance, I still don t understand what 2 bulsik and 3 bulsik refer to. AFAICT (comparing that
      Message 2 of 3 , Jun 19, 2008
      • 0 Attachment
        On 19/06/08 06:34, Kiwon Um wrote:
        > Hello there.
        >
        > Because of some problems with XIM, I checked the hangulinput option.
        > But it doesn't seem to work well with UTF-8 locale.
        > Is there anyway to use this option with UTF-8 locale without changing
        > it to EUC-KR?
        >
        > Thanks.

        I don't understand ":help hangulin.txt" very well. For instance, I still
        don't understand what "2 bulsik" and "3 bulsik" refer to.

        AFAICT (comparing that helpfile with what is said in mbyte.txt),
        +hangul_input requires euc-kr, "korea" or maybe cp949 input, and it
        seems that the module author is not going to add new features. Anyway,
        as (IIUC) +hangul_input is not compatible with +gui_gtk2 (maybe because
        the latter uses exclusively UTF-8 when running in GUI mode), I cannot
        test it.

        Maybe you can try another XIM flavour (see
        http://en.wikipedia.org/wiki/List_of_input_methods_for_UNIX_platforms )?
        Or another mode of operation? Note that of the four possible modes,
        On-the-Spot is _not_ supported by gvim (see ":help xim-input-style").


        Best regards,
        Tony.
        --
        hundred-and-one symptoms of being an internet addict:
        12. You turn off your modem and get this awful empty feeling, like you just
        pulled the plug on a loved one.

        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_multibyte" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • Kiwon Um
        Thanks for your answer. On 6¿ù20ÀÏ, ¿ÀÀü1½Ã25ºÐ, Tony Mechelynck ... That s about how the Korean keys are aligned on
        Message 3 of 3 , Jun 22, 2008
        • 0 Attachment
          Thanks for your answer.

          On 6월20일, 오전1시25분, Tony Mechelynck <antoine.mechely...@...>
          wrote:
          > On 19/06/08 06:34,KiwonUm wrote:
          >
          > > Hello there.
          >
          > > Because of some problems with XIM, I checked the hangulinput option.
          > > But it doesn't seem to work well with UTF-8 locale.
          > > Is there anyway to use this option with UTF-8 locale without changing
          > > it to EUC-KR?
          >
          > > Thanks.
          >
          > I don't understand ":help hangulin.txt" very well. For instance, I still
          > don't understand what "2 bulsik" and "3 bulsik" refer to.
          >

          That's about how the Korean keys are aligned on the keyboard.
          Generally, almost all Korean, except some special(?) guys, uses 2
          bulsik keyboard now. :)

          > AFAICT (comparing that helpfile with what is said in mbyte.txt),
          > +hangul_input requires euc-kr, "korea" or maybe cp949 input, and it
          > seems that the module author is not going to add new features. Anyway,
          > as (IIUC) +hangul_input is not compatible with +gui_gtk2 (maybe because
          > the latter uses exclusively UTF-8 when running in GUI mode), I cannot
          > test it.
          >

          Unfortunate fact.... only euc-kr.. I wondered if there is any way to
          support utf-8 locale.

          > Maybe you can try another XIM flavour (seehttp://en.wikipedia.org/wiki/List_of_input_methods_for_UNIX_platforms)?
          > Or another mode of operation? Note that of the four possible modes,
          > On-the-Spot is _not_ supported by gvim (see ":help xim-input-style").
          >

          Actually my problem was from latex-vim with scim, not between vim and
          scim. I reported this issue into vim_use.
          Thanks again.

          Best regards,
          Kiwon Um.

          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_multibyte" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        Your message has been successfully submitted and would be delivered to recipients shortly.