Loading ...
Sorry, an error occurred while loading the content.

how can I ogonki-fy on Wind*ws?

Expand Messages
  • Joseph Schiller
    Hi, I love Vim s language support, but I am puzzled how can I ogonkify on Wind*ws platform as well as I can on Linux? For example, to enter extended latin-1
    Message 1 of 3 , Mar 12, 2008
    • 0 Attachment
      Hi,

      I love Vim's language support, but I am puzzled how
      can I ogonkify on Wind*ws platform as well as I can on
      Linux? For example, to enter extended latin-1
      characters in edit mode I use [CTRL+SHIFT+CODE]
      combinations as follows:

      [CTRL+SHIFT+<...>]:Ą<104>;ą<105>;Ć<106>;ć<107>;Ę<118>;ę<119>;
      Ł<141>;ł<142>;Ń<143>;ń<144>;Ó<D3>;ó<F3>;Ś<15A>;ś<15B>;Ż<17B>;
      ż<17C>;Ź<179>;ź<17A>

      The <number> in angle brackets corresponds to 2 or 3
      key combinations, and there are others for other
      languages.

      This shortcut works on gVim 7.0.35 built on SuSE 10.0
      with GTK+ 1.8.4 with +multi_byte and does not work on
      gVim 6.3 built on Damn Small Linux 3.5 normal version
      with GTK GUI with -multi_byte running on WinXP inside
      an emulator. It does not work in gVim 7.1 on
      MS-Wind*ws 32 bit with OLE support with
      +multi_byte_ime/dyn. Apparently the key is +multi_byte
      option.

      Inside the typical MS enabled apps we can use ALT+CODE
      using 4 digit combo when entered from the number
      keypad, such as MS Word. I've searched in the Vim
      documentation and tried google, but could not find any
      answers.

      Regards,

      Joe



      ____________________________________________________________________________________
      Never miss a thing. Make Yahoo your home page.
      http://www.yahoo.com/r/hs
      thing. Make Yahoo your home page.
      http://www.yahoo.com/r/hs

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_multibyte" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • Camillo Särs
      ... //Ged -- Camillo Särs Aim for the impossible and you http://www.ged.fi will achieve the improbable
      Message 2 of 3 , Mar 12, 2008
      • 0 Attachment
        Joseph Schiller wrote:
        > Inside the typical MS enabled apps we can use ALT+CODE
        > using 4 digit combo when entered from the number
        > keypad, such as MS Word. I've searched in the Vim
        > documentation and tried google, but could not find any
        > answers.

        :help i_CTRL-V_digit

        //Ged
        --
        Camillo Särs <ged@...> Aim for the impossible and you
        http://www.ged.fi will achieve the improbable

        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_multibyte" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • Tony Mechelynck
        ... Note: the present reply is in UTF-8 On Windows, +multi_byte is usually part of +multi_byte_ime/dyn. You can check it by ... (similarly for any other
        Message 3 of 3 , Mar 12, 2008
        • 0 Attachment
          Joseph Schiller wrote:
          > Hi,
          >
          > I love Vim's language support, but I am puzzled how
          > can I ogonkify on Wind*ws platform as well as I can on
          > Linux? For example, to enter extended latin-1
          > characters in edit mode I use [CTRL+SHIFT+CODE]
          > combinations as follows:
          >
          > [CTRL+SHIFT+<...>]:Ą<104>;ą<105>;Ć<106>;ć<107>;Ę<118>;ę<119>;
          > Ł<141>;ł<142>;Ń<143>;ń<144>;Ó<D3>;ó<F3>;Ś<15A>;ś<15B>;Ż<17B>;
          > ż<17C>;Ź<179>;ź<17A>
          >
          > The<number> in angle brackets corresponds to 2 or 3
          > key combinations, and there are others for other
          > languages.
          >
          > This shortcut works on gVim 7.0.35 built on SuSE 10.0
          > with GTK+ 1.8.4 with +multi_byte and does not work on
          > gVim 6.3 built on Damn Small Linux 3.5 normal version
          > with GTK GUI with -multi_byte running on WinXP inside
          > an emulator. It does not work in gVim 7.1 on
          > MS-Wind*ws 32 bit with OLE support with
          > +multi_byte_ime/dyn. Apparently the key is +multi_byte
          > option.
          >
          > Inside the typical MS enabled apps we can use ALT+CODE
          > using 4 digit combo when entered from the number
          > keypad, such as MS Word. I've searched in the Vim
          > documentation and tried google, but could not find any
          > answers.
          >
          > Regards,
          >
          > Joe

          Note: the present reply is in UTF-8

          On Windows, +multi_byte is usually part of +multi_byte_ime/dyn. You can
          check it by

          :echo has("multi_byte")

          (similarly for any other feature): the answer will be nonzero if and
          only if the feature is present.

          In Vim (and especially in gvim, which isn't bound by what your text
          console can show), you can enter a character by its decimal or hex
          value, but there is even better: digraphs. You use them by hitting
          Ctrl-K in Insert mode, followed by two keys which define the "special
          character" you want to enter. Since the ogonek corresponds (in Vim
          digraphs) to a semicolon, you use
          ^KA; for Ą
          ^Ka; for ą
          ^KE; for Ę
          ^Ke; for ę
          etc.
          Similarly, the acute accent is represented by an apostrophe, so you type
          ^KC' for Ć
          ^Kc' for ć
          ^KO' for Ó
          ^Ko' for ó
          etc.
          and, for other diacritics:
          ^KL/ for Ł
          ^Kl/ for ł
          etc.

          These are so practical that whenever I want to use in an email (or in a
          type-in field on a web page) a character which isn't on my keyboard (or
          maybe it is, but I don't know where) I enter it in gvim and transfer it
          over the clipboard. I used this method for the Polish letters above, in
          particular. (On this Linux system, my Belgian keyboard can make many
          "special" letters by means of at least five "dead keys", but if it can
          make ogonki and barred L's I don't know how.)


          See
          :help i_CTRL-V_digit
          :help digraph.txt
          :help digraphs-default
          :digraphs


          Best regards,
          Tony.
          --
          Welcome thy neighbor into thy fallout shelter. He'll come in handy if
          you run out of food.
          -- Dean McLaughlin.

          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_multibyte" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        Your message has been successfully submitted and would be delivered to recipients shortly.