Loading ...
Sorry, an error occurred while loading the content.

Re: Problem with searching multi-byte word in gvim

Expand Messages
  • Kiwon Um
    On 12¿ù30ÀÏ, ¿ÀÀü12½Ã31ºÐ, Tony Mechelynck ... That s right. After hitting , process is hanging. (It needs to
    Message 1 of 5 , Dec 30, 2007
    • 0 Attachment
      On 12월30일, 오전12시31분, Tony Mechelynck <antoine.mechely...@...>
      wrote:
      > Kiwon Um wrote:
      > > Hi there.
      > > I've got a problem during VIMming.
      >
      > > I'm using VIM 7.1.175 (svn version) compiled with following options:
      > > ./configure --enable-xim --enable-gui --enable-multibyte -enable-
      > > multilang
      > > And I'm using nabi-0.99.0 XIM for hangul(Korean) input.
      >
      > > Input is fine all.
      > > No problem is with that.
      > > But when I search (/) some hangul words, the gvim is stopped to work.
      > > If I use vim with xterm, that's fine again.
      > > Only gui-version vim (gvim) has the problem, searching multibyte word.
      >
      > > Any idea?
      >
      > I don't quite understand what the problem is: please corret me if I'm wrong.
      >
      > You're hitting / followed by some hangul text, then <Enter>. This works fine
      > in Console Vim in xterm, but it hangs gvim. Is that it?
      >

      That's right. After hitting <Enter>, process is hanging. (It needs to
      force quit.)

      > I suspect some interaction between Vim and XIM, but I'm not sure what. How do
      > you enter Korean text in xterm? Maybe Vim is completely bypassed in that case
      > (the interaction being between XIM and the terminal, not XIM and gvim)? What
      > are your XIM settings? (both in XIM, and IM-related settings in gvim)?
      >

      I use same XIM for both xterm and gvim, nabi-0.99.0.
      My /etc/X11/xinit/inputrc setting is as follows:

      XIM=NABI
      XMODIFIERS="@im=nabi"
      XIM_PROGRAM=/usr/local/bin/nabi
      GTK_IM_MODULE=xim
      QT_IM_MODULE=xim

      As I mentioned before, even in gvim, hangul input is fine.
      Only searching has the problem.

      > Best regards,
      > Tony.
      > --
      > % cat /usr/include/sys/errno.h
      > #define EPERM 1 /* Operation not permitted */
      > #define ENOENT 2 /* No such file or directory */
      > #define ESRCH 3 /* No such process */
      > #define EINTR 4 /* Interrupted system call */
      > [...]
      > #define EMACS 666 /* Editor Too Large */
      > %

      Thanks for your reply.
      If you need to know something about my other XIM-related setting to
      solve this problem, just let me know. :)
      Thanks again.
      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_multibyte" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • Jjgod Jiang
      ... I think it will be helpful to know where it stopped at. Could you please run vim inside gdb and see if you can get a backtrace when it happens? - Jiang
      Message 2 of 5 , Dec 31, 2007
      • 0 Attachment
        On Sun, 30 Dec 2007, Kiwon Um wrote:
        > That's right. After hitting <Enter>, process is hanging. (It needs to
        > force quit.)

        I think it will be helpful to know where it stopped at. Could you please
        run vim inside gdb and see if you can get a backtrace when it happens?

        - Jiang


        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_multibyte" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • Kiwon Um
        Hi all. I ve solved this problem. It seemed to be problematic with my XIM module, nabi. Today I ve changed to scim-1.4.7 with scim-hangul-0.3.2. And All is
        Message 3 of 5 , Dec 31, 2007
        • 0 Attachment
          Hi all.

          I've solved this problem.
          It seemed to be problematic with my XIM module, nabi.

          Today I've changed to scim-1.4.7 with scim-hangul-0.3.2.
          And All is fine.

          Thanks for all you guys' interests and advises. :)

          Best regards,
          Kiwon Um

          On 12월31일, 오후6시50분, Jjgod Jiang <gzjj...@...> wrote:
          > On Sun, 30 Dec 2007, Kiwon Um wrote:
          > > That's right. After hitting <Enter>, process is hanging. (It needs to
          > > force quit.)
          >
          > I think it will be helpful to know where it stopped at. Could you please
          > run vim inside gdb and see if you can get a backtrace when it happens?
          >
          > - Jiang
          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_multibyte" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        Your message has been successfully submitted and would be delivered to recipients shortly.