Loading ...
Sorry, an error occurred while loading the content.

Re: utf problems with regular vim (not macvim) on os x

Expand Messages
  • Stefán
    Hi I am probably too late to answer this thread, but I ran into the same problem. It seems to be a problem with the settings of Terminal.app . By going to the
    Message 1 of 7 , Nov 9, 2007
    • 0 Attachment
      Hi

      I am probably too late to answer this thread, but I ran into the same
      problem.

      It seems to be a problem with the settings of Terminal.app . By going
      to the menu Terminal -> Window Settings... , then the Emulation page
      there and unchecking "Escape non-ASCII characters" the problem seems
      to have disappeared. If it works, you have to click the "Use Settings
      as Default" to make the change pernanent. (Bash, after applying the
      hints at http://www.macosxhints.com/article.php?story=20060825071728278
      seems not to care about this "Escape non-ASCII characters" business.
      But that is another matter.)

      Also note that even with this solution, Terminal.app does a pretty
      lousy job of utf-8 rendering, as can be seen from trying "cat" or
      "vim" with UTF-8-demo.txt . Both mess up eg. polytonic greek pretty
      badly.

      Stefán

      On Sep 28, 5:21 am, lanzz <lanz...@...> wrote:
      > On Sep 28, 4:06 pm, Tony Mechelynck <antoine.mechely...@...>
      > wrote:
      >
      > > When you do
      >
      > > vim -N -u NONE
      > > :verbose set enc? tenc?
      >
      > > what is the reply?
      >
      > encoding=utf-8
      > termencoding=


      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_multibyte" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • David Sewell
      ... In the Terminal.app Display preferences, are both the options for Wide glyphs unchecked? Greek and most of the other fonts display properly for me with
      Message 2 of 7 , Nov 10, 2007
      • 0 Attachment
        On Fri, 9 Nov 2007, Stefán wrote:

        > It seems to be a problem with the settings of Terminal.app . By going
        > to the menu Terminal -> Window Settings... , then the Emulation page
        > there and unchecking "Escape non-ASCII characters" the problem seems
        > to have disappeared. If it works, you have to click the "Use Settings
        > as Default" to make the change pernanent. (Bash, after applying the
        > hints at http://www.macosxhints.com/article.php?story=20060825071728278
        > seems not to care about this "Escape non-ASCII characters" business.
        > But that is another matter.)
        >
        > Also note that even with this solution, Terminal.app does a pretty
        > lousy job of utf-8 rendering, as can be seen from trying "cat" or
        > "vim" with UTF-8-demo.txt . Both mess up eg. polytonic greek pretty
        > badly.

        In the Terminal.app Display preferences, are both the options for "Wide
        glyphs" unchecked? Greek and most of the other fonts display properly
        for me with these boxes unchecked.

        --
        David Sewell, Editorial and Technical Manager
        Electronic Imprint, The University of Virginia Press
        PO Box 400318, Charlottesville, VA 22904-4318 USA
        Courier: 310 Old Ivy Way, Suite 302, Charlottesville VA 22903
        Email: dsewell@... Tel: +1 434 924 9973
        Web: http://www.ei.virginia.edu/
        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_multibyte" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • Stefán
        Thanks Unchecking the two wide glyphs options helped a lot. Now the polytonic greek works properly. I think I finally made my Tiger terminal work as I want
        Message 3 of 7 , Nov 10, 2007
        • 0 Attachment
          Thanks

          Unchecking the two "wide glyphs" options helped a lot. Now the
          polytonic greek works properly. I think I finally made my Tiger
          terminal work as I want it. (And they just released Leopard :)

          Stefán

          On Nov 10, 6:26 am, David Sewell <dsew...@...> wrote:
          > On Fri, 9 Nov 2007, Stefán wrote:
          > > It seems to be a problem with the settings of Terminal.app . By going
          > > to the menu Terminal -> Window Settings... , then the Emulation page
          > > there and unchecking "Escape non-ASCII characters" the problem seems
          > > to have disappeared. If it works, you have to click the "Use Settings
          > > as Default" to make the change pernanent. (Bash, after applying the
          > > hints athttp://www.macosxhints.com/article.php?story=20060825071728278
          > > seems not to care about this "Escape non-ASCII characters" business.
          > > But that is another matter.)
          >
          > > Also note that even with this solution, Terminal.app does a pretty
          > > lousy job of utf-8 rendering, as can be seen from trying "cat" or
          > > "vim" with UTF-8-demo.txt . Both mess up eg. polytonic greek pretty
          > > badly.
          >
          > In the Terminal.app Display preferences, are both the options for "Wide
          > glyphs" unchecked? Greek and most of the other fonts display properly
          > for me with these boxes unchecked.
          >
          > --
          > David Sewell, Editorial and Technical Manager
          > Electronic Imprint, The University of Virginia Press
          > PO Box 400318, Charlottesville, VA 22904-4318 USA
          > Courier: 310 Old Ivy Way, Suite 302, Charlottesville VA 22903
          > Email: dsew...@... Tel: +1 434 924 9973
          > Web:http://www.ei.virginia.edu/


          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_multibyte" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        • lanzz
          ... great, thanks! this fixed the problem. ... fortunately cyrillic works fine :) --~--~---------~--~----~------------~-------~--~----~ You received this
          Message 4 of 7 , Nov 15, 2007
          • 0 Attachment
            On Nov 10, 12:14 am, Stefán <sivaldimars...@...> wrote:
            > It seems to be a problem with the settings of Terminal.app . By going
            > to the menu Terminal -> Window Settings... , then the Emulation page
            > there and unchecking "Escape non-ASCII characters" the problem seems
            > to have disappeared.

            great, thanks! this fixed the problem.

            > Also note that even with this solution, Terminal.app does a pretty
            > lousy job of utf-8 rendering, as can be seen from trying "cat" or
            > "vim" with UTF-8-demo.txt . Both mess up eg. polytonic greek pretty
            > badly.

            fortunately cyrillic works fine :)
            --~--~---------~--~----~------------~-------~--~----~
            You received this message from the "vim_multibyte" maillist.
            For more information, visit http://www.vim.org/maillist.php
            -~----------~----~----~----~------~----~------~--~---
          Your message has been successfully submitted and would be delivered to recipients shortly.