Loading ...
Sorry, an error occurred while loading the content.
 

Re: keymap problem, mapping '2' and '6' to Char

Expand Messages
  • Nico Weber
    ... Probably a bug. Which version are you using? It works ok with the latest version of MacVim and the terminal version that s preinstalled (both OS X). Nico
    Message 1 of 4 , Oct 5, 2007
      > I've got a vim keymap problem when trying to map digits to Char
      >
      > But if I have, in the same keymap, a digit on the left-hand-side, e.g.
      >
      > 6 <Char-0x10431>
      > 2 <Char-0x10432>
      >
      > then it does NOT work. Rather the 2 or 6 is rendered on the screen
      > literally,
      > without mapping to the Unicode (Deseret Alphabet) code point.
      >
      > Bug? or am I doing something wrong?

      Probably a bug. Which version are you using? It works ok with the
      latest version of MacVim and the terminal version that's preinstalled
      (both OS X).

      Nico


      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_multibyte" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • Kenneth Beesley
      Nico, Background: I m running OS X version 10.4.10 I just installed the latest MacVim and tried it with a version of DejaVuSansMono.ttf, augmented with
      Message 2 of 4 , Oct 5, 2007
        Nico,

        Background: I'm running OS X version 10.4.10

        I just installed the latest MacVim and tried it with a version of
        DejaVuSansMono.ttf, augmented
        with (monowidth) glyphs, the same width as the original
        DejaVuSansMono.ttf glyphs,
        for the Deseret Alphabet block (U+10400). It doesn't seem to work
        for me. When I select my
        Deseret Alphabet keymap and try to type Deseret Alphabet, I see
        pseudo glyphs in boxes
        rendered on the screen.

        Yesterday I downloaded, via svn, 7.1.135 and got it compiled and
        running on OS X.
        I also got 7.1.135 running on Red Hat Linux. These seem to work
        better, for my Deseret
        Alphabet editing, than MacVim, using the augmented version of
        DejaVuSansMono.ttf.
        Not perfect yet, but better.

        I see the keymap problem (involving digits on the left-hand-side of
        mappings) on both
        platforms with 7.1.135, and with MacVim. I'm confused to see your
        report that it works
        for you in the latest version of MacVim.

        When using MacVim, it complained about setting 'macatsui' in
        my .gvimrc file. It also complained
        about setting 'nomacatsui'. So I took out both for the tests.
        Would you consider sharing your
        .gvimrc file--perhaps there's something in there that makes it work
        better with MacVim.

        Ken



        On 5 Oct 2007, at 04:01, Nico Weber wrote:

        >
        >> I've got a vim keymap problem when trying to map digits to Char
        >>
        >> But if I have, in the same keymap, a digit on the left-hand-side,
        >> e.g.
        >>
        >> 6 <Char-0x10431>
        >> 2 <Char-0x10432>
        >>
        >> then it does NOT work. Rather the 2 or 6 is rendered on the screen
        >> literally,
        >> without mapping to the Unicode (Deseret Alphabet) code point.
        >>
        >> Bug? or am I doing something wrong?
        >
        > Probably a bug. Which version are you using? It works ok with the
        > latest version of MacVim and the terminal version that's preinstalled
        > (both OS X).
        >
        > Nico
        >
        >
        > >


        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_multibyte" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • Tony Mechelynck
        ... The macatsui option exists only in Mac GUI versions and may become obsolete in the future . Therefore, you should check for it before using it, e.g.: if
        Message 3 of 4 , Oct 5, 2007
          Kenneth Beesley wrote:
          > Nico,
          >
          > Background: I'm running OS X version 10.4.10
          >
          > I just installed the latest MacVim and tried it with a version of
          > DejaVuSansMono.ttf, augmented
          > with (monowidth) glyphs, the same width as the original
          > DejaVuSansMono.ttf glyphs,
          > for the Deseret Alphabet block (U+10400). It doesn't seem to work
          > for me. When I select my
          > Deseret Alphabet keymap and try to type Deseret Alphabet, I see
          > pseudo glyphs in boxes
          > rendered on the screen.
          >
          > Yesterday I downloaded, via svn, 7.1.135 and got it compiled and
          > running on OS X.
          > I also got 7.1.135 running on Red Hat Linux. These seem to work
          > better, for my Deseret
          > Alphabet editing, than MacVim, using the augmented version of
          > DejaVuSansMono.ttf.
          > Not perfect yet, but better.
          >
          > I see the keymap problem (involving digits on the left-hand-side of
          > mappings) on both
          > platforms with 7.1.135, and with MacVim. I'm confused to see your
          > report that it works
          > for you in the latest version of MacVim.
          >
          > When using MacVim, it complained about setting 'macatsui' in
          > my .gvimrc file. It also complained
          > about setting 'nomacatsui'. So I took out both for the tests.
          > Would you consider sharing your
          > .gvimrc file--perhaps there's something in there that makes it work
          > better with MacVim.
          >
          > Ken

          The 'macatsui' option exists only in Mac GUI versions and "may become obsolete
          in the future". Therefore, you should check for it before using it, e.g.:

          if exists('+macatsui')
          set nomacatsui
          endif

          (When the option is present, it defaults to TRUE according to ":help 'macatsui'".)

          Best regards,
          Tony.
          --
          Slowly and surely the unix crept up on the Nintendo user ...

          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_multibyte" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        Your message has been successfully submitted and would be delivered to recipients shortly.