Loading ...
Sorry, an error occurred while loading the content.

Re: Problems with polish characters in VIM

Expand Messages
  • Tony Mechelynck
    ... [...] ... Without +multi_byte, you cannot use UTF-8, which is a multibyte encoding using between one and six bytes per character in theory, one and four in
    Message 1 of 7 , Aug 28, 2007
    • 0 Attachment
      Krzysztof Maj wrote:
      > Hello,
      > I just compiled VIM 7.1.68 on my Mac Tiger platform. Everything work
      > great, but I cannot force it to accept polish keyboard anymore. I tried
      > many things, changing terminal options, fonts etc and nothing. My
      > .gvimrc file:
      >
      > set enc=utf-8
      [...]
      > ViM is not compled with myltibyte option, because when I tried to do so
      > during configuration process, compilation start crashing.
      > Insted of polish characters I have something like ę, ć, ó I see '~M~W.
      > When I copy it and put to email window for instance they are display
      > correct like ęćó. What is going on??
      >
      > Many thanks for any suggestions...
      >
      > Best regards,

      Without +multi_byte, you cannot use UTF-8, which is a multibyte encoding using
      between one and six bytes per character in theory, one and four in practice,
      to represent characters. Every codepoint above U+007F, including many Polish
      characters such as L-bar, anything with ogonek, etc., requires two or more
      bytes in UTF-8.

      A build of Vim with --disable-multibyte might support Polish using some 8-bit
      East-European encoding, it won't support UTF-8, and it won't be able to
      display UTF-8 files correctly.

      You may want to check your src/auto/config.log for a hint of why configure
      crashed.

      I'm adding vim_dev to the list of groups this is sent to because I have a
      feeling this might be a general config question rather than a specific
      multibyte question.

      Oh, and by the way, the latest patchlevel is now 87. See
      http://ftp.vim.org/pub/vim/patches/7.1/README for details.


      Best regards,
      Tony.
      --
      "There's nothing wrong with teenagers that reasoning with them won't
      aggravate."

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_multibyte" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • Nico Weber
      Hi, ... as Tony said, you need to configure with --enable-multibyte. This option works for me...where did you get your source from? Nico
      Message 2 of 7 , Aug 28, 2007
      • 0 Attachment
        Hi,

        > I just compiled VIM 7.1.68 on my Mac Tiger platform. Everything
        > work great, but I cannot force it to accept polish keyboard
        > anymore. I tried many things, changing terminal options, fonts etc
        > and nothing. My .gvimrc file:

        as Tony said, you need to configure with --enable-multibyte. This
        option works for me...where did you get your source from?

        Nico

        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_multibyte" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • Krzysztof Maj
        ... Well I get the source from the official VIM site AFAIK. Maybe I should to try once again or get the newer minor release. I am using svn to get the source
        Message 3 of 7 , Aug 29, 2007
        • 0 Attachment
          On 2007-08-29, at 08:38, Nico Weber wrote:

          >
          > Hi,
          >
          >> I just compiled VIM 7.1.68 on my Mac Tiger platform. Everything
          >> work great, but I cannot force it to accept polish keyboard
          >> anymore. I tried many things, changing terminal options, fonts etc
          >> and nothing. My .gvimrc file:
          >
          > as Tony said, you need to configure with --enable-multibyte. This
          > option works for me...where did you get your source from?
          >

          Well I get the source from the official VIM site AFAIK. Maybe I
          should to try once again or get the newer minor release. I am using
          svn to get the source from the repository:

          mkrzychs-computer:~/bin mkrzych$ more getvimsource
          cd ~/Downled/Source/ && svn co https://vim.svn.sourceforge.net/
          svnroot/vim/vim7

          Version 7.1.68 does not compile with multibyte option on my Mac Tiger
          10.4.10.



          Pozdrawiam,
          --
          Krzysztof Maj, JNCIP-M/T
          I'm a M@c, are you still a PC?
        • Krzysztof Maj
          ... Eureka! I just compiled .87 patchlevel sources and everything works fine now. Thanks a lot guys! Cheers, -- Krzysztof Maj, JNCIP-M/T I m a M@c, are you
          Message 4 of 7 , Aug 29, 2007
          • 0 Attachment
            On 2007-08-29, at 08:26, Tony Mechelynck wrote:

            > Oh, and by the way, the latest patchlevel is now 87. See
            > http://ftp.vim.org/pub/vim/patches/7.1/README for details.

            Eureka! I just compiled .87 patchlevel sources and everything works
            fine now.
            Thanks a lot guys!


            Cheers,
            --
            Krzysztof Maj, JNCIP-M/T
            I'm a M@c, are you still a PC?
          Your message has been successfully submitted and would be delivered to recipients shortly.