Loading ...
Sorry, an error occurred while loading the content.
 

Re: Problems with Vim lists on Google Groups

Expand Messages
  • Tony Mechelynck
    ... I may be victim of that mass subscribe -- I don t rightly know. Here s what I experience: - My gmail account knows that I am both
    Message 1 of 7 , Aug 17, 2007
      Bram Moolenaar wrote:
      >
      > Hello Vim users,
      >
      > A few weeks ago the Vim maillists were moved to the Google Groups
      > system. For most people this worked well, but some experienced problems
      > receiving and posting messages. That means one is successfully
      > subscribed, but messages are not received and posting is not allowed.
      >
      > It took a while to figure out what went wrong. It turned out that it
      > was caused by a denied mass-subscribe request. At first I had tried to
      > automatically subscribe the subscribers of the old maillists at Google
      > Groups. The requests that were denied have resulted in a special flag
      > for the e-mail addresses in these lists. That caused the problems.
      >
      > I have sent this message to the people in the denied requests, but
      > I got quite a few bounces. Thus I'm repeating the message here for
      > others that appear to be in this situation.
      >
      > If you have the problems described, you can do one of these:
      > - Subscribe with another e-mail address.
      > - Some people reported that it started working after creating a Google
      > account.
      > - Contact Groups support at this URL:
      > http://groups.google.com/support/bin/request.py
      >
      > I'm very sorry we caused these problems and it took so long to figure
      > out what went wrong.
      >

      I "may" be victim of that mass subscribe -- I don't rightly know. Here's what
      I experience:
      - My gmail account "knows" that I am both antoine.mechelynck@... and
      antoine.mechelynck@...
      - My Google Groups are set to send email to the former but know about the
      latter (it appears in the drop-down).
      - My @... address used to be my address-of-record for Vim lists before
      the switch to Google groups.
      - I can post with @... in my from-line, but @... gets a bounce.

      I don't really need help, since I can use @... to post, and Thunderbird
      (which reads my Google mail by POP) correctly sets the from-address to
      @... when I reply to a vim-list post. The only time I must pay attention
      to which identity I send mail from is when creating a new thread.


      Best regards,
      Tony.
      --
      Living in LA is like not having a date on Saturday night.
      -- Candice Bergen

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_multibyte" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • Krzysztof Maj
      Hello, I just compiled VIM 7.1.68 on my Mac Tiger platform. Everything work great, but I cannot force it to accept polish keyboard anymore. I tried many
      Message 2 of 7 , Aug 28, 2007
        Hello,
        I just compiled VIM 7.1.68 on my Mac Tiger platform. Everything work
        great, but I cannot force it to accept polish keyboard anymore. I
        tried many things, changing terminal options, fonts etc and nothing.
        My .gvimrc file:

        set enc=utf-8
        set guifont=Courier:h22
        set background=dark
        set backupcopy=yes
        set nofen
        set fdl=0
        set autoread
        set ruler

        "Set backspace
        set backspace=eol,start,indent
        "Backspace and cursor keys wrap to
        set whichwrap+=<,>,h,l

        set incsearch

        "Set magic on
        set magic

        "No sound on errors.
        set noerrorbells
        set novisualbell
        set t_vb=

        "show matching bracets
        set showmatch

        "Format the statusline
        set statusline=\ %F%m%r%h\ %w\ \ Line:\ %l/%L:%c

        set fileformats+=mac
        set fileformats+=dos

        set cursorline
        hi cursorline guibg=#433333
        hi CursorColumn guibg=#333333
        colorscheme darkblue

        syntax enable
        set number

        autocmd BufWinEnter * lcd %:p:h


        ViM is not compled with myltibyte option, because when I tried to do
        so during configuration process, compilation start crashing.
        Insted of polish characters I have something like ę, ć, ó I see
        '~M~W. When I copy it and put to email window for instance they are
        display correct like ęćó. What is going on??

        Many thanks for any suggestions...

        Best regards,
        --
        Krzysztof Maj, JNCIP-M/T
        I'm a M@c, are you still a PC?
      • Tony Mechelynck
        ... [...] ... Without +multi_byte, you cannot use UTF-8, which is a multibyte encoding using between one and six bytes per character in theory, one and four in
        Message 3 of 7 , Aug 28, 2007
          Krzysztof Maj wrote:
          > Hello,
          > I just compiled VIM 7.1.68 on my Mac Tiger platform. Everything work
          > great, but I cannot force it to accept polish keyboard anymore. I tried
          > many things, changing terminal options, fonts etc and nothing. My
          > .gvimrc file:
          >
          > set enc=utf-8
          [...]
          > ViM is not compled with myltibyte option, because when I tried to do so
          > during configuration process, compilation start crashing.
          > Insted of polish characters I have something like ę, ć, ó I see '~M~W.
          > When I copy it and put to email window for instance they are display
          > correct like ęćó. What is going on??
          >
          > Many thanks for any suggestions...
          >
          > Best regards,

          Without +multi_byte, you cannot use UTF-8, which is a multibyte encoding using
          between one and six bytes per character in theory, one and four in practice,
          to represent characters. Every codepoint above U+007F, including many Polish
          characters such as L-bar, anything with ogonek, etc., requires two or more
          bytes in UTF-8.

          A build of Vim with --disable-multibyte might support Polish using some 8-bit
          East-European encoding, it won't support UTF-8, and it won't be able to
          display UTF-8 files correctly.

          You may want to check your src/auto/config.log for a hint of why configure
          crashed.

          I'm adding vim_dev to the list of groups this is sent to because I have a
          feeling this might be a general config question rather than a specific
          multibyte question.

          Oh, and by the way, the latest patchlevel is now 87. See
          http://ftp.vim.org/pub/vim/patches/7.1/README for details.


          Best regards,
          Tony.
          --
          "There's nothing wrong with teenagers that reasoning with them won't
          aggravate."

          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_multibyte" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        • Nico Weber
          Hi, ... as Tony said, you need to configure with --enable-multibyte. This option works for me...where did you get your source from? Nico
          Message 4 of 7 , Aug 28, 2007
            Hi,

            > I just compiled VIM 7.1.68 on my Mac Tiger platform. Everything
            > work great, but I cannot force it to accept polish keyboard
            > anymore. I tried many things, changing terminal options, fonts etc
            > and nothing. My .gvimrc file:

            as Tony said, you need to configure with --enable-multibyte. This
            option works for me...where did you get your source from?

            Nico

            --~--~---------~--~----~------------~-------~--~----~
            You received this message from the "vim_multibyte" maillist.
            For more information, visit http://www.vim.org/maillist.php
            -~----------~----~----~----~------~----~------~--~---
          • Krzysztof Maj
            ... Well I get the source from the official VIM site AFAIK. Maybe I should to try once again or get the newer minor release. I am using svn to get the source
            Message 5 of 7 , Aug 29, 2007
              On 2007-08-29, at 08:38, Nico Weber wrote:

              >
              > Hi,
              >
              >> I just compiled VIM 7.1.68 on my Mac Tiger platform. Everything
              >> work great, but I cannot force it to accept polish keyboard
              >> anymore. I tried many things, changing terminal options, fonts etc
              >> and nothing. My .gvimrc file:
              >
              > as Tony said, you need to configure with --enable-multibyte. This
              > option works for me...where did you get your source from?
              >

              Well I get the source from the official VIM site AFAIK. Maybe I
              should to try once again or get the newer minor release. I am using
              svn to get the source from the repository:

              mkrzychs-computer:~/bin mkrzych$ more getvimsource
              cd ~/Downled/Source/ && svn co https://vim.svn.sourceforge.net/
              svnroot/vim/vim7

              Version 7.1.68 does not compile with multibyte option on my Mac Tiger
              10.4.10.



              Pozdrawiam,
              --
              Krzysztof Maj, JNCIP-M/T
              I'm a M@c, are you still a PC?
            • Krzysztof Maj
              ... Eureka! I just compiled .87 patchlevel sources and everything works fine now. Thanks a lot guys! Cheers, -- Krzysztof Maj, JNCIP-M/T I m a M@c, are you
              Message 6 of 7 , Aug 29, 2007
                On 2007-08-29, at 08:26, Tony Mechelynck wrote:

                > Oh, and by the way, the latest patchlevel is now 87. See
                > http://ftp.vim.org/pub/vim/patches/7.1/README for details.

                Eureka! I just compiled .87 patchlevel sources and everything works
                fine now.
                Thanks a lot guys!


                Cheers,
                --
                Krzysztof Maj, JNCIP-M/T
                I'm a M@c, are you still a PC?
              Your message has been successfully submitted and would be delivered to recipients shortly.