Loading ...
Sorry, an error occurred while loading the content.

Re: Solution for the problem of gvimext in UTF-8 locale

Expand Messages
  • Bram Moolenaar
    ... What is your encoding set to then? Win32 has reasonable Unicode support, and Vim does some conversion itself too. Thus this would only fail if your
    Message 1 of 9 , Jul 31, 2007
    • 0 Attachment
      Rainux wrote:

      > Wonderful answer!
      >
      > Yes, I think the problem that Vim can not handle ucs-2le encoding file
      > I've encoutered, is produced by the problem of native encoding
      > conversion in Win32.

      What is your 'encoding' set to then? Win32 has reasonable Unicode
      support, and Vim does some conversion itself too. Thus this would only
      fail if your 'encoding' is set to something that MS-Windows doesn't
      support.

      It might be that your 'fileencodings' setting has a wrong value.

      --
      hundred-and-one symptoms of being an internet addict:
      70. ISDN lines are added to your house on a hourly basis

      /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
      /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
      \\\ download, build and distribute -- http://www.A-A-P.org ///
      \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_multibyte" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • Rainux
      This is the relative settings in my .vimrc set fileencodings=ucs-bom,utf-8,chinese set encoding=utf-8 I m sorry now I can not recur that problem, it not occur
      Message 2 of 9 , Jul 31, 2007
      • 0 Attachment
        This is the relative settings in my .vimrc

        set fileencodings=ucs-bom,utf-8,chinese
        set encoding=utf-8

        I'm sorry now I can not recur that problem, it not occur on all Win32
        environment.

        Sorry for the repeat, I just forgot to "Reply to all".

        On 8/1/07, Bram Moolenaar <Bram@...> wrote:
        >
        > Rainux wrote:
        >
        > > Wonderful answer!
        > >
        > > Yes, I think the problem that Vim can not handle ucs-2le encoding file
        > > I've encoutered, is produced by the problem of native encoding
        > > conversion in Win32.
        >
        > What is your 'encoding' set to then? Win32 has reasonable Unicode
        > support, and Vim does some conversion itself too. Thus this would only
        > fail if your 'encoding' is set to something that MS-Windows doesn't
        > support.
        >
        > It might be that your 'fileencodings' setting has a wrong value.
        >
        > --
        > hundred-and-one symptoms of being an internet addict:
        > 70. ISDN lines are added to your house on a hourly basis
        >
        > /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
        > /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
        > \\\ download, build and distribute -- http://www.A-A-P.org ///
        > \\\ help me help AIDS victims -- http://ICCF-Holland.org ///
        >


        --
        Best Regards

        Rainux

        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_multibyte" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      Your message has been successfully submitted and would be delivered to recipients shortly.