Loading ...
Sorry, an error occurred while loading the content.

813Re: Wrong encoding when copying to/from Clipboard in the newest builds

Expand Messages
  • Bram Moolenaar
    Mar 12, 2003
    • 0 Attachment
      Valery Kondakoff wrote:

      > I'm not sure if you are aware of this issue already, but it seems
      > there is smth broken in Clipboard copying in the newest GVIM builds.
      > (I'm using GVIM 6.1, under WinXP Pro).
      >
      > There are my encoding settings:
      >
      > set encoding=cp1251
      > set fileencodings=cp1251,cp866,koi8-r
      > set guifont=courier_new:h11
      >
      > When using GVIM 6.1 I can copy text in cp1251 encoding to system
      > Clipboard and paste it to another application (*"y). The text is
      > pasted without problems. Also I can copy text from another app to VIM
      > (*"p) and this text will be still displayed correctly (cp1251).
      >
      > But after upgrading to GVIM 6.1.364 and GVIM 6.1.386 I have noticed,
      > that the Russian text is pasted to/from Clipboard as a garbage - in
      > wrong encoding. It's interesting that 'plain' yanking/pasting (y/p)
      > works as expected and does not produce wrong encoding. After reverting
      > back to GVIM 6.1 the problem disappears.
      >
      > Do you have any idea - what's wrong?

      I don't know what's wrong. Glenn? Ron?

      --
      Everyone has a photographic memory. Some don't have film.

      /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
      /// Creator of Vim - Vi IMproved -- http://www.Vim.org \\\
      \\\ Project leader for A-A-P -- http://www.A-A-P.org ///
      \\\ Help AIDS victims, buy at Amazon -- http://ICCF.nl/click1.html ///
    • Show all 9 messages in this topic