Loading ...
Sorry, an error occurred while loading the content.

Syntax setting not working in classic, v6.1

Expand Messages
  • Steven Haworth
    Howdy. I m new to this list, but a rather long-time VIM and VI user, on Unix, Macs and Windows. Anyway, I upgraded VIM 5.7.9 to 6.1 on the my Mac (running OS
    Message 1 of 2 , Jun 6, 2003
    • 0 Attachment
      Howdy.

      I'm new to this list, but a rather long-time VIM and VI user, on Unix, Macs and Windows. Anyway, I upgraded VIM 5.7.9 to 6.1 on the my Mac (running OS 9.2.2), and now I can't get color syntax-highlighting to work. Can anyone help? Here's the details:

      I've read thru all the docs, and still can't figure out what's wrong. When I start up vimPPC, I get an error saying it can't open the 'syntax.vim' file, although the path it gives is correct (vim61/runtime/syntax/sytnax.vim). I tried using both 'syntax on' and ':syntax enable' in the vimrc file, and both seem to generate the same error.

      I'm after using the HTML syntax file (also included here).


      Also, I've defined a colorscheme 'sjh.vim' and referenced it in the vimrc file, but the command seems to be ignored, and the colors are not set.

      All this worked fine w/5.7.9, although most of the color commands were in a gvimrc file and there were no colorschemes.

      Thanks much!!!

      --
      - Steven
      Freelance Lighting Designer
      http://www.stagelights.info
    • Ben Fowler
      ... That path does not look right for classic. Could you give more detail, the path to the executable and perhaps some comparative information for the latest
      Message 2 of 2 , Jun 16, 2003
      • 0 Attachment
        At 9:17 pm -0500 2003-06-06, Steven Haworth wrote:
        >Howdy.
        >
        >I'm new to this list, but a rather long-time VIM and VI user, on Unix, Macs and Windows. Anyway, I upgraded VIM 5.7.9 to 6.1 on the my Mac (running OS 9.2.2), and now I can't get color syntax-highlighting to work. Can anyone help? Here's the details:
        >
        >I've read thru all the docs, and still can't figure out what's wrong. When I start up vimPPC, I get an error saying it can't open the 'syntax.vim' file, although the path it gives is correct (vim61/runtime/syntax/sytnax.vim). I tried using both 'syntax on' and ':syntax enable' in the vimrc file, and both seem to generate the same error.


        That path does not look right for classic. Could you give more detail, the path to the executable and perhaps some
        comparative information for the latest version that does work for you.

        Did you unstuff/install the vim runtimes files?

        Ben
        --
        Privileged/Confidential Information may be contained in this message.
        If you are not the addressee indicated in this message (or responsible
        for delivery of the message to such person), you may not copy or deliver
        this message to anyone. In such case, you should destroy this message
        and kindly notify the sender by reply email. Please advise immediately
        if you or your employer do not consent to Internet email messages of this
        kind. Opinions, conclusions and other information in this message that
        do not relate to the official business of ewitness Limited shall be
        understood as neither given nor endorsed by it.

        eWitness Limited, Alpha House, Redvers Close, Lawnswood Business Park, Leeds, LS16 6QY
        Telephone: 0113 2951112 Fax: 0113 2951114
      Your message has been successfully submitted and would be delivered to recipients shortly.