Loading ...
Sorry, an error occurred while loading the content.

Re: MacVim.app - Snapshot 43

Expand Messages
  • Yongwei Wu
    ... Maybe not. I am happy to report that since a few snapshots ago this issue has ceased to appear on my computer. Not sure whether it is because of an OS
    Message 1 of 8 , Feb 22, 2009
    • 0 Attachment
      2009/2/23 Nico Weber <nicolasweber@...>:
      >
      >> When I do `open -a MacVim` with this snapshot (Snapshot 43), it just
      >> bounces in the dock and I have to force quit the bouncing icon. This
      >> used to work fine (a few snapshots ago), I could regularly do things
      >> like `open -a MacVim *.txt` in a directory.
      >
      > Hm, works for me. Does this only happen if you use `open`? Does
      > opening MacVim via double-clicking it in the Finder work? Via `mvim`?
      >
      > What's the output of
      >
      > cat ~/.CFUserTextEncoding
      >
      > ? This sounds a bit like issue 56 ( http://code.google.com/p/macvim/issues/detail?id=56
      > , particularly comments 23-26). Perhaps it's just a coincidence this
      > started happening after you installed 43? Does snapshot 42 still work?

      Maybe not. I am happy to report that since a few snapshots ago this
      issue has ceased to appear on my computer. Not sure whether it is
      because of an OS update or the MacVim update.

      There are still strange things related to locales. After I start
      MacVim by double-clicking, I can open a new Vim window by clicking on
      the dock icon when there is not an active Vim window. I cannot do
      this if I first launch MacVim by typing mvim in a terminal. For some
      reason unknown, the language as indicated by v:lang is zh-CN (Chinese)
      in the former case, but it is en_GB in the latter.

      --
      Wu Yongwei
      URL: http://wyw.dcweb.cn/

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • Jordan
      ... Very strange indeed. But now I can t replicate it. I was seeing the problem on an older install, but I was about to re-install for other reasons, then it
      Message 2 of 8 , Feb 23, 2009
      • 0 Attachment
        On Feb 22, 11:56 am, björn <bjorn.winck...@...> wrote:
        > 2009/2/21 Jordan <jordan.breed...@...>:
        >
        >
        >
        > > When I do `open -a MacVim` with this snapshot (Snapshot 43), it just
        > > bounces in the dock and I have to force quit the bouncing icon. This
        > > used to work fine (a few snapshots ago), I could regularly do things
        > > like `open -a MacVim *.txt` in a directory.
        >
        > Hmmm...this sounds strange.  Are you saying you can double-click the
        > MacVim icon to open it but "open -a MacVim" fails?  If you have
        > multiple versions of MacVim.app on your hard drive you may want to
        > delete all but one and try again.
        >
        > Has anybody else had this problem?
        >
        > Björn

        Very strange indeed. But now I can't replicate it. I was seeing the
        problem on an older install, but I was about to re-install for other
        reasons, then it re-occurred on the new install as well, but I think
        this was a fluke.

        I made sure that I could double-click on the icon, authorized any
        permissions, etc. Now it opens just fine with `open -a MacVim`.

        Odd, but at least it is working now.
        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_mac" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • björn
        ... I haven t done anything on purpose to fix this so I m not sure what has changed... ... The problem with clicking on the dock has nothing to do with
        Message 3 of 8 , Mar 2, 2009
        • 0 Attachment
          2009/2/23 Yongwei Wu:
          >
          > 2009/2/23 Nico Weber:
          >>
          >>> When I do `open -a MacVim` with this snapshot (Snapshot 43), it just
          >>> bounces in the dock and I have to force quit the bouncing icon. This
          >>> used to work fine (a few snapshots ago), I could regularly do things
          >>> like `open -a MacVim *.txt` in a directory.
          >>
          >> Hm, works for me. Does this only happen if you use `open`? Does
          >> opening MacVim via double-clicking it in the Finder work? Via `mvim`?
          >>
          >> What's the output of
          >>
          >>     cat ~/.CFUserTextEncoding
          >>
          >> ? This sounds a bit like issue 56 ( http://code.google.com/p/macvim/issues/detail?id=56
          >>  , particularly comments 23-26). Perhaps it's just a coincidence this
          >> started happening after you installed 43? Does snapshot 42 still work?
          >
          > Maybe not.  I am happy to report that since a few snapshots ago this
          > issue has ceased to appear on my computer.  Not sure whether it is
          > because of an OS update or the MacVim update.

          I haven't done anything on purpose to fix this so I'm not sure what
          has changed...

          > There are still strange things related to locales.  After I start
          > MacVim by double-clicking, I can open a new Vim window by clicking on
          > the dock icon when there is not an active Vim window.  I cannot do
          > this if I first launch MacVim by typing mvim in a terminal.  For some
          > reason unknown, the language as indicated by v:lang is zh-CN (Chinese)
          > in the former case, but it is en_GB in the latter.

          The problem with clicking on the dock has nothing to do with locales.
          It is a bug that should have been fixed in snapshot 43 -- can you
          please test snap 43 to confirm that it has indeed been fixed?

          The fact that the locale depends on how you start MacVim is somehing I
          was not aware of however. I don't know why this happens or what
          consequences it may have unfortunately.

          Björn

          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_mac" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        • Yongwei Wu
          ... Yup. Thanks! ... Not your problem here. For some reason I have LANG=en_GB.UTF-8 in the terminal. I did not set it in .bashrc or .bash_profile.
          Message 4 of 8 , Mar 3, 2009
          • 0 Attachment
            2009/3/3 björn <bjorn.winckler@...>:
            >
            > 2009/2/23 Yongwei Wu:
            >>
            >> 2009/2/23 Nico Weber:
            >>>
            >>>> When I do `open -a MacVim` with this snapshot (Snapshot 43), it just
            >>>> bounces in the dock and I have to force quit the bouncing icon. This
            >>>> used to work fine (a few snapshots ago), I could regularly do things
            >>>> like `open -a MacVim *.txt` in a directory.
            >>>
            >>> Hm, works for me. Does this only happen if you use `open`? Does
            >>> opening MacVim via double-clicking it in the Finder work? Via `mvim`?
            >>>
            >>> What's the output of
            >>>
            >>>     cat ~/.CFUserTextEncoding
            >>>
            >>> ? This sounds a bit like issue 56 ( http://code.google.com/p/macvim/issues/detail?id=56
            >>>  , particularly comments 23-26). Perhaps it's just a coincidence this
            >>> started happening after you installed 43? Does snapshot 42 still work?
            >>
            >> Maybe not.  I am happy to report that since a few snapshots ago this
            >> issue has ceased to appear on my computer.  Not sure whether it is
            >> because of an OS update or the MacVim update.
            >
            > I haven't done anything on purpose to fix this so I'm not sure what
            > has changed...
            >
            >> There are still strange things related to locales.  After I start
            >> MacVim by double-clicking, I can open a new Vim window by clicking on
            >> the dock icon when there is not an active Vim window.  I cannot do
            >> this if I first launch MacVim by typing mvim in a terminal.  For some
            >> reason unknown, the language as indicated by v:lang is zh-CN (Chinese)
            >> in the former case, but it is en_GB in the latter.
            >
            > The problem with clicking on the dock has nothing to do with locales.
            > It is a bug that should have been fixed in snapshot 43 -- can you
            > please test snap 43 to confirm that it has indeed been fixed?

            Yup. Thanks!

            > The fact that the locale depends on how you start MacVim is somehing I
            > was not aware of however.  I don't know why this happens or what
            > consequences it may have unfortunately.

            Not your problem here. For some reason I have LANG=en_GB.UTF-8 in the
            terminal. I did not set it in .bashrc or .bash_profile. LANG=zh_CN
            is natural, since I've set Simplified Chinese as my first language in
            System Preferences > International.

            Best regards,

            Yongwei

            --
            Wu Yongwei
            URL: http://wyw.dcweb.cn/

            --~--~---------~--~----~------------~-------~--~----~
            You received this message from the "vim_mac" maillist.
            For more information, visit http://www.vim.org/maillist.php
            -~----------~----~----~----~------~----~------~--~---
          Your message has been successfully submitted and would be delivered to recipients shortly.