Loading ...
Sorry, an error occurred while loading the content.

Re: [Sugestion] Maximize window before going to fullscreen mode

Expand Messages
  • Pedro Borges
    Thanks for the sugestion! With that option the windows doesn t fill the screen horizontally. ... -- Pedro Borges
    Message 1 of 12 , Feb 11, 2009
    • 0 Attachment
      Thanks for the sugestion! With that option the windows doesn't fill
      the screen horizontally.

      On Wed, Feb 11, 2009 at 3:35 AM, Nico Weber <nicolasweber@...> wrote:
      >
      > Hi,
      >
      > On 10.02.2009, at 17:12, Pedro Borges wrote:
      >
      >> I think this would be very handy when using split windows.
      >
      > I'm not entirely sure what you're asking for, bug try doing `:set
      > fuopts=maxhorz` before entering fullscreen mode, and then enter
      > fullscreen mode. Does that do what you want?
      >
      > Nico
      >
      > >
      >



      --
      Pedro Borges

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • Nico Weber
      ... It should, once you enter fullscreen mode (either by hitting ⌘⇧F or by typing `:set fu`). If you want a normal window that covers most of the screen,
      Message 2 of 12 , Feb 11, 2009
      • 0 Attachment
        > Thanks for the sugestion! With that option the windows doesn't fill
        > the screen horizontally.

        It should, once you enter fullscreen mode (either by hitting ⌘⇧F or
        by typing `:set fu`). If you want a "normal" window that covers most
        of the screen, try hitting ⌘ while clicking the green zoom button in
        the top left corner of the MacVim window. Is this what you want?

        Nico
        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_mac" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • Pedro Borges
        I meant vertically , sorry ... -- Pedro Borges --~--~---------~--~----~------------~-------~--~----~ You received this message from the vim_mac maillist. For
        Message 3 of 12 , Feb 11, 2009
        • 0 Attachment
          I meant vertically , sorry

          On Wed, Feb 11, 2009 at 3:00 PM, Nico Weber <nicolasweber@...> wrote:
          >
          >> Thanks for the sugestion! With that option the windows doesn't fill
          >> the screen horizontally.
          >
          > It should, once you enter fullscreen mode (either by hitting ⌘⇧F or
          > by typing `:set fu`). If you want a "normal" window that covers most
          > of the screen, try hitting ⌘ while clicking the green zoom button in
          > the top left corner of the MacVim window. Is this what you want?
          >
          > Nico
          > >
          >



          --
          Pedro Borges

          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_mac" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        • Tobia Conforto
          ... -Tobia --~--~---------~--~----~------------~-------~--~----~ You received this message from the vim_mac maillist. For more information, visit
          Message 4 of 12 , Feb 11, 2009
          • 0 Attachment
            Pedro Borges wrote:
            > I meant vertically, sorry

            :set fuopts=maxhorz,maxvert


            -Tobia

            --~--~---------~--~----~------------~-------~--~----~
            You received this message from the "vim_mac" maillist.
            For more information, visit http://www.vim.org/maillist.php
            -~----------~----~----~----~------~----~------~--~---
          • Nico Weber
            ... I meant to write `:set fuopt+=maxhorz` (note the `+`). Sorry, my fault. Nico --~--~---------~--~----~------------~-------~--~----~ You received this
            Message 5 of 12 , Feb 11, 2009
            • 0 Attachment
              On Feb 11, 7:37 am, Pedro Borges <pedro....@...> wrote:
              > I meant vertically , sorry

              I meant to write `:set fuopt+=maxhorz` (note the `+`). Sorry, my
              fault.

              Nico
              --~--~---------~--~----~------------~-------~--~----~
              You received this message from the "vim_mac" maillist.
              For more information, visit http://www.vim.org/maillist.php
              -~----------~----~----~----~------~----~------~--~---
            • björn
              ... Pedro, I guess I should point out that any option (i.e. that you can ... optionname . For example, ... will tell you everything you want to know about
              Message 6 of 12 , Feb 11, 2009
              • 0 Attachment
                2009/2/11 Nico Weber:
                >
                > On Feb 11, 7:37 am, Pedro Borges wrote:
                >> I meant vertically , sorry
                >
                > I meant to write `:set fuopt+=maxhorz` (note the `+`). Sorry, my
                > fault.

                Pedro, I guess I should point out that any option (i.e. that you can
                :set) also has nice help that you can access by entering ":h
                'optionname'". For example,

                :h 'fuopt'

                will tell you everything you want to know about full-screen options.

                Björn

                --~--~---------~--~----~------------~-------~--~----~
                You received this message from the "vim_mac" maillist.
                For more information, visit http://www.vim.org/maillist.php
                -~----------~----~----~----~------~----~------~--~---
              • Tobia Conforto
                Slightly related question: on my machine fuopts=maxhorz,maxvert almost maxmizes the fullscreen vim. It appears to leave black margins equivalent to the size
                Message 7 of 12 , Feb 12, 2009
                • 0 Attachment
                  Slightly related question: on my machine fuopts=maxhorz,maxvert
                  "almost" maxmizes the fullscreen vim. It appears to leave black
                  margins equivalent to the size of the menu bar and of the dock.

                  Is this a known limitation?

                  Tobia

                  --~--~---------~--~----~------------~-------~--~----~
                  You received this message from the "vim_mac" maillist.
                  For more information, visit http://www.vim.org/maillist.php
                  -~----------~----~----~----~------~----~------~--~---
                • Pedro Borges
                  That was my issue too. On Thu, Feb 12, 2009 at 10:54 AM, Tobia Conforto ... -- Pedro Borges --~--~---------~--~----~------------~-------~--~----~ You received
                  Message 8 of 12 , Feb 12, 2009
                  • 0 Attachment
                    That was my issue too.

                    On Thu, Feb 12, 2009 at 10:54 AM, Tobia Conforto
                    <tobia.conforto@...> wrote:
                    >
                    > Slightly related question: on my machine fuopts=maxhorz,maxvert
                    > "almost" maxmizes the fullscreen vim. It appears to leave black
                    > margins equivalent to the size of the menu bar and of the dock.
                    >
                    > Is this a known limitation?
                    >
                    > Tobia
                    >
                    > >
                    >



                    --
                    Pedro Borges

                    --~--~---------~--~----~------------~-------~--~----~
                    You received this message from the "vim_mac" maillist.
                    For more information, visit http://www.vim.org/maillist.php
                    -~----------~----~----~----~------~----~------~--~---
                  • Nico Weber
                    ... MacVim keeps the vim view at a multiple of your character width/ height, so there will be a few pixels black margin. Oh, I see the problem. No, it
                    Message 9 of 12 , Feb 12, 2009
                    • 0 Attachment
                      > Slightly related question: on my machine fuopts=maxhorz,maxvert
                      > "almost" maxmizes the fullscreen vim. It appears to leave black
                      > margins equivalent to the size of the menu bar and of the dock.
                      >
                      > Is this a known limitation?

                      MacVim keeps the vim view at a multiple of your character width/
                      height, so there will be a few pixels black margin.

                      Oh, I see the problem. No, it shouldn't leave that much space, that
                      looks like a bug. I'll take a look. (You don't get the horizontal
                      space if your dock is on auto-hide by the way).

                      Nico

                      --~--~---------~--~----~------------~-------~--~----~
                      You received this message from the "vim_mac" maillist.
                      For more information, visit http://www.vim.org/maillist.php
                      -~----------~----~----~----~------~----~------~--~---
                    • björn
                      ... I took the liberty to fix this problem. The patch is in the repo and will be included in snapshot 44. Björn
                      Message 10 of 12 , Mar 16, 2009
                      • 0 Attachment
                        2009/2/12 Nico Weber:
                        >
                        >> Slightly related question: on my machine fuopts=maxhorz,maxvert
                        >> "almost" maxmizes the fullscreen vim. It appears to leave black
                        >> margins equivalent to the size of the menu bar and of the dock.
                        >>
                        >> Is this a known limitation?
                        >
                        > MacVim keeps the vim view at a multiple of your character width/
                        > height, so there will be a few pixels black margin.
                        >
                        > Oh, I see the problem. No, it shouldn't leave that much space, that
                        > looks like a bug. I'll take a look. (You don't get the horizontal
                        > space if your dock is on auto-hide by the way).

                        I took the liberty to fix this problem. The patch is in the repo and
                        will be included in snapshot 44.

                        Björn

                        --~--~---------~--~----~------------~-------~--~----~
                        You received this message from the "vim_mac" maillist.
                        For more information, visit http://www.vim.org/maillist.php
                        -~----------~----~----~----~------~----~------~--~---
                      Your message has been successfully submitted and would be delivered to recipients shortly.