Loading ...
Sorry, an error occurred while loading the content.

history not saved

Expand Messages
  • Bee
    MacVim Snapshot 42 MacOS 10.4.11 When I quit MacVim the restart, the history has not been saved. If I use a cli vim, history IS saved and shows up later in
    Message 1 of 13 , Jan 28, 2009
    • 0 Attachment
      MacVim Snapshot 42
      MacOS 10.4.11

      When I quit MacVim the restart, the history has not been saved.

      If I use a cli vim, history IS saved and shows up later in MacVim.

      What am I missing? Is it a preference? They both use the same .vimrc.

      --
      Bill Muench
      Santa Cruz, California


      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • Bee
      MacVim Snapshot 42 MacOS 10.4.11 When I quit MacVim then restart, the history has not been saved. If I use a cli vim, history IS saved and shows up later in
      Message 2 of 13 , Jan 31, 2009
      • 0 Attachment
        MacVim Snapshot 42
        MacOS 10.4.11

        When I quit MacVim then restart, the history has not been saved.

        If I use a cli vim, history IS saved and shows up later in MacVim.

        What am I missing? Is it a preference? They both use the same .vimrc.

        --
        Bill Muench
        Santa Cruz, California


        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_mac" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • björn
        ... Can you specify exactly what you mean by the history and how to tell whether it has been saved or not? Sorry if I m being obtuse, but I m not sure
        Message 3 of 13 , Jan 31, 2009
        • 0 Attachment
          2009/1/29 Bee:
          >
          > MacVim Snapshot 42
          > MacOS 10.4.11
          >
          > When I quit MacVim the restart, the history has not been saved.
          >
          > If I use a cli vim, history IS saved and shows up later in MacVim.
          >
          > What am I missing? Is it a preference? They both use the same .vimrc.

          Can you specify exactly what you mean by "the history" and how to tell
          whether it has been "saved" or not? Sorry if I'm being obtuse, but
          I'm not sure exactly what you are talking about. :?

          Björn

          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_mac" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        • Bee
          ... command line history See VIM REFERENCE MANUAL cmdline.txt --or-- ... When using MacVim or terminal vim, I can use up-arrow to recall previous commands.
          Message 4 of 13 , Feb 1 10:43 AM
          • 0 Attachment
            > Date: Sat, Jan 31 2009 10:16 am
            > 2009/1/29 Bee:
            >> MacVim Snapshot 42
            >> MacOS 10.4.11
            >>
            >> When I quit MacVim the restart, the history has not been saved.
            >>
            >> If I use a cli vim, history IS saved and shows up later in MacVim.
            >>
            >> What am I missing? Is it a preference? They both use the same .vimrc.
            >
            > Can you specify exactly what you mean by "the history" and how to tell
            > whether it has been "saved" or not? Sorry if I'm being obtuse, but
            > I'm not sure exactly what you are talking about. :?

            command line history

            See VIM REFERENCE MANUAL > cmdline.txt
            --or--
            :help :history
            :help q\:
            :help q\/

            When using MacVim or terminal vim, I can use up-arrow to recall
            previous commands. Also :history, q: or q/ will open a window showing
            the previous commands. All this works in MacVim or terminal vim in
            the current session.

            The problem is after quitting MacVim, and starting again the commands
            issued in the previous session are no longer there, ie NOT saved. The
            terminal vim does save those commands in the file named .viminfo

            Using :history, q: or q/ with MacVim will show the items
            in .viminfo but new commands issued in MacVim are not persistent
            across sessions.

            --
            Bill


            --~--~---------~--~----~------------~-------~--~----~
            You received this message from the "vim_mac" maillist.
            For more information, visit http://www.vim.org/maillist.php
            -~----------~----~----~----~------~----~------~--~---
          • björn
            ... This could be related to the Quickstart+viminfo issue Jonathon brought up in a previous post. Please disable Quickstart and see if that makes any
            Message 5 of 13 , Feb 1 11:16 AM
            • 0 Attachment
              2009/2/1 Bee:
              >
              > The problem is after quitting MacVim, and starting again the commands
              > issued in the previous session are no longer there, ie NOT saved. The
              > terminal vim does save those commands in the file named .viminfo
              >
              > Using :history, q: or q/ with MacVim will show the items
              > in .viminfo but new commands issued in MacVim are not persistent
              > across sessions.

              This could be related to the Quickstart+viminfo issue Jonathon brought
              up in a previous post. Please disable Quickstart and see if that
              makes any difference (or let me know if you weren't using Quickstart
              to begin with).

              Björn

              --~--~---------~--~----~------------~-------~--~----~
              You received this message from the "vim_mac" maillist.
              For more information, visit http://www.vim.org/maillist.php
              -~----------~----~----~----~------~----~------~--~---
            • Bee
              ... I do not have Quickstart enabled. So that is not the problem, I tried all combinations of: [ ] Launch Vim processes in a login shell [ ] Use ATSUI renderer
              Message 6 of 13 , Feb 2 6:55 AM
              • 0 Attachment
                > Date: Sun, Feb 1 2009 11:16 am From: björn
                > 2009/2/1 Bee:
                >> The problem is after quitting MacVim, and starting again the commands
                >> issued in the previous session are no longer there, ie NOT saved. The
                >> terminal vim does save those commands in the file named .viminfo
                >>
                >> Using :history, q: or q/ with MacVim will show the items
                >> in .viminfo but new commands issued in MacVim are not persistent
                >> across sessions.
                >
                > This could be related to the Quickstart+viminfo issue Jonathon brought
                > up in a previous post. Please disable Quickstart and see if that
                > makes any difference (or let me know if you weren't using Quickstart
                > to begin with).

                I do not have Quickstart enabled.

                So that is not the problem, I tried all combinations of:
                [ ] Launch Vim processes in a login shell
                [ ] Use ATSUI renderer
                [ ] Enable Quickstart

                And history was not saved.

                Then I was inspired...

                I used :qa! to close all the files I was using as tests and THEN
                command+q to quit MacVim, restarted MacVim and there it was... a
                history of the commands issued in the last session.

                It seems command+q does not update .viminfo

                --
                Bill Muench
                Santa Cruz, California


                --~--~---------~--~----~------------~-------~--~----~
                You received this message from the "vim_mac" maillist.
                For more information, visit http://www.vim.org/maillist.php
                -~----------~----~----~----~------~----~------~--~---
              • björn
                ... Ok, I ve found the problem and pushed a patch now. The fix will be in the next snapshot. Thanks for reporting this issue! Björn
                Message 7 of 13 , Feb 2 11:47 AM
                • 0 Attachment
                  2009/2/2 Bee:
                  >
                  > I used :qa! to close all the files I was using as tests and THEN
                  > command+q to quit MacVim, restarted MacVim and there it was... a
                  > history of the commands issued in the last session.
                  >
                  > It seems command+q does not update .viminfo

                  Ok, I've found the problem and pushed a patch now. The fix will be in
                  the next snapshot.

                  Thanks for reporting this issue!
                  Björn

                  --~--~---------~--~----~------------~-------~--~----~
                  You received this message from the "vim_mac" maillist.
                  For more information, visit http://www.vim.org/maillist.php
                  -~----------~----~----~----~------~----~------~--~---
                • dex
                  ... Hi. I m using the latest snapshot (42, vim ver 7.2.75) and I can confirm this issue still exists. -dex
                  Message 8 of 13 , Feb 19 1:03 PM
                  • 0 Attachment
                    > by björn-11 Feb 02, 2009; 02:47pm:
                    >
                    > 2009/2/2 Bee:
                    > > I used :qa! to close all the files I was using as tests and THEN
                    > > command+q to quit MacVim, restarted MacVim and there it was... a
                    > > history of the commands issued in the last session.
                    > > It seems command+q does not update .viminfo
                    >
                    > Ok, I've found the problem and pushed a patch now. The fix will be in
                    > the next snapshot.
                    > Thanks for reporting this issue!
                    > Björn

                    Hi. I'm using the latest snapshot (42, vim ver 7.2.75) and I can
                    confirm this issue still exists.

                    -dex

                    --~--~---------~--~----~------------~-------~--~----~
                    You received this message from the "vim_mac" maillist.
                    For more information, visit http://www.vim.org/maillist.php
                    -~----------~----~----~----~------~----~------~--~---
                  • björn
                    Hi Dex, ... I guess I should say which snapshot is the next at the time of typing. This particular bug was only fixed in snapshot 43 (released today).
                    Message 9 of 13 , Feb 20 5:51 AM
                    • 0 Attachment
                      Hi Dex,

                      2009/2/19 dex:
                      >
                      >> by björn-11 Feb 02, 2009; 02:47pm:
                      >>
                      >> 2009/2/2 Bee:
                      >> > I used :qa! to close all the files I was using as tests and THEN
                      >> > command+q to quit MacVim, restarted MacVim and there it was... a
                      >> > history of the commands issued in the last session.
                      >> > It seems command+q does not update .viminfo
                      >>
                      >> Ok, I've found the problem and pushed a patch now. The fix will be in
                      >> the next snapshot.
                      >> Thanks for reporting this issue!
                      >> Björn
                      >
                      > Hi. I'm using the latest snapshot (42, vim ver 7.2.75) and I can
                      > confirm this issue still exists.

                      I guess I should say which snapshot is the "next" at the time of
                      typing. This particular bug was only fixed in snapshot 43 (released
                      today).

                      Björn

                      --~--~---------~--~----~------------~-------~--~----~
                      You received this message from the "vim_mac" maillist.
                      For more information, visit http://www.vim.org/maillist.php
                      -~----------~----~----~----~------~----~------~--~---
                    • Nico Weber
                      ... No snapshot with the fix has been released yet. 43 will probably come out this weekend, so you just have to wait a few more days. Nico
                      Message 10 of 13 , Feb 20 6:53 AM
                      • 0 Attachment
                        >> 2009/2/2 Bee:
                        >>> I used :qa! to close all the files I was using as tests and THEN
                        >>> command+q to quit MacVim, restarted MacVim and there it was... a
                        >>> history of the commands issued in the last session.
                        >>> It seems command+q does not update .viminfo
                        >>
                        >> Ok, I've found the problem and pushed a patch now. The fix will be
                        >> in
                        >> the next snapshot.
                        >> Thanks for reporting this issue!
                        >> Björn
                        >
                        > Hi. I'm using the latest snapshot (42, vim ver 7.2.75) and I can
                        > confirm this issue still exists.

                        No snapshot with the fix has been released yet. 43 will probably come
                        out this weekend, so you just have to wait a few more days.

                        Nico
                        --~--~---------~--~----~------------~-------~--~----~
                        You received this message from the "vim_mac" maillist.
                        For more information, visit http://www.vim.org/maillist.php
                        -~----------~----~----~----~------~----~------~--~---
                      • ahso
                        ... Hi. I m using the latest snapshot (42, vim ver 7.2.75) and I can confirm this issue still exists. -dex
                        Message 11 of 13 , Feb 20 6:20 PM
                        • 0 Attachment
                          On Feb 2, 2:47 pm, björn <bjorn.winck...@...> wrote:
                          > 2009/2/2 Bee:
                          > > I used  :qa!  to close all the files I was using as tests and THEN
                          > > command+q to quit MacVim, restarted MacVim and there it was... a
                          > >historyof the commands issued in the last session.
                          > > It seems  command+q  does not update  .viminfo
                          >
                          > Ok, I've found the problem and pushed a patch now.  The fix will be in
                          > the next snapshot.
                          > Thanks for reporting this issue!
                          > Björn

                          Hi. I'm using the latest snapshot (42, vim ver 7.2.75) and I can
                          confirm this issue still exists.

                          -dex

                          --~--~---------~--~----~------------~-------~--~----~
                          You received this message from the "vim_mac" maillist.
                          For more information, visit http://www.vim.org/maillist.php
                          -~----------~----~----~----~------~----~------~--~---
                        • dex
                          ... Never mind on this. I figured out the problem. For some reason, my ~/.viminfo was set with root ownership instead of my user.
                          Message 12 of 13 , Mar 27, 2009
                          • 0 Attachment
                            On Thu, Feb 19, 2009 at 5:03 PM, dex <djdexter@...> wrote:
                            > Hi.  I'm using the latest snapshot (42, vim ver 7.2.75) and I can
                            > confirm this issue still exists.

                            Never mind on this. I figured out the problem. For some reason, my
                            ~/.viminfo was set with root ownership instead of my user.

                            --~--~---------~--~----~------------~-------~--~----~
                            You received this message from the "vim_mac" maillist.
                            For more information, visit http://www.vim.org/maillist.php
                            -~----------~----~----~----~------~----~------~--~---
                          • Brian McKee
                            ... You did sudo vi somethingorother before you ever launched vi regularly IIRC. I remember a couple of threads about this before, but that may have been the
                            Message 13 of 13 , Mar 27, 2009
                            • 0 Attachment
                              On Fri, Mar 27, 2009 at 11:05 AM, dex <djdexter@...> wrote:
                              >
                              > On Thu, Feb 19, 2009 at 5:03 PM, dex <djdexter@...> wrote:
                              >> Hi.  I'm using the latest snapshot (42, vim ver 7.2.75) and I can
                              >> confirm this issue still exists.
                              >
                              > Never mind on this.  I figured out the problem.  For some reason, my
                              > ~/.viminfo was set with root ownership instead of my user.
                              >

                              You did sudo vi somethingorother before you ever launched vi regularly IIRC.
                              I remember a couple of threads about this before, but that may have
                              been the Ubuntu mailing list.

                              Brian

                              --~--~---------~--~----~------------~-------~--~----~
                              You received this message from the "vim_mac" maillist.
                              For more information, visit http://www.vim.org/maillist.php
                              -~----------~----~----~----~------~----~------~--~---
                            Your message has been successfully submitted and would be delivered to recipients shortly.