Loading ...
Sorry, an error occurred while loading the content.
 

Re: building in python2.5 support

Expand Messages
  • björn
    ... Another thing to try (apart from Ben s suggestions) is to do a minimal configure, i.e. start with ./configure --enable-gui=macvim and add flags one at a
    Message 1 of 9 , Nov 10, 2008
      2008/11/10 Kevin Watters <kevinwatters@...>:
      >
      > I'm interested in Python 2.5 support. These instructions don't work
      > for me on Leopard--
      >
      > /configure --enable-perlinterp --enable-pyttyhoninterp --enable-
      > rubyinterp --enable-cscope --enable-gui=macvim --with-mac-arch=intel --
      > with-features=huge

      Another thing to try (apart from Ben's suggestions) is to do a minimal
      configure, i.e. start with

      ./configure --enable-gui=macvim

      and add flags one at a time to see which flag causes the error (or let
      us know if it appears even with that one flag only). In particular,
      the --with-mac-arch=intel flag should be left out as I'm pretty sure
      it has caused problems in the past (the build is native by default, so
      unless you are building a universal binary or are cross-compiling you
      should not use that flag).

      It has been reported on the Building wiki that it can be necessary to

      make reconfig

      before building as well. Does that help?

      Björn

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • Kevin Watters
      kevins-macbook:vim7 kevin$ ./configure --enable-gui=macvim; make results in sh: /Users/kevin/src/vim7/src/auto/osdef.sh: No such file or directory make[1]: ***
      Message 2 of 9 , Nov 10, 2008
        kevins-macbook:vim7 kevin$ ./configure --enable-gui=macvim; make

        results in

        sh: /Users/kevin/src/vim7/src/auto/osdef.sh: No such file or directory
        make[1]: *** [auto/osdef.h] Error 127
        make: *** [first] Error 2

        "make reconfig" after that did work, though. Weird that that is
        necessary.

        Thanks for the help guys.

        On Nov 10, 3:47 am, "björn" <bjorn.winck...@...> wrote:
        > 2008/11/10 Kevin Watters <kevinwatt...@...>:
        >
        >
        >
        > > I'm interested in Python 2.5 support. These instructions don't work
        > > for me on Leopard--
        >
        > > /configure --enable-perlinterp --enable-pyttyhoninterp --enable-
        > > rubyinterp --enable-cscope --enable-gui=macvim --with-mac-arch=intel --
        > > with-features=huge
        >
        > Another thing to try (apart from Ben's suggestions) is to do a minimal
        > configure, i.e. start with
        >
        > ./configure --enable-gui=macvim
        >
        > and add flags one at a time to see which flag causes the error (or let
        > us know if it appears even with that one flag only).  In particular,
        > the --with-mac-arch=intel flag should be left out as I'm pretty sure
        > it has caused problems in the past (the build is native by default, so
        > unless you are building a universal binary or are cross-compiling you
        > should not use that flag).
        >
        > It has been reported on the Building wiki that it can be necessary to
        >
        > make reconfig
        >
        > before building as well.  Does that help?
        >
        > Björn
        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_mac" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • Kevin Watters
        So my newly built macvim with ./configure --enable-pythoninterp --enable-cscope --enable-multibyte --enable-fontset --enable-gui=macvim is up an
        Message 3 of 9 , Nov 11, 2008
          So my newly built macvim with

          ./configure \
          --enable-pythoninterp \
          --enable-cscope \
          --enable-multibyte \
          --enable-fontset \
          --enable-gui=macvim

          is up an running...I made sure to close my non-dev MacVim. But in the
          dev build the fonts are all wacky, and there's no items in the menubar
          other than the mac supplied "Window" and whatever. No "Preferences"
          option for instance. Then I noticed in Apple-Tab that there was
          another MacVim icon...when I select that one, there /is/ a menubar
          with items, but no windows.

          Then I followed the instructions on http://code.google.com/p/macvim/wiki/Building
          and changed CFBundleIdentifier in Info.plist to MacVimDevel and reran
          xcodebuild...but still the same result.

          Anyone have any ideas?

          On Nov 10, 8:08 pm, Kevin Watters <kevinwatt...@...> wrote:
          > kevins-macbook:vim7 kevin$ ./configure --enable-gui=macvim; make
          >
          > results in
          >
          > sh: /Users/kevin/src/vim7/src/auto/osdef.sh: No such file or directory
          > make[1]: *** [auto/osdef.h] Error 127
          > make: *** [first] Error 2
          >
          > "make reconfig" after that did work, though. Weird that that is
          > necessary.
          >
          > Thanks for the help guys.
          >
          > On Nov 10, 3:47 am, "björn" <bjorn.winck...@...> wrote:
          >
          > > 2008/11/10 Kevin Watters <kevinwatt...@...>:
          >
          > > > I'm interested in Python 2.5 support. These instructions don't work
          > > > for me on Leopard--
          >
          > > > /configure --enable-perlinterp --enable-pyttyhoninterp --enable-
          > > > rubyinterp --enable-cscope --enable-gui=macvim --with-mac-arch=intel --
          > > > with-features=huge
          >
          > > Another thing to try (apart from Ben's suggestions) is to do a minimal
          > > configure, i.e. start with
          >
          > > ./configure --enable-gui=macvim
          >
          > > and add flags one at a time to see which flag causes the error (or let
          > > us know if it appears even with that one flag only).  In particular,
          > > the --with-mac-arch=intel flag should be left out as I'm pretty sure
          > > it has caused problems in the past (the build is native by default, so
          > > unless you are building a universal binary or are cross-compiling you
          > > should not use that flag).
          >
          > > It has been reported on the Building wiki that it can be necessary to
          >
          > > make reconfig
          >
          > > before building as well.  Does that help?
          >
          > > Björn
          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_mac" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        • Ches Martin
          ... I got this error and then realized I was running configure and make from the vim7 root and not the src directory -- I m guessing you realized the same
          Message 4 of 9 , Nov 12, 2008
            > On Nov 10, 8:08 pm, Kevin Watters <kevinwatt...@...> wrote:
            > > sh: /Users/kevin/src/vim7/src/auto/osdef.sh: No such file or directory
            > > make[1]: *** [auto/osdef.h] Error 127
            > > make: *** [first] Error 2

            I got this error and then realized I was running configure and make
            from the vim7 root and not the src directory -- I'm guessing you
            realized the same since you posted further progress :-)

            On Nov 12, 12:19 am, Kevin Watters <kevinwatt...@...> wrote:
            > So my newly built macvim with
            >
            > ./configure \
            > --enable-pythoninterp \
            > --enable-cscope \
            > --enable-multibyte \
            > --enable-fontset \
            > --enable-gui=macvim
            >
            > is up an running...I made sure to close my non-dev MacVim. But in the
            > dev build the fonts are all wacky...

            I believe the official distro is built without the fontset option
            since it's not configured for X anyway, so maybe try omitting it?

            I had build problems similar to Kevin's, though, too. Trying to build
            for Python 2.5 support in Leopard, including ruby support seems to be
            the source of the trouble (and I need ruby too :-)). Building with a
            similar set of config options:

            ./configure --enable-gui=macvim \
            --enable-pythoninterp \
            --enable-rubyinterp \
            --enable-cscope \
            --enable-multibyte

            make runs fine until:

            gcc -L. -arch ppc -arch i386 -L/usr/local/lib -o Vim objects/
            buffer.o objects/charset.o objects/diff.o objects/digraph.o objects/
            edit.o objects/eval.o objects/ex_cmds.o objects/ex_cmds2.o objects/
            ex_docmd.o objects/ex_eval.o objects/ex_getln.o objects/fileio.o
            objects/fold.o objects/getchar.o objects/hardcopy.o objects/hashtab.o
            objects/if_cscope.o objects/if_xcmdsrv.o objects/main.o objects/mark.o
            objects/memfile.o objects/memline.o objects/menu.o objects/message.o
            objects/misc1.o objects/misc2.o objects/move.o objects/mbyte.o objects/
            normal.o objects/ops.o objects/option.o objects/os_unix.o objects/
            pathdef.o objects/popupmnu.o objects/quickfix.o objects/regexp.o
            objects/screen.o objects/search.o objects/spell.o objects/syntax.o
            objects/tag.o objects/term.o objects/ui.o objects/undo.o objects/
            window.o objects/gui.o objects/pty.o objects/gui_macvim.o objects/
            MMBackend.o objects/MacVim.o objects/if_python.o objects/if_ruby.o
            objects/os_macosx.o objects/os_mac_conv.o objects/netbeans.o objects/
            version.o -framework Cocoa -framework Carbon -lncurses -liconv -
            lacl -framework Python -lruby -lpthread -ldl -lm
            ld: warning in objects/buffer.o, file is not of required architecture
            ld: warning in objects/charset.o, file is not of required architecture
            <more snipped>
            Undefined symbols for architecture ppc:
            "_main", referenced from:
            start in crt1.10.5.o
            ld: symbol(s) not found for architecture ppc
            collect2: ld returned 1 exit status
            ld: warning in /usr/local/lib/libacl.dylib, file is not of required
            architecture
            lipo: can't open input file: /var/folders/XL/XLdLIuAPFbeQaJOa-6n-ME++
            +TI/-Tmp-//ccehNUjM.out (No such file or directory)
            make: *** [Vim] Error 1

            If I run the the gcc command manually, removing the '-arch ppc' flag
            that showed up there, it completes, and I can then run make again and
            end up with a successful build.

            By the way, I had the same issues as Kevin when '--with-mac-
            arch=intel' was specified when configuring: it would complain about
            not finding a terminal library. Adding '--with-tlib=ncurses' resulted
            in the next generic error Kevin listed (though including the option is
            not an issue if the arch one is omitted). It was tempting to try
            forcing the arch when something was creeping in trying to add ppc
            flags ;-)

            --
            Ches Martin

            --~--~---------~--~----~------------~-------~--~----~
            You received this message from the "vim_mac" maillist.
            For more information, visit http://www.vim.org/maillist.php
            -~----------~----~----~----~------~----~------~--~---
          • Kevin Watters
            ... Actually I tried it without fontset first, and got the same result :/ If you ve got a working Py2.5 build Ches, are you willing to share? ;)
            Message 5 of 9 , Nov 12, 2008
              > I believe the official distro is built without the fontset option
              > since it's not configured for X anyway, so maybe try omitting it?

              Actually I tried it without fontset first, and got the same result :/

              If you've got a working Py2.5 build Ches, are you willing to share? ;)
              --~--~---------~--~----~------------~-------~--~----~
              You received this message from the "vim_mac" maillist.
              For more information, visit http://www.vim.org/maillist.php
              -~----------~----~----~----~------~----~------~--~---
            • Jason Foreman
              ... You may need to: export MACOSX_DEPLOYMENT_TARGET=10.4 I typically change the configure script to use the 10.5 SDK instead of 10.4u when on Leopard. ...
              Message 6 of 9 , Nov 12, 2008
                On Wed, Nov 12, 2008 at 4:17 AM, Ches Martin <ches.martin@...> wrote:

                > Undefined symbols for architecture ppc:
                > "_main", referenced from:
                > start in crt1.10.5.o
                > ld: symbol(s) not found for architecture ppc

                > If I run the the gcc command manually, removing the '-arch ppc' flag
                > that showed up there, it completes, and I can then run make again and
                > end up with a successful build.

                You may need to:

                export MACOSX_DEPLOYMENT_TARGET=10.4

                I typically change the configure script to use the 10.5 SDK instead of
                10.4u when on Leopard.

                >
                > By the way, I had the same issues as Kevin when '--with-mac-
                > arch=intel' was specified when configuring: it would complain about
                > not finding a terminal library. Adding '--with-tlib=ncurses' resulted
                > in the next generic error Kevin listed (though including the option is
                > not an issue if the arch one is omitted). It was tempting to try
                > forcing the arch when something was creeping in trying to add ppc
                > flags ;-)

                "--enable-rubyinterp" is the culprit here. The configure script runs
                Ruby to query the LDFLAGS with which it was built. It gets both
                arches in return and tries to use them. Either build a universal Vim
                (--with-mac-arch=both), or you'll have to edit the config (config.mk?)
                before building to remove the extraneous "--arch ppc".

                Long term, the Vim configure scripts need fixed for the Mac to remove
                the arch flags from Ruby's LDFLAGS. I believe this is already on the
                Vim todo list.


                Jason

                --~--~---------~--~----~------------~-------~--~----~
                You received this message from the "vim_mac" maillist.
                For more information, visit http://www.vim.org/maillist.php
                -~----------~----~----~----~------~----~------~--~---
              • björn
                ... Mulitbyte is implied by --enable-gui=macvim so you can leave it out. ... This is not supported so leave it out. ... This sounds like some problem with the
                Message 7 of 9 , Nov 12, 2008
                  2008/11/12 Kevin Watters <kevinwatters@...>:
                  >
                  > So my newly built macvim with
                  >
                  > --enable-multibyte \

                  Mulitbyte is implied by --enable-gui=macvim so you can leave it out.

                  > --enable-fontset \

                  This is not supported so leave it out.

                  >
                  > is up an running...I made sure to close my non-dev MacVim. But in the
                  > dev build the fonts are all wacky, and there's no items in the menubar
                  > other than the mac supplied "Window" and whatever. No "Preferences"
                  > option for instance. Then I noticed in Apple-Tab that there was
                  > another MacVim icon...when I select that one, there /is/ a menubar
                  > with items, but no windows.
                  >
                  > Then I followed the instructions on http://code.google.com/p/macvim/wiki/Building
                  > and changed CFBundleIdentifier in Info.plist to MacVimDevel and reran
                  > xcodebuild...but still the same result.
                  >
                  > Anyone have any ideas?

                  This sounds like some problem with the Vim binary. Try to rebuild
                  first, i.e. in src/ type "make clean; make", then "cd MacVim" followed
                  by "xcodebuild clean" and finally "xcodebuild". When it finishes
                  building, type "open build/Release/MacVim.app".

                  If that does not work, please do the following:

                  1. After "make" (and still in the src/ directory), type "./Vim",
                  you'll get a few errors which you can ignore, once in Vim type ":ver"
                  and let me know what it says.

                  2. Are there any errors logged to the console? Open up Console.app to find out.

                  Björn

                  --~--~---------~--~----~------------~-------~--~----~
                  You received this message from the "vim_mac" maillist.
                  For more information, visit http://www.vim.org/maillist.php
                  -~----------~----~----~----~------~----~------~--~---
                Your message has been successfully submitted and would be delivered to recipients shortly.