Loading ...
Sorry, an error occurred while loading the content.

Re: Backspace and indentation

Expand Messages
  • Tobia Conforto
    ... I must have either enabled expandtab or disabled smarttab. If you d rather have actual tab characters, then :set noexpandtab, otherwise if you want space
    Message 1 of 2 , Nov 7, 2008
    • 0 Attachment
      > Until some days ago, when I pressed backspace on the beginning of an
      > indented line, the indentation would be reduced by one level, the
      > opposite behavior was for tab. Now, the tab key works fine, but the
      > backspace key only deletes one space instead of the whole indent
      > level.

      I must have either enabled expandtab or disabled smarttab.

      If you'd rather have actual tab characters, then :set noexpandtab,
      otherwise if you want space characters, but with the ability to
      backspace through a "whole tab", then :set smarttab

      Other useful options are tabwidth and shiftwidth.


      Tobia

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    Your message has been successfully submitted and would be delivered to recipients shortly.