Loading ...
Sorry, an error occurred while loading the content.

Re: compiling vim from source on Leopard

Expand Messages
  • Ben Schmidt
    ... Yuck. This is one of those things that I d probably be able to track down if I had the commandline in front of me, but is really hard to do by email. One
    Message 1 of 3 , Oct 22, 2008
    • 0 Attachment
      > Has anyone successfully compiled Vim 7.0 on OS X 10.5.5 using the
      > --disable-darwin and --enable-gui=no options? I'm running into some
      > kind of weird issues with a system header.
      > I'm downloading 7.0.243 from the sourceforge svn repository (I'm using
      > 7.0 instead of 7.2 because I have a patch that's only for 7.0). For
      > now, I'm not patching the source - just trying to get a text-only
      > (non-gui) version up and running. I'm using the following configure line:
      >
      > ./configure \
      > --disable-darwin \
      > --prefix=/opt/vim-7.0.243 \
      > --enable-pythoninterp \
      > --enable-gui=no \
      > --with-tlib=ncurses \
      > --disable-gpm \
      > --enable-multibyte
      >
      > Which works just fine. Next, I change into the src/ directory and run
      > make (using Apple's 4.0.1 gcc compilers, from the Xcode tools), and I
      > immediately get this error:
      >
      > mkdir objects
      > CC="gcc -Iproto -DHAVE_CONFIG_H -I/usr/X11/include
      > -I/System/Library/Frameworks/Python.framework/Versions/2.5/include/python2.5
      > " srcdir=. sh ./osdef.sh
      > gcc -c -I. -Iproto -DHAVE_CONFIG_H -g -O -I/usr/X11/include
      > -I/System/Library/Frameworks/Python.framework/Versions/2.5/include/python2.5
      > -o objects/buffer.o buffer.c
      > In file included from os_unix.h:28,
      > from vim.h:242,
      > from buffer.c:28:
      > /usr/include/sys/types.h:135: error: two or more data types in
      > declaration specifiers
      > make: *** [objects/buffer.o] Error 1
      >
      > And the line in /usr/include/sys/types.h that creates the issue is:
      >
      > 134 #ifndef _INO_T
      > 135 typedef __darwin_ino_t ino_t; /* inode number */
      > 136 #define _INO_T
      > 137 #endif
      >
      > If I remove the --disable-darwin option in my configure line, I have a
      > problem with the same file (/usr/include/types.h) at the same place. It
      > seems like there's a Darwin issue here, despite the --disable-darwin
      > flag. But I'm feeling a little clueless, as I don't have much C++
      > experience (I have a vague idea of what this error means but no idea how
      > I might go about fixing it). I've also tried Fink's 4.3 gcc, and I run
      > into the same issue. Might this be related to Any information or help
      > would be greatly appreciated. Please let me know if there's any
      > additional information that would be helpful.

      Yuck. This is one of those things that I'd probably be able to track
      down if I had the commandline in front of me, but is really hard to do
      by email. One thought...does adding --without-x to your configure
      command help at all? Otherwise, perhaps the next most useful piece of
      output would be from

      gcc -E -I. -Iproto -DHAVE_CONFIG_H -g -O -I/usr/X11/include
      -I/System/Library/Frameworks/Python.framework/Versions/2.5/include/python2.5
      -o buffer.cpp buffer.c

      I.e. preprocess (-E) buffer.c instead of compile it (-c), and put the
      output in buffer.cpp (-o). Looking at the preprocessor output along with
      the error message it's more likely we can spot the
      problem...hopefully...

      Though may I ask what your 7.0-only patch is? Is it publicly available?
      Depending how extensive it is, it may be easier to update that to Vim
      7.2 than solve the compilation problems. Of course, this assumes Vim 7.2
      doesn't share the same problems...but I suppose it doesn't, as MacVim is
      now compiled on Leopard.

      Ben.




      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_mac" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    Your message has been successfully submitted and would be delivered to recipients shortly.